openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wolfgang Jäth <jawo.ml.hams...@arcor.de>
Subject Re: Zell-Bezüge - Brett vor'm Kopf :/
Date Sat, 28 Feb 2015 15:29:05 GMT
Am 28.02.2015 um 15:07 schrieb Semmel:
> 
> Moin junx & medlz,  ;)
> 
> ich beiße mir gerade die Zähne an einer Tabelle aus und habe aktuell ein 
> richtig dickes Brett vor'm Kopf.
> 
> Ich habe eine Tabelle (A1 bis G44) und die Werte werden in der 
> Waagerechten nacheinander eingetragen - die ersten Werte in Zeile 5, 
> dann Zeile 6, usw..
> Es ist aber nicht zwingend, dass auch alle Zeilen bis zur letzten (Zeile 
> 44) ausgefüllt werden (müssen). Das bedeutet, dass in dem einen 
> Tabellenblatt die letzte ausgefüllte Zeile die Zeile 20 ist und im 
> nächsten Blatt ist es vielleicht die Zeile 35.
> 
> Jetzt benötige ich den letzten und den vorletzten Wert aus Spalte B, um 
> damit weitere Operationen durchführen zu können.
> 
> Wer kann helfen, das Brett vor meinem Kopf zu entfernen?  ;)

Wenn die Werte lückenlos eingetragen werden, kannst Du den letzten
vorhandenen Wert relativ einfach mit

|  =INDEX(B1:B44;ANZAHL(B1:B44))

ermitteln. Andernfalls musst Du mit einer Hilfsspalte arbeiten, in der
Du von /hinten/ her den Index der 'ersten' (aka hintersten) belegten
Zeile nach vorne reichst, und dann dort abgreifst:

Zelle H1 (bzw. ganze Spalte H):
|  =WENN(H2<>"";H2;WENN(B1<>"";ZEILE();""))

Zugriff:
|  =INDEX(B1:B44;H1)

Wolfgang
-- 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message