openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Habbe <...@habbe.de>
Subject Re: Calc, gruppieren von Zeilen
Date Thu, 25 Sep 2014 14:12:59 GMT
Hallo Wolfgang,

vielen Dank.
Mit SummeWenn habe ich sogar schon gearbeitet, manchmal muss man nur
einen Anschubser bekommen. ;-)


Grüße von
Michael


Am 25.09.2014 um 06:55 schrieb Wolfgang Jäth:
> Am 24.09.2014 um 19:05 schrieb Michael Habbe:
>> Hallo Listengemeinde.
>>
>> Bin mir nicht sicher, ob das, was ich vorhabe, mit Calc funktioniert.
>> (Per SQL wäre es kein Ding.)
>>
>> Ich habe eine Tabelle mit den Spalten Datum, Uhrzeit, Kcal und Minuten.
>> Ich möchte nach Datum gruppieren und die Spalten Kcal und Minuten
>> summieren, um daraus ein Diagramm zu erstellen.
>>
>> Hat jemand eine Idee, wie ich aus den bestehenden Daten eine neue
>> Tabelle forme?
>>
>>
>> Danke im Voraus
>> Michael
>>
>>
>> Hier noch ein paar Beispieldaten:
>>
>> Datum    Uhrzeit    Minuten  Kcal
>> 12.03.2014    19:41    62     772
>> 12.03.2014    20:50    52     835
>> 13.03.2014    18:02    58     624
>> 13.03.2014    19:03    49     677
>> 19.03.2014    19:39    59     765
>> 19.03.2014    20:44    44     634
>> 20.03.2014    18:11    50     637
>> 20.03.2014    19:04    37     533
>> 26.03.2014    19:36    67     845
>> 26.03.2014    20:46    44     657
>> 27.03.2014    18:14    53     585
>> 27.03.2014    19:07    42     570
>> 02.04.2014    19:40    64     788
>> 02.04.2014    20:51    44     653
>> 03.04.2014    18:03    61     578
>> 03.04.2014    19:09    38     508
> Spalte 1:
>
> 1	Datum	
> 2	=T1.A2	
> 3	=A2+1	
> 4	=A3+1	
> 	   :
>
> Spalte 2 (und entsprechend Spalte 3)
>
> 1	Minuten
> 2	=WENN(SUMMEWENN(Tabelle1.$A$2:$A$17;$A2;Tabelle1.$C$2:$C$17)=0; "";
> SUMMEWENN(Tabelle1.$A$2:$A$17;$A2;Tabelle1.$C$2:$C$17))
> 3	   :
>
> Die kompliziert erscheinende Formel (in Wirklichkeit ist es ja nur
> zweimal die selbe Berechnung) liegt daran, dass ohne dieses WENN der
> Wert '0' in den Zeilen ohne Daten stehen würde, was dann aus dem Graphen
> einen Sägezahn machen würde. So jedoch steht ein Leerstring darin, und
> der Graph erkennt diesen Bereich als ohne Daten.
>
> BTW kannst Du die Darstellung des Graphen noch je nach Wunsch noch
> anpassen (z. B. kannst Du bei einem Liniengraphen mit "Doppelklick auf
> den Graphen => Rechtsklick auf eine Datenreihe => Datenreihe formatieren
> => Optionen" entscheiden, ob die datenfreien Lücken als Lücken bleiben,
> oder die Linie fortgesetzt werden soll, u. v. m.).
>
> Wolfgang



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message