openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wolfgang Jäth <jawo.ml.hams...@arcor.de>
Subject Re: Calc-Formel-Wert
Date Mon, 29 Oct 2012 08:29:01 GMT
Am 28.10.2012 18:49, schrieb avirbhav sprotte:
> 
> in der folgenden Formel:
>  
> =SUMMEWENN(D25:D42;$B15;E25:E42)
> 
> repräsentiert der Ausdruck $B15 z.B. den Wert 4, der z.B. von 4,1 bis
> 4,9 reicht!

Sorry, ich versehe nicht; was verstehst Du unter 'repräsentiert'? *Was*
*genau* steht in der Zelle? Ein Text? Ein Wert? Mit oder ohne
unterdrückten Nachkommastellen? '4'? '4,x'?

Btw: Ein Wert (z. b. '4') repräsentiert nur genau *einen* Wert (in dem
Fall '4,00000000') und keinen Wertebereich wie etwa '4,-4,9'.

> D.h. ich möchte eine Summe aus der Spalte E haben, die für alle Werte
> aus der Spalte D gilt, die von 4,1 bis 4,9 reichen.

Also wenn ich Dich richtig verste^Winterpretiere, dann steht in §B15 ein
ganzzahliger Wert (kein text o. ä.), und Du möchtest jetzt alle Einträge
in Spalte E aufsummiert haben, die in der Spalte D mit diesem Wert
beginnen. Also größer/gleich diesem Wert und kleiner der nächstgrößeren
Ganzen Zahl ist. Ist das soweit richtig?

D. H. Du willst *mehrere* Bedingungen (konkret zwei) abfragen, nämlich
ob größer/gleich 4,1 und kleiner/gleich 4,9; das geht nicht mit
SUMMEWENN, sondern nur mit SUMMEPRODUKT:

| =SUMMEPRODUKT(E25:E42;D25:D42>=$B$15;D25:D42<($B$15+1))

D. h. Du summierst die Formel 'E * (D>=$B§15) * (D<($B$15+1))' auf,
wobei die beiden hinteren Faktoren Wahrheitswerte sind, und 0 oder 1
ergeben, je nachdem, ob sie zutreffen oder nicht.


Wolfgang
-- 


---------------------------------------------------------------------

Abmelden von der Mailingliste: ooo-users-de-unsubscribe@incubator.apache.org 
Informationen: http://www.openoffice.org/de/

To unsubscribe, e-mail: ooo-users-de-unsubscribe@incubator.apache.org
For additional commands, e-mail: ooo-users-de-help@incubator.apache.org


Mime
View raw message