openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regina Henschel <rb.hensc...@t-online.de>
Subject Re: Inkrement bei automatischne Ausfüllen
Date Wed, 04 Apr 2012 18:41:17 GMT
Hallo Hans-Martin,

jetzt kommt eine etwas längere Antwort.

Hans-Martin Rappold schrieb:
> Hallo Regina,
>
> dann habe ich die Formel wohl nicht ganz verstanden.
> Gebildet werden soll der Mittelwert aus jeweils 10 Zellen einer Zeile
> (10-jähriges Mittel) fur jeden Monat(Zeile).

??? Haben die Spalten und Zeilen aussagekräftige 
Spaltenköpfe/Zeilenköpfe? Dann wäre es ganz nützlich, wenn du mir einmal 
eine solche Tabelle schickst. Ich kann mir immernoch nicht vorstellen 
wie sie aufgebaut ist. (Ganz abgesehen davon kann ich mir nicht 
vorstellen wozu du 10-jährige Mittel benötigst, obwohl man sich in der 
Klimauntersuchung auf 30-jährige Mittel geeinigt hat.)

Aber nehmen wir mal an, dass deine Daten in der Zeile 2 stehen, 
beispielsweise von A2, B2, C2, ... bis Z2.
Der Mittelwert der ersten 10 Zellen wäre dann
=MITTELWERT(A2:J2)
der Mittelwert der zweiten 10 Zellen wäre dann
=MITTELWERT(K2:T2)

Die Funktion VERSCHIEBUNG erlaubt es einen Zellbezug dadurch anzugeben, 
dass man eine Bezugszelle und die Verschiebung angibt.
Bezugszelle ist A2. Die Verschiebung wäre 0 Zeilen nach unten und 10 
Spalten nach rechts. ALso für das erste 10er-Pack VERSCHIEBUNG(A2;0;0) 
für das zweite 10er-Pack VERSCHIEBUNG(A2;0;10) und für das dritte 
10er-Pack VERSCHIEBUNG(A2;0;20).

Weil du deine Formeln aber nicht einzeln mit Konstanten schreiben 
willst, sondern durch Kopieren vervielfachen willst, muss man nun die 
Verschiebung aus der Position der Formel berechnen. Wenn deine 
10-Jahres-Mittel alle nebeneinander stehen sollen, kannst du dafür die 
Spalte der Formel benutzen.

Steht die Formel für die ersten 10 Zellen in Spalte AH (das ist 34) dann 
wäre die Verschiebung 0;(SPALTE()-34)*10. Denn das löst sich beim ersten 
10er-Pack zu 0;(34-34)*10 also 0;0 auf. Die Formel für das zweite 
10er-Pack steht dann in AI (das ist 35) und die Verschiebung löst sich 
dann zu 0;(35-34)*10 also 0;10 auf.

Schreibst du nun statt der einzelnen Zelle A2 einen Bereich bei 
VERSCHIEBUNG hinein, bezieht sich die Verschiebung auf diesen gesamten 
Bereich. Du kannst statt dessen auch vorn die einzelne Zelle stehen 
lassen und als vierten und fünften Parameter angeben, wieviele Zeilen 
und Spalten von der Verschiebung betroffen sein sollen, wie groß also 
das Rechteck ist, das die Funktion VERSCHIEBUNG liefert. Für das erste 
10er-Pack ist es dann VERSCHIEBUNG(A2;0;0;1;10) und für das zweite 
10er-Pack ist es dann VERSCHIEBUNG(A2;0;10;1;10) bzw allgemein dann
VERSCHIEBUNG(A2;0;(SPALTE()-34)*10;1;10). Die Größe des Rechtecks ändert 
sich nicht.

Die Funktion VERSCHIEBUNG liefert also einen rechteckigen Bereich von 
Zellen als Zwischenergebnis. Und auf dieses Rechteck wird dann 
MITTELWERT angewendet.

Wenn du nun die Formel durch Kopieren vervielfältigen willst, musst du 
überlegen, welcher Teil der Zelladressen sich nicht ändert. Dieser Teil 
erhält dann ein $-Zeichen davor. Welche Teile so als absolut 
gekennzeichnet werden, erkennt man meist ganz gut, wenn man die Formeln 
mal so aufschreibt, wie sie lauten müssten, wenn man sie komplett von 
Hand einträgt.

Ich hoffe, das hilft jetzt ein bisschen weiter.

Mit freundlichen Grüßen
Regina





---------------------------------------------------------------------

Abmelden von der Mailingliste: ooo-users-de-unsubscribe@incubator.apache.org 
Informationen: http://www.openoffice.org/de/

To unsubscribe, e-mail: ooo-users-de-unsubscribe@incubator.apache.org
For additional commands, e-mail: ooo-users-de-help@incubator.apache.org


Mime
View raw message