openoffice-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Issue 125578] New: soffice.exe instances hang when started by program running by windows task scheduler in background
Date Thu, 04 Sep 2014 14:04:58 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=125578

          Issue ID: 125578
        Issue Type: DEFECT
           Summary: soffice.exe instances hang when started by program
                    running by windows task scheduler in background
           Product: General
           Version: 4.0.0
          Hardware: All
                OS: Windows 7
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: code
          Assignee: issues@openoffice.apache.org
          Reporter: matafagafo@yahoo.com

Created attachment 83928
  --> https://issues.apache.org/ooo/attachment.cgi?id=83928&action=edit
Simple VBS script file to reproduce the issue

I'm facing some odd problem running some scripts that use OO to convert files,
when this scripts are running by Windows task scheduler after upgrade from OO
3.4.1 to OO 4.0.0.
We did a lot of tests and figured out that the problem happens when we set the 
"Run whether user is logged or not" option in the task scheduler.
With the "Run whether user is logged or not" on, the soffice.exe and
soffice.bin are started but they appears to not responding to script.

I wrote a simple sample VBS script code (attached) that basically just create a
ServiceManager and record the results in a log file, bellow the sequence of
steps to show the problem:
1 save my script file in some temp directory
2 check/correct the log file path
3 create a simple task in Windows Task scheduler to run the script saved in
step 1, be sure that the option "Run only when user is logged on" is on (it's
the the default configuration for a new task)
4 run the task
5 look at the log file, the message "All OK!" shows that the ServiceManager
instance creation was successful
6 update the task created in step 3, and set "Run whether user is logged or
not" to on
7 run the task
8 look at the log file, the message "An error occurred" shows that the
ServiceManager instance creation was NOT successful !

Running the task with "Run whether user is logged or not" several times result
in many instances of soffice.exe and soffice.bin stuck in the system

We need use the "Run whether user is logged or not" option because we need to
run this scripts on a server.
I can reproduce this behaviour in many computers running Windows 7 32 and 64
bits and Windows 2008 R2
I can reproduce the problem not only with VBS scripts, it happens using other
programing languages too. 

The problem DON'T happens with OO 3.4.1, it begins with OO 4.0.0+

-- 
You are receiving this mail because:
You are the assignee for the issue.
You are watching all issue changes.

Mime
View raw message