openoffice-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Issue 105243] PDF file size increased between OOo 3.1 and 3.1.1 when using "Losless compression"
Date Fri, 27 Jun 2014 21:54:58 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=105243

Ariel Constenla-Haile <arielch@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |CLOSED

--- Comment #31 from Ariel Constenla-Haile <arielch@apache.org> ---
(In reply to henrik_roseno from comment #30)
> Try exporting the HTML-doc in this ZIP-archive to PDF
> 
> Hi
> 
> Right now I can only reproduce the error when working with an HTML-file (in
> OOo 4.1.0). 

I can reproduce the bug with OOo 3.0.0 and the current nightly build from the
build bot.

> So I have attached the HTML-file and its image-files. All in a
> ZIP-archive. 

Note that your html file has

<base href="http://www.transformation.dk/chemtrails/">

with this, OpenOffice will fetch all the images from that site, not relative to
the HTML file.

> When I PDF-export it with "Lossless compression" the result is
> 4.5MB.

I get the same result.
The bug is that the images are linked.
When exporting to PDF, the original JPG image format is not preserved.

As a workaround, save the HTML file as ODT.
With the ODT, go to menu Edit - Links, and break all the links.

I get an ODT with 565 Kb; this file, exported to PDF, generates a 673 Kb PDF,
with all the original JPG files retained. 

In short, this is another bug, and is not a regression (happens the same in
3.0.0 and 4.1.0

> The "Lossless compression" PDF-file
> is even considerably smaller than the "JPEG compression - quality 100%"
> PDF-file!

This might be yet another bug.

-- 
You are receiving this mail because:
You are on the CC list for the issue.
You are watching all issue changes.

Mime
View raw message