openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Seidel <matthias.sei...@hamburg.de>
Subject Re: WikiPublisher extension (was Re: servlet-api.jar)
Date Fri, 13 Oct 2017 18:43:29 GMT
Am 06.10.2017 um 03:40 schrieb Don Lewis:

> I think I understand what is going wrong with WikiPublisher on Windows.
> The FreeBSD port sets the --with-system-apache-commons=yes, and lists
> the all the commons-*.jar files as dependencies, so when AOO is
> installed on a machine, the commons-*.jar files will also get installed
> because they are dependencies.
>
> On Windows, and probably Linux and Mac, we don't set
> --with-system-apache-commons=yes.  Instead we rely on bootstrap to
> download the source for these .jar files and we build the actual .jar
> files during the build.  Only commons-lang.jar is needed for the base
> package and it gets packaged along with the rest of the AOO files.  The
> WikiPublisher extension also requires commons-codec.jar,
> commons-httpclient.jar, and commons-logging.jar, but these don't get
> packaged along with the AOO files, and they also don't get packaged into
> the .oxt file for the extension.  The only .jar files bundled with the
> extension are help.jar and mediawiki.jar.

Do we have a bug # for this longstanding issue? We still advertise this
feature but it is not working since 4.1.0 (?).

I really would love to have it back working in 4.2.0.

Matthias

>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>



Mime
View raw message