openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Jagielski"<...@apache.org>
Subject Re: Expat 2.2.3 and Windows woes
Date Fri, 04 Aug 2017 13:54:57 GMT
Worse case scenario I have an ugly, nasty hack: simply append loadlibrary to the end of the
xmlparse.c file... Unless someone has other ideas, we may be forced to try that.

On 2017-08-04 08:57, Matthias Seidel <matthias.seidel@hamburg.de> wrote: 
> Am 04.08.2017 um 13:30 schrieb Jim Jagielski:
> > Ahh.. so yeah, either the obj file for loadlibrary is not being built or else its
not being linked in. At this point we need someone who knows the Windows dev environment to
help out on what needs to be done... I am guessing it is our makefile.mk file that needs to
be updated??
> 
> I hope someone can jump in here...
> 
> Meanwhile my build (based on Rev. 1803945 with reverted expat2.2.1)
> finished successful.
> 
> >
> > On 2017-08-04 01:17, Matthias Seidel <matthias.seidel@hamburg.de> wrote: 
> >> Am 04.08.2017 um 00:10 schrieb Matthias Seidel:
> >>> I forced a build from our buildbot:
> >>> https://ci.apache.org/builders/aoo-w741x/builds/155
> >>>
> >>> Maybe those logs are telling something...
> >> https://ci.apache.org/projects/openoffice/buildlogs/win41x/log/wntmsci12.pro.build.html
> >>
> >> "error LNK2019: unresolved external symbol __Expat_LoadLibrary
> >> referenced in function _writeRandomBytes_RtlGenRandom
> >> ../../wntmsci12.pro/bin/sax.uno.dll : fatal error LNK1120: 1 unresolved
> >> externals"
> >>
> >>> Additionally I reverted my SVN back to expat2.2.1 and will let it
> >>> (hopefully) build over night.
> >>> For me it is time to go to bed... ;-)
> >> My "personal" build is still running, so I got past that point by
> >> reverting to expat2.2.1.
> >>
> >>>
> >>> Am 03.08.2017 um 23:50 schrieb Jim Jagielski:
> >>>> Is there any way to get a more verbose build output?
> >>>>
> >>>> I am totally in-the-dark re: Windows build environs, so I'm
> >>>> just spit balling on possible fixes ;)
> >>>>
> >>>>> On Aug 3, 2017, at 5:44 PM, Matthias Seidel <matthias.seidel@hamburg.de>
wrote:
> >>>>>
> >>>>> Hi Jim,
> >>>>>
> >>>>> I applied your patch but now it stops at:
> >>>>>
> >>>>> ---
> >>>>>
> >>>>> 1 module(s):
> >>>>>        expat
> >>>>> need(s) to be rebuilt
> >>>>>
> >>>>> Reason(s):
> >>>>>
> >>>>> ERROR: error 65280 occurred while making
> >>>>> /cygdrive/c/Source/aoo-414/main/expat
> >>>>>
> >>>>> When you have fixed the errors in that module you can resume the
build
> >>>>> by running:
> >>>>>
> >>>>>        build --from expat
> >>>>>
> >>>>> ---
> >>>>>
> >>>>>
> >>>>> Am 03.08.2017 um 22:34 schrieb Jim Jagielski:
> >>>>>> Hrm. Matthias is reporting that with expat 2.2.3, that Windows
is
> >>>>>> no longer building....
> >>>>>>
> >>>>>> Some ideas:
> >>>>>>
> >>>>>>  o expat 2.2.3 requires c99
> >>>>>>  o expat 2.2.3 requires loadlibrary.obj be built
> >>>>>>    and it doesn't look like our expat-2.2.3.patch
> >>>>>>    file, which creates makefile.mk does that.
> >>>>>>
> >>>>>> Can anyone check and correct?
> >>>>>>
> >>>>>> tia
> >>>>>>
> >>>>>> ---------------------------------------------------------------------
> >>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> >>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
> >>>>>>
> >>>>>>
> >>>> ---------------------------------------------------------------------
> >>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> >>>> For additional commands, e-mail: dev-help@openoffice.apache.org
> >>>>
> >>
> >>
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> > For additional commands, e-mail: dev-help@openoffice.apache.org
> >
> 
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message