openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damjan Jovanovic <dam...@apache.org>
Subject Re: Building OO
Date Sun, 13 Aug 2017 08:57:59 GMT
:(.

gmake version?

If you go into main/udm and run "build", do you still get that error?

Damjan


On Sun, Aug 13, 2017 at 10:44 AM, Matthias Seidel <
matthias.seidel@hamburg.de> wrote:

> Yes, they are...
>
> precomp.h and cr_html.hxx are checked out every time. And every time we
> get the same error.
>
> It is reproducible.
>
>
> Am 11.08.2017 um 01:41 schrieb Don Lewis:
> > Strange, those files should be part of the checked-out source.
> >
> > On 10 Aug, Matthias Seidel wrote:
> >> I could now get past the gtest error by disabling unit tests
> >> (--disable-unit-tests).
> >>
> >> Errors in udm and xml2cmp remain:
> >>
> >> make: *** No rule to make target '/cygdrive/e/slave14/aoo-win7/
> build/main/udm/source/inc/precomp.h
> >> ', needed by '/cygdrive/e/slave14/aoo-win7/build/main/solver/420/
> wntmsci12.pro/workdir/CxxObject/udm/source/html/htmlitem.o'.  Stop.
> >> dmake:  Error code 2, while making 'all'
> >>
> >> make: *** No rule to make target '/cygdrive/e/slave14/aoo-win7/
> build/main/xml2cmp/source/xcd/cr_html.hxx
> >> ', needed by '/cygdrive/e/slave14/aoo-win7/build/main/solver/420/
> wntmsci12.pro/workdir/CxxObject/xml2cmp/source/xcd/cr_html.o'.  Stop.
> >> dmake:  Error code 2, while making 'all'
> >>
> >>
> >> Am 09.08.2017 um 12:35 schrieb Matthias Seidel:
> >>> The buildbot does a complete checkout every day...
> >>>
> >>> gtest throws an error, before(?) udm and xml2cmp:
> >>>
> >>> *** gb_Deliver_deliver: file does not exist in solver, and cannot be
> >>> delivered:
> >>> /cygdrive/e/slave14/aoo-win7/build/main/solver/420/wntmsci1
> 2.pro/inc/gtest/gtest.h
> >>>
> >>> (Note: The buildbot is still called aoo-win7, but Infra updated the
> >>> system to Windows 10 64bit. AOO 4.1.4 is building without problems)
> >>>
> >>>
> >>> Am 09.08.2017 um 12:12 schrieb Don Lewis:
> >>>> The udm and xml2cmp errors appear to be incomplete source checkouts.
> >>>>
> >>>> On  9 Aug, Matthias Seidel wrote:
> >>>>> I see similar errors in our buildbot for trunk (system: Windows
10
> 64bit):
> >>>>>
> >>>>> https://ci.apache.org/projects/openoffice/buildlogs/
> win/log/wntmsci12.pro.build.html
> >>>>>
> >>>>> The buildbot builds once a day. If some requirements have to be
> changed
> >>>>> drop me a line and I will edit the config accordingly.
> >>>>>
> >>>>> Regards, Matthias
> >>>>>
> >>>>>
> >>>>> Am 20.07.2017 um 04:56 schrieb Yemelyanenko Fyodor:
> >>>>>> I?ve took another try to build OO on W7 x32
> >>>>>> But got same errors, as on W8 x64
> >>>>>> May be I missed some prerequisites?
> >>>>>>
> >>>>>> Errors are in modules gtest, xml2cmp, salhelper, udm
> >>>>>> Cygwin seems to have bug on Windows as it only  shows full error
> text when resized to some size? So path to missed file is not full.
> >>>>>> The gtest.h is in place, why gb_Deliver_deliver cannot find
it?
> >>>>>>
> >>>>>> $ build --all:gtest
> >>>>>> build -- version: 1775979
> >>>>>>
> >>>>>>
> >>>>>> =============
> >>>>>> Building module gtest
> >>>>>> =============
> >>>>>>
> >>>>>> Entering /cygdrive/c/source/aoo-trunk/ext_libraries/gtest
> >>>>>>
> >>>>>> mkdir: cannot create directory './wntmsci12.pro/misc/build/
> gtest-1.7.0/': File exists
> >>>>>> C:/source/aoo-trunk/main/solenv/gbuild/Package.mk:28: ***
> gb_Deliver_deliver: file does not exist in solver, and cannot be deli.
> Stop.nk/main/solver/420/wntmsci12.pro/inc/gtest/gtest.h
> >>>>>> dmake:  Error code 2, while making './wntmsci12.pro/misc/build/
> so_built_oo_gtest'
> >>>>>>
> >>>>>> 1 module(s):
> >>>>>>         gtest
> >>>>>> need(s) to be rebuilt
> >>>>>>
> >>>>>> Reason(s):
> >>>>>>
> >>>>>> ERROR: error 65280 occurred while making
> /cygdrive/c/source/aoo-trunk/ext_libraries/gtest
> >>>>>>
> >>>>>> When you have fixed the errors in that module you can resume
the
> build by running:
> >>>>>>
> >>>>>>         build --all:gtest
> >>>>>>
> >>>>>> The sal helper cannot open include file conditn.h
> >>>>>>
> >>>>>> =============
> >>>>>> Building module salhelper
> >>>>>> =============
> >>>>>>
> >>>>>> Entering /cygdrive/c/source/aoo-trunk/main/salhelper/source
> >>>>>>
> >>>>>> mkout -- version: 1.8
> >>>>>> Making:    all_salhelper.dpslo
> >>>>>> Compiling: salhelper/wntmsci12.pro/misc/salhelper3MSC_version.c
> >>>>>> Compiling: salhelper/source/condition.cxx
> >>>>>> ../inc\salhelper/condition.hxx(29) : fatal error C1083: Cannot
> open include file: 'osl/conditn.h': No such file or directory
> >>>>>> dmake:  Error code 2, while making '../wntmsci12.pro/slo/
> condition.obj'
> >>>>>>
> >>>>>> 1 module(s):
> >>>>>>         salhelper
> >>>>>> need(s) to be rebuilt
> >>>>>>
> >>>>>> Reason(s):
> >>>>>>
> >>>>>> ERROR: error 65280 occurred while making
> /cygdrive/c/source/aoo-trunk/main/salhelper/source
> >>>>>>
> >>>>>> When you have fixed the errors in that module you can resume
the
> build by running:
> >>>>>>
> >>>>>>         build --all:salhelper
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> From: Yemelyanenko Fyodor [mailto:fyodor_e@hotmail.com]
> >>>>>> Sent: Wednesday, July 19, 2017 10:51 AM
> >>>>>> To: Damjan Jovanovic <damjan@apache.org>; Apache OO <
> dev@openoffice.apache.org>
> >>>>>> Subject: Re[5]: Building OO
> >>>>>>
> >>>>>> Hello!
> >>>>>>
> >>>>>> I've switched to Ubuntu 14.04 mini with xubuntu-desktop and
xrdp
> installed
> >>>>>> And OO built successfully! :-)
> >>>>>>
> >>>>>> Now trying to do the same on W7 x32.
> >>>>>>
> >>>>>> As Id like to deep dive into OO development, could you please
share
> what dev environment do you use on Ubuntu and on W7 (I believe, that I'll
> finally success in building OO on Windows).
> >>>>>> Any thoughts on establishing dev environment will be appreciated.
> >>>>>>
> >>>>>> --
> >>>>>> Fyodor
> >>>>>>
> >>>>>> ------ ??????о? ????????? ------
> >>>>>> ??: "??????????о ?????" <fyodor_e@hotmail.com<mailto:f
> yodor_e@hotmail.com>>
> >>>>>> ????: "Damjan Jovanovic" <damjan@apache.org<mailto:damj
> an@apache.org>>
> >>>>>> ?????: "Apache OO" <dev@openoffice.apache.org<mailto:
> dev@openoffice.apache.org>>
> >>>>>> ?????в????: 04.07.2017 12:57:52
> >>>>>> ????: Re[4]: Building OO
> >>>>>>
> >>>>>> I use following config script
> >>>>>>
> >>>>>> ./configure \
> >>>>>>    --with-frame-home="$SDK_PATH" \
> >>>>>>    --with-psdk-home="$SDK_PATH" \
> >>>>>>    --with-midl-path="$SDK_PATH/bin" \
> >>>>>>    --with-ant-home="/cygdrive/c/ant110/apache-ant-1.10.1" \
> >>>>>>    --with-jdk-home="C:/PROGRA~2/Java/JDK18~1.0_1" \
> >>>>>>    --with-csc-path="C:/Windows/Microsoft.NET/Framework/v3.5"
\
> >>>>>>    --with-cl-home="C:/PROGRA~2/MICROS~1.0/VC" \
> >>>>>>    --with-asm-home="C:/PROGRA~2/MICROS~1.0/VC/bin" \
> >>>>>>    --with-dmake-url="https://sourceforge.net/projects/
> oooextras.mirror/files/dmake-4.12.tar.bz2" \
> >>>>>>    --with-epm-url="https://sourceforge.net/projects/
> oooextras.mirror/files/epm-3.7.tar.gz" \
> >>>>>>    --disable-pch \
> >>>>>>    --disable-atl \
> >>>>>>    --disable-activex \
> >>>>>>    --disable-nss-module \
> >>>>>>    --without-junit \
> >>>>>>    --disable-directx
> >>>>>>
> >>>>>> On Windows 8.1 64 bit Hyper-v VM
> >>>>>>
> >>>>>> Full jdk path C:\Program Files (x86)\Java\jdk1.8.0_131
> >>>>>> CL home C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC
> >>>>>> Asm home C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin
> >>>>>>
> >>>>>> I've tried to rebuild with following script (full path) with
no
> success
> >>>>>>
> >>>>>> ./configure \
> >>>>>>    --with-frame-home="$SDK_PATH" \
> >>>>>>    --with-psdk-home="$SDK_PATH" \
> >>>>>>    --with-midl-path="$SDK_PATH/bin" \
> >>>>>>    --with-ant-home="/cygdrive/c/ant110/apache-ant-1.10.1" \
> >>>>>>    --with-jdk-home="/cygdrive/c/Program Files
> (x86)/Java/jdk1.8.0_131" \
> >>>>>>    --with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5"
> \
> >>>>>>    --with-cl-home="/cygdrive/c/Program Files (x86)/Microsoft
> Visual Studio 9.0/VC" \
> >>>>>>    --with-asm-home="/cygdrive/c/Program Files (x86)/Microsoft
> Visual Studio 9.0/VC/bin" \
> >>>>>>    --with-dmake-url="https://sourceforge.net/projects/
> oooextras.mirror/files/dmake-4.12.tar.bz2" \
> >>>>>>    --with-epm-url="https://sourceforge.net/projects/
> oooextras.mirror/files/epm-3.7.tar.gz" \
> >>>>>>    --disable-pch \
> >>>>>>    --disable-atl \
> >>>>>>    --disable-activex \
> >>>>>>    --disable-nss-module \
> >>>>>>    --without-junit \
> >>>>>>    --disable-directx
> >>>>>>
> >>>>>> Now I have error on module gtest...
> >>>>>>
> >>>>>> dmake: Error code 2, while making './wntmsci12.pro/misc/build/
> so_built_oo_gtest'
> >>>>>>
> >>>>>> 1 module(s):
> >>>>>> gtest
> >>>>>> need(s) to be rebuilt
> >>>>>>
> >>>>>> Reason(s):
> >>>>>>
> >>>>>> ERROR: error 65280 occurred while making
> /cygdrive/c/source/aoo-trunk/ext_libraries/gtest
> >>>>>>
> >>>>>> When you have fixed the errors in that module you can resume
the
> build by running:
> >>>>>>
> >>>>>> build --all:gtest
> >>>>>>
> >>>>>> ------ ???????? ????????? ------
> >>>>>> ?Ñ?: "Damjan Jovanovic" <damjan@apache.org<mailto:damjan@apache.org
> >>
> >>>>>> ????: "Yemelyanenko Fyodor" <fyodor_e@hotmail.com<mailto:f
> yodor_e@hotmail.com>>
> >>>>>> ?????: "Apache OO" <dev@openoffice.apache.org<mailto:
> dev@openoffice.apache.org>>
> >>>>>> ????а????о: 02.07.2017 16:46:09
> >>>>>> ????: Re: Re[2]: Building OO
> >>>>>>
> >>>>>> I just succeeded in building trunk with:
> >>>>>> 32 bit VirtualBox VM
> >>>>>> Windows XP
> >>>>>> SDK_PATH="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0"
> ./configure --with-frame-home="$SDK_PATH" --with-psdk-home="$SDK_PATH"
> --with-midl-path="$SDK_PATH/bin" --with-ant-home="/cygdrive/c/apache-ant-1.9.6"
> --with-dmake-url="http://dmake.apache-extras.org.
> codespot.com/files/dmake-4.12.tar.bz2" --with-epm-url="http://www.
> msweet.org/files/project2/epm-3.7-source.tar.gz" --enable-pch
> --disable-atl --disable-activex --with-junit="/cygdrive/c/source/junit.jar"
> --with-hamcrest-core="/cygdrive/c/source/hamcrest.jar"
> --with-cl-home="/cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC"
> --with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5"
> --with-jdk-home="/cygdrive/c/Program Files/Java/jdk1.7.0"
> --disable-directx --with-package-format="installed"
> --enable-wiki-publisher
> >>>>>>
> >>>>>> Please post your full setup and build options.
> >>>>>> Regards
> >>>>>> Damjan
> >>>>>>
> >>>>>> On Fri, Jun 30, 2017 at 7:37 AM, Yemelyanenko Fyodor <
> fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>> wrote:
> >>>>>> Hello Damjan,
> >>>>>>
> >>>>>> I've commented out in main/udm/StaticLibrary_udm.mk
> >>>>>>
> >>>>>> #ifeq ($(OS),WNT)
> >>>>>> #$(eval $(call gb_StaticLibrary_add_cflags,udm,-GR))
> >>>>>> #else
> >>>>>>
> >>>>>> Now build stopped on xml2cmp module...
> >>>>>>
> >>>>>>
> >>>>>>                         =============
> >>>>>>                         Building module xml2cmp
> >>>>>>                         =============
> >>>>>>
> >>>>>>                         Entering /cygdrive/c/source/aoo-trunk/
> main/xml2cmp/prj
> >>>>>>
> >>>>>>                         cd .. && make -s -r -j1   &&
make -s -r
> deliverlog
> >>>>>>                         [ info  ALL ] LinkTarget
> Library/msvcprt.lib not defined: Assuming
> >>>>>> headers to be there!
> >>>>>>                         [ info  ALL ] LinkTarget
> Library/kernel32.lib not defined: Assuming
> >>>>>> headers to be there!
> >>>>>>                         [ info  ALL ] LinkTarget Library/msvcrt.lib
> not defined: Assuming
> >>>>>> headers to be there!
> >>>>>>                         [ info  ALL ] LinkTarget
> Library/oldnames.lib not defined: Assuming
> >>>>>> headers to be there!
> >>>>>>                         [ build CXX ] xml2cmp/source/finder/dependy
> >>>>>>                         dependy.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/finder/dep_main
> >>>>>>                         dep_main.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/cr_html
> >>>>>>                         cr_html.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/cr_index
> >>>>>>                         cr_index.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/cr_metho
> >>>>>>                         cr_metho.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/filebuff
> >>>>>>                         filebuff.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/parse
> >>>>>>                         parse.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/xmlelem
> >>>>>>                         xmlelem.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/xmltree
> >>>>>>                         xmltree.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/support/cmdline
> >>>>>>                         cmdline.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/support/heap
> >>>>>>                         heap.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/support/sistr
> >>>>>>                         sistr.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/support/syshelp
> >>>>>>                         syshelp.cxx
> >>>>>>                         [ build CXX ] xml2cmp/source/support/badcast
> >>>>>>                         badcast.cxx
> >>>>>>                         [ build DEP ] LNK:Executable/srvdepy.exe
> >>>>>>                         [ build CXX ] xml2cmp/source/xcd/main
> >>>>>>                         main.cxx
> >>>>>>                         [ build DEP ] LNK:Executable/xml2cmp.exe
> >>>>>>                         ', needed by
> >>>>>> '/cygdrive/c/source/aoo-trunk/main/solver/420/wntmsci12.pro/
> workdir/CxxObject/xml2cmp/source/xcd/cr_html.o<http://
> wntmsci12.pro/workdir/CxxObject/xml2cmp/source/xcd/cr_html.o>'.
> >>>>>>   Stop.
> >>>>>>                         dmake:  Error code 2, while making 'all'
> >>>>>>
> >>>>>>                         1 module(s):
> >>>>>>                                 xml2cmp
> >>>>>>                         need(s) to be rebuilt
> >>>>>>
> >>>>>>                         Reason(s):
> >>>>>>
> >>>>>>                         ERROR: error 65280 occurred while making
> >>>>>> /cygdrive/c/source/aoo-trunk/main/xml2cmp/prj
> >>>>>>
> >>>>>>                         When you have fixed the errors in that
> module you can resume the
> >>>>>> build by running:
> >>>>>>
> >>>>>>                                 build --all:xml2cmp
> >>>>>>
> >>>>>> ------ ???????? ????????? ------
> >>>>>> ??: "Damjan Jovanovic" <damjan@apache.org<mailto:damjan@apache.org
> >>
> >>>>>> ???Ñ?: "Yemelyanenko Fyodor" <fyodor_e@hotmail.com<mailto:f
> yodor_e@hotmail.com>>
> >>>>>> ?????: "Apache OO" <dev@openoffice.apache.org<mailto:
> dev@openoffice.apache.org>>
> >>>>>> ??????????: 28.06.2017 15:07:29
> >>>>>> ????: Re: Building OO
> >>>>>>
> >>>>>>> Hi Fyodor
> >>>>>>>
> >>>>>>> The problem is almost certainly in
> >>>>>>> main/udm/StaticLibrary_udm.mk
> >>>>>>>
> >>>>>>> Make try take out the contents of the ifeq ($(OS),WNT) section?
> >>>>>>>
> >>>>>>> I'll try build it later.
> >>>>>>>
> >>>>>>> Damjan
> >>>>>>>
> >>>>>>> On Wed, Jun 28, 2017 at 6:00 AM, Yemelyanenko Fyodor
> >>>>>>> <fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>>
wrote:
> >>>>>>>> Hi Damjan,
> >>>>>>>>
> >>>>>>>> I?ve got OO using svn co
> >>>>>>>> https://svn.apache.org/repos/asf/openoffice/trunk
> >>>>>>>> <https://svn.apache.org/repos/asf/openoffice/trunk>
aoo-trunk a
> week
> >>>>>>>> ago.
> >>>>>>>>
> >>>>>>>> I've cd'ed to udm and tried build -all:udm
> >>>>>>>>
> >>>>>>>> This is output
> >>>>>>>>                         Admin@shr-pc
> >>>>>>>> /cygdrive/c/source/aoo-trunk/main/udm
> >>>>>>>>                         $ build --all:udm
> >>>>>>>>                         build -- version: 1775979
> >>>>>>>>
> >>>>>>>>
> >>>>>>>>                         =============
> >>>>>>>>                         Building module udm
> >>>>>>>>                         =============
> >>>>>>>>
> >>>>>>>>                         Entering
> >>>>>>>> /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>>>>
> >>>>>>>>                         cd .. && make -s -r
-j1   && make -s -r
> >>>>>>>> deliverlog
> >>>>>>>>                         ', needed by
> >>>>>>>> '/cygdrive/c/source/aoo-trunk/main/solver/420/wntmsci12.pro/
> workdir/CxxObject/udm/source/html/htmlitem.o<http://wntmsci12.pro/workdir/
> CxxObject/udm/source/html/htmlitem.o>
> >>>>>>>> <http://wntmsci12.pro/workdir/CxxObject/udm/source/html/
> htmlitem.o>'.
> >>>>>>>>   Stop.
> >>>>>>>>                         dmake:  Error code 2, while
making 'all'
> >>>>>>>>
> >>>>>>>>                         1 module(s):
> >>>>>>>>                                 udm
> >>>>>>>>                         need(s) to be rebuilt
> >>>>>>>>
> >>>>>>>>                         Reason(s):
> >>>>>>>>
> >>>>>>>>                         ERROR: error 65280 occurred
while making
> >>>>>>>> /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>>>>
> >>>>>>>>                         When you have fixed the errors
in that
> module
> >>>>>>>> you can resume the
> >>>>>>>> build by running:
> >>>>>>>>
> >>>>>>>>                                 build --all:udm
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> I think I need to deep dive into dmake, so I'll be able
to trace
> build
> >>>>>>>> and link processes and find what exactly done on udm
module. So
> I'll
> >>>>>>>> appreciate reference to information on dmake.
> >>>>>>>>
> >>>>>>>> --
> >>>>>>>> Fyodor
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> From: Damjan Jovanovic [mailto:damjan@apache.org<mailto:
> damjan@apache.org>]
> >>>>>>>> Sent: Tuesday, June 27, 2017 5:38 PM
> >>>>>>>> To: Apache OO <dev@openoffice.apache.org<mailto:
> dev@openoffice.apache.org>>; fyodor_e@hotmail.com<mailto:fy
> odor_e@hotmail.com>
> >>>>>>>> Subject: Re: Building OO
> >>>>>>>>
> >>>>>>>> Hi Fyodor
> >>>>>>>> Welcome to AOO :).
> >>>>>>>> What version are you building?
> >>>>>>>> Can you "cd" into the udm directory, and post the full
output of
> >>>>>>>> "build"
> >>>>>>>> run from there?
> >>>>>>>> Thank you
> >>>>>>>> Damjan
> >>>>>>>>
> >>>>>>>> On Tue, Jun 27, 2017 at 8:12 AM, Yemelyanenko Fyodor
> >>>>>>>> <fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>>
wrote:
> >>>>>>>> =============
> >>>>>>>> Building module udm
> >>>>>>>> =============
> >>>>>>>>
> >>>>>>>> Entering /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>>>> Hello!
> >>>>>>>>
> >>>>>>>> I'm newbie in OO development, and as New Volunteer Orientation
> module
> >>>>>>>> suggests, I've established local build env, and try
to build OO.
> >>>>>>>> I've installed required prerequisites from Building
Guide
> >>>>>>>> (http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> >>>>>>>> <http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
> >)
> >>>>>>>> and
> >>>>>>>> started to build with this command
> >>>>>>>>
> >>>>>>>> ./configure \
> >>>>>>>>      --with-frame-home="$SDK_PATH" \
> >>>>>>>>      --with-psdk-home="$SDK_PATH" \
> >>>>>>>>      --with-midl-path="$SDK_PATH/bin" \
> >>>>>>>>      --with-ant-home="/cygdrive/c/ant110/apache-ant-1.10.1"
\
> >>>>>>>>      --with-jdk-home="C:/PROGRA~2/Java/JDK18~1.0_1"
\
> >>>>>>>>      --with-csc-path="C:/Windows/Microsoft.NET/Framework/v3.5"
\
> >>>>>>>>      --with-cl-home="C:/PROGRA~2/MICROS~1.0/VC" \
> >>>>>>>>      --with-asm-home="C:/PROGRA~2/MICROS~1.0/VC/bin"
\
> >>>>>>>>
> >>>>>>>> --with-dmake-url="https://sourceforge.net/projects/
> oooextras.mirror/files/dmake-4.12.tar.bz2
> >>>>>>>> <https://sourceforge.net/projects/oooextras.mirror/
> files/dmake-4.12.tar.bz2>"
> >>>>>>>> \
> >>>>>>>>
> >>>>>>>> --with-epm-url="https://sourceforge.net/projects/
> oooextras.mirror/files/epm-3.7.tar.gz
> >>>>>>>> <https://sourceforge.net/projects/oooextras.mirror/
> files/epm-3.7.tar.gz>"
> >>>>>>>> \
> >>>>>>>>      --disable-pch \
> >>>>>>>>      --disable-atl \
> >>>>>>>>      --disable-activex \
> >>>>>>>>      --disable-nss-module \
> >>>>>>>>      --without-junit \
> >>>>>>>>      --disable-directx
> >>>>>>>>
> >>>>>>>> There are some modules built successfully, but built
stop on UDM
> >>>>>>>> module
> >>>>>>>> with following error
> >>>>>>>>
> >>>>>>>> cd .. && make -s -r -j1   && make -s
-r deliverlog
> >>>>>>>> [ build CXX ] udm/source/html/htmlitem
> >>>>>>>> htmlitem.cxx
> >>>>>>>> [ build CXX ] udm/source/xml/xmlitem
> >>>>>>>> xmlitem.cxx
> >>>>>>>> [ build DEP ] LNK:StaticLibrary/udm.lib
> >>>>>>>> [ build PKG ] udm_inc
> >>>>>>>> ', needed by
> >>>>>>>> '/cygdrive/c/source/aoo-trunk/main/solver/420/wntmsci12.pro/
> workdir/CxxObject/udm/source/html/htmlitem.o<http://wntmsci12.pro/workdir/
> CxxObject/udm/source/html/htmlitem.o>
> >>>>>>>> <http://wntmsci12.pro/workdir/CxxObject/udm/source/html/
> htmlitem.o>'.
> >>>>>>>>   Stop.
> >>>>>>>> dmake:  Error code 2, while making 'all'
> >>>>>>>>
> >>>>>>>> 1 module(s):
> >>>>>>>>          udm
> >>>>>>>> need(s) to be rebuilt
> >>>>>>>>
> >>>>>>>> Reason(s):
> >>>>>>>>
> >>>>>>>> ERROR: error 65280 occurred while making
> >>>>>>>> /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>>>>
> >>>>>>>> When you have fixed the errors in that module you can
resume the
> build
> >>>>>>>> by running:
> >>>>>>>>
> >>>>>>>>          build --all:udm
> >>>>>>>>
> >>>>>>>> I'm not professional with dmake (yet), so any help would
be
> >>>>>>>> appreciated.
> >>>>>>>>
> >>>>>>>> --
> >>>>>>>> Fyodor
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> ------------------------------------------------------------
> ---------
> >>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> <mailto:dev-unsubscribe@openoffice.apache.org>
> >>>>>>>> <mailto:dev-unsubscribe@openoffice.apache.org<mailto:d
> ev-unsubscribe@openoffice.apache.org>>
> >>>>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
> <mailto:dev-help@openoffice.apache.org>
> >>>>>>>>
> >>>> ---------------------------------------------------------------------
> >>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> >>>> For additional commands, e-mail: dev-help@openoffice.apache.org
> >>>>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> > For additional commands, e-mail: dev-help@openoffice.apache.org
> >
> >
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message