openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: Building OO
Date Wed, 16 Aug 2017 17:51:18 GMT
I fixed the --enable-win-x64-shellext problem in r1805208.

On 16 Aug, Matthias Seidel wrote:
> Hi Don,
> 
> it worked like a charm! ;-)
> 
> My first AOO 4.2.0 builds are to be found here:
> https://home.apache.org/~mseidel/AOO-builds/AOO-420-Test/
> 
> My next build will be with "--enable-win-x64-shellext" but I suspect it
> will stop because of expat2.2.3.
> (For 4.1.4 we reverted to Jims patch)
> 
> Matthias
> 
> 
> Am 15.08.2017 um 20:00 schrieb Don Lewis:
>> On 15 Aug, Matthias Seidel wrote:
>>> Am 15.08.2017 um 11:18 schrieb Don Lewis:
>>>> On 10 Aug, Matthias Seidel wrote:
>>>>> I could now get past the gtest error by disabling unit tests
>>>>> (--disable-unit-tests).
>>>>>
>>>>> Errors in udm and xml2cmp remain:
>>>>>
>>>>> make: *** No rule to make target '/cygdrive/e/slave14/aoo-win7/build/main/udm/source/inc/precomp.h
>>>>> ', needed by '/cygdrive/e/slave14/aoo-win7/build/main/solver/420/wntmsci12.pro/workdir/CxxObject/udm/source/html/htmlitem.o'.
 Stop.
>>>>> dmake:  Error code 2, while making 'all'
>>>>>
>>>>> make: *** No rule to make target '/cygdrive/e/slave14/aoo-win7/build/main/xml2cmp/source/xcd/cr_html.hxx
>>>>> ', needed by '/cygdrive/e/slave14/aoo-win7/build/main/solver/420/wntmsci12.pro/workdir/CxxObject/xml2cmp/source/xcd/cr_html.o'.
 Stop.
>>>>> dmake:  Error code 2, while making 'all'
>>>> I'm able to reproduce this on Windows 10 with cygwin 2.8.2.  If you look
>>>> carefully about the "missing" files, you'll find that the file names in
>>>> the error report have a carriage return character appended to them as
>>>> in: 
>>>>
>>>>   '/cygdrive/e/slave14/aoo-win7/build/main/udm/source/inc/precomp.h^M'
>>>>
>>>> Something is going wrong in the Windows version of "make depend",
>>>> essentially.  If I look at
>>>> main/solver/420/wntmsci12.pro/workdir/Dep/CxxObject/xml2cmp/source/xcd/cr_html.d,
>>>> I see:
>>>>
>>>> $(WORKDIR)/CxxObject/xml2cmp/source/xcd/cr_html.o: \
>>>> 	 \
>>>> 	$(SRCDIR)/xml2cmp/source/xcd/cr_html.hxx^M \
>>>> 	$(SRCDIR)/xml2cmp/source/support/sistr.hxx^M \
>>>> etc.
>>>>
>>>> I believe I have this fixed in trunk revision r1805063.
>>> Hi Don,
>>>
>>> Well done!
>>>
>>> My build is still running, but it looks good so far! Still have disabled
>>> unit tests, will enable later and see if there may be a similar problem.
>> This fixed gtest for me as well.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>
>>
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message