openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay Schenk <ksch...@apache.org>
Subject Re: [DISCUSS] Release 4.2: General Topics
Date Sat, 27 Aug 2016 22:28:03 GMT


On 08/27/2016 09:32 AM, Andrea Pescetti wrote:
> Kay Schenk wrote:
>> On Thu, Aug 25, 2016 at 2:55 PM, Andrea Pescetti wrote:
>>> Andrea Pescetti wrote:
>>>> Last translations import were done in 4.1.0 and not 4.1.1 (if I recall
>>>> correctly); but this is a minor detail. There are no new languages
>>>> to be
>>>> expected in 4.2.0: we have new languages in Pootle, but I don't think
>>>> any of them is ready enough for being released (this may of course
>>>> improve with time). ...
>> ​Ok, from what I saw in Pootle, it looked like at least were VERY
>> close to
>> be added.​
> 
> Indeed, work on those 3 languages has progressed more than I expected.
> Not 100% but close enough. With a bit a flexibility (which I would
> recommend) we could add
> https://translate.apache.org/is/
> https://translate.apache.org/si/
> https://translate.apache.org/ug/
> 
>> [from Java 1.5 to *at least* Java 1.7]
>> Possible security issues. I can not imagine at this point in time that
>> ANYONE is really using java 1.5 as a default java installation. ...
>> We can not in good conscience continue to supply software built with the
>> old outdated version of Java.
> 
> I think we have a misunderstanding here. If you believe that we build
> with Java 1.5, open
> http://svn.apache.org/viewvc/openoffice/devtools/build-scripts/4.1.2
> then go through all the config.log files in the various dirs and search
> for "installed JDK".

Ok, I stand corrected. The *nix builds are using java 1.6. The others,
Mac and Windows are using Java 1.7, so we only need to correct the *nix
builds at this time.

> 
> I want it to be very clear that all possible insecurity is on the user's
> side. Again, this is exactly like saying "Windows XP is unsupported and
> OpenOffice won't run on it since we need to educate users" and "solving"
> it by inserting an explicit check that makes OpenOffice quit at startup
> on XP even if it would run normally there.

I don't agree 100% with this statement. We seem to be rather concerned
with supplying current versions of the libraries we use due to security
issues as near as I can tell. I would think something as important as
building with a more current version of Java would fall into this category.

> 
> This clarification aside, I suggest that we adjourn the discussion to
> when there is real code to see: this will avoid misunderstandings.
> 

OK.

>>>>> Add, at least the ant version we're checking for in our
>>>>> configuration is
>>>>> not the version recommended in our Building Guide.
>>>> The this is a bug in configure, needs its own issue and must be
>>>> checked.
>> ​Checked by builders?
> 
> No, checked by us. If there is an ant version that passes ./configure
> but does not allow a successful build, then configure.ac must obviously
> be corrected (again, if you have an issue number this will make things
> clearer). I see 1.6.0 (conditional to 1.7.0 depending on the specified
> bundle-time extensions) at the moment in configure.ac.
> 
> Regards,
>   Andrea.


-- 
----------------------------------------
Kay Schenk
Apache OpenOffice

"Things work out best for those who make
 the best of the way things work out."
                         -- John Wooden

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message