openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damjan Jovanovic <dam...@apache.org>
Subject Re: Building on Windows
Date Tue, 02 Feb 2016 12:18:28 GMT
For me, main/icu fails to build on Windows about 50% of the time for no
apparent reason; I've begun to think it's some sort of build race condition
within that module. I haven't seen the buildbots fail there, and nobody
else has reported this problem.

If this is your problem, the only fix I know is the following hack:

cd main/icu

then keep cleaning and rebuilding it until it builds successfully:

rm -rf wntmsci12.pro
one of: dmake / build -P2 / build -- -P2 / build -P2 -- -P2

then when it does, continue as before:

cd ../instsetoo_native
build --all -P2 -- -P2


On Tue, Feb 2, 2016 at 2:00 PM, Patricia Shanahan <pats@acm.org> wrote:

> Good. My latest error is:
>
> NMAKE : fatal error U1073: don't know how to make '".\..\..\lib\icuin.lib"'
> Stop.
> NMAKE : fatal error U1077: 'C:\PROGRA~2\MICROS~1.0\VC\bin\nmake.exe' :
> return code '0x2'
> Stop.
> dmake:  Error code 2, while making './
> wntmsci12.pro/misc/build/so_built_so_icu'
>
> I am hoping after this is all done to add a section on gotchas and their
> symptoms to the step-by-step guide. That may save future new developers
> some time.
>
>
>
>
> On 2/2/2016 3:32 AM, Damjan Jovanovic wrote:
>
>> I've documented this gotcha on both
>>
>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>> and https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>
>> On Tue, Feb 2, 2016 at 10:29 AM, Patricia Shanahan <pats@acm.org> wrote:
>>
>> Thanks.
>>>
>>>
>>> On 2/1/2016 11:50 PM, Damjan Jovanovic wrote:
>>>
>>> According to
>>>>
>>>>
>>>> http://stackoverflow.com/questions/19641685/java-jni-jawt-error-unresolved-external-symbol-imp-jawt-getawt8
>>>> you're using a 64 bit JDK instead of a 32 bit one.
>>>>
>>>> On Tue, Feb 2, 2016 at 9:40 AM, Patricia Shanahan <pats@acm.org> wrote:
>>>>
>>>> After checking out with Cygwin's svn rather than TortoiseSVN, my build
>>>>
>>>>> failed in "Building module bean" with the following message:
>>>>>
>>>>>      Creating library ../../wntmsci12.pro/lib/iofficebean_t1.lib and
>>>>> object
>>>>> ../../wntmsci12.pro/lib/iofficebean_t1.exp
>>>>> officebean.lib(com_sun_star_comp_beans_LocalOfficeWindow.obj) : error
>>>>> LNK2019: unresolved external symbol __imp__JAWT_GetAWT@8 referenced in
>>>>> function
>>>>> _Java_com_sun_star_comp_beans_LocalOfficeWindow_getNativeWindow@8
>>>>> ../../wntmsci12.pro/bin/officebean.dll : fatal error LNK1120: 1
>>>>> unresolved externals
>>>>> dmake:  Error code 96, while making '../../
>>>>> wntmsci12.pro/bin/officebean.dll'
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>
>>>>>
>>>>>
>>>>>
>>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>
>>>
>>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message