openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damjan Jovanovic <dam...@apache.org>
Subject Re: Building on Windows
Date Mon, 01 Feb 2016 16:34:51 GMT
On Mon, Feb 1, 2016 at 1:49 PM, Patricia Shanahan <pats@acm.org> wrote:

>
>
> On 1/31/2016 11:59 PM, Damjan Jovanovic wrote:
>
>> On Mon, Feb 1, 2016 at 4:36 AM, Patricia Shanahan <pats@acm.org> wrote:
>>
>> Now I'm stuck. I got through configure, with warnings. My build attempt
>>> failed with:
>>>
>>> $ build --all
>>> build -- version: 275224
>>>
>>>
>>> =============
>>> Building module solenv
>>> =============
>>>
>>> Entering /cygdrive/c/OpenOfficeDev/Trunk/main/solenv
>>>
>>> /cygdrive/c/OpenOfficeDev/Trunk/main/solenv/bin/mkout.pl: line 1:
>>> $':\r':
>>> command not found
>>> mkout -- version: 1.8
>>> /usr/bin/bash: C:/OpenOfficeDev/Trunk/main/solenv/
>>> wntmsci12.pro/inc/myworld.mk: No such file or directory
>>> dmake:  Error code 1, while making
>>> '/cygdrive/C/OpenOfficeDev/Trunk/main/solenv/
>>> wntmsci12.pro/inc/myworld.mk'
>>>
>>> 1 module(s):
>>>          solenv
>>> need(s) to be rebuilt
>>>
>>> Reason(s):
>>>
>>> ERROR: error 65280 occurred while making
>>> /cygdrive/c/OpenOfficeDev/Trunk/main/solenv
>>>
>>> When you have fixed the errors in that module you can resume the build by
>>> running:
>>>
>>>          build --all:solenv
>>>
>>> Any advice on e.g. configure warnings that are likely to be significant?
>>>
>>>
>>> A Perl problem of some kind?
>>
>> Please post your main/config.log and see if the "perl" command works.
>>
>
> A perl "hello, world" runs in the Cygwin terminal window I used for the
> build attempt. I am attaching my config.log. The call was:
>
> SDK_PATH="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0"
> ./configure \
>     --with-frame-home="$SDK_PATH" \
>     --with-psdk-home="$SDK_PATH" \
>     --with-midl-path="$SDK_PATH/bin" \
>     --with-directx-home="C:/Program Files (x86)/Microsoft DirectX SDK
> (June 2010)" \
>     --with-ant-home="/cygdrive/c/ant" \
>
> --with-dmake-url="
> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2" \
>
> --with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz"
> \
>     --enable-pch \
>     --disable-atl \
>     --disable-activex \
>     --without-junit \
>     --with-jdk-home="/cygdrive/c/Program Files/Java/jdk1.7.0_67"
>
> Thanks for any advice,
>
> Patricia
>
>
Why do you have both PROGRA~1 and PROGRA~2 paths (I presume these are
"Program Files" and "Program Files (x86)")? Are you building on Win64? We
don't have a Win64 version of AOO, so it's possible (I'm not sure) that AOO
doesn't even compile on Win64.

PATH: /cygdrive/c/PROGRA~1/Java/JDK18~1.0_7/bin
PATH: /cygdrive/c/PROGRA~2/MICROS~1.0/VC/bin
PATH: /cygdrive/c/PROGRA~2/MICROS~1.0/Common7/IDE
PATH: /cygdrive/c/PROGRA~1/MICROS~2/Windows/v7.0/bin
PATH: /cygdrive/c/Windows/MICROS~1.NET/FRAMEW~1/V20~1.507
PATH: /cygdrive/c/PROGRA~2/MICROS~1.0/VC/bin

Otherwise my own ./configure options differ from yours as follows:
* Build is done in a 32 bit virtual machine
* I used --disable-directx instead of your --with-directx-home=...
* I also had --with-cl-home=/cygdrive/c/Program Files/Microsoft Visual
Studio 9.0/VC
* I also had
--with-csc-path=/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5

Damjan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message