openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damjan Jovanovic <dam...@apache.org>
Subject Re: Let's fix the Windows build bots
Date Thu, 04 Feb 2016 14:05:20 GMT
On Wed, Feb 3, 2016 at 1:48 PM, Jochen Nitschke <j.nitschke@ok.de> wrote:

> On Wed, 3 Feb 2016 13:15:23 +0200 Damjan Jovanovic wrote:
> > So builds@ replied saying the buildbot was broken by an earlier bad
> commit
> > (not mine) and should be working now, and it was, but I ended up needing
> to
> > commit another patch (cydrive -> cygdrive typo in the path to "svn
> info").
> > That 1 byte patch cannot be wrong, yet the buildbot isn't using it now,
> > despite committing it hours ago.
> >
> > The website changes also haven't taken.
> but hey, its progress :-)
>
> could you follow the flow?
> commit
> wait 5 mins
> pull changes
> buildbot checkconfig  (on your local config files?)
> buildbot reconfig (wouldn't know how)
>
>
After mailing builds@ and infrastructure@, I ran into other IRC users on
#asftest, one of which (pono) helped, restarting the buildmaster. That got
it using the latest commits, which finally fixed "svn info" on aoo-win7 :-).

I then made further commits with the same "svn info" improvement and
bootstrap improvement for aoo-w7snap, and another on aoo-win7 to use "svn
export" instead of rsync to generate the build directory to test the theory
that the use of rsync is what breaks apr later (
https://issues.apache.org/jira/browse/INFRA-10481), but the commits weren't
going through again. Pono investigated, eventually finding the buildbot
configuration was up to date, but the buildbot wasn't using it; by
reloading the config (not sure how) (which caused the ooo-bot to
temporarily disconnect from IRC) it started using them again.

My aoo-w7snap fixes went through and "svn info" is now working there too,
but my aoo-win7 changes were less successful: my new svn export command was
preceded by "rm -rf build" which fails in the infamous apr module:

rm: cannot remove `build/ext_libraries/apr/
wntmsci12.pro/misc/build/apr-1.4.5/Makefile.win': Device or resource busy
(
https://ci.apache.org/builders/aoo-win7/builds/173/steps/svn%20export/logs/stdio
)

"Device or resource busy" is the same error that later breaks building apr,
and they seem related. I asked pono to look into what has that file opened
or locked and am waiting for that and other maintenance on aoo-win7.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message