openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay Schenk <kay.sch...@gmail.com>
Subject Re: Buildbots update
Date Tue, 16 Feb 2016 22:25:42 GMT


On 02/13/2016 11:45 AM, Andrea Pescetti wrote:
> Damjan Jovanovic wrote:
>> The buildbots are all failing to download 15 dependencies every night
>> now. I think something is wrong with access to SourceForge :-(.
> 
> Well, from what I see for example here
> https://ci.apache.org/builders/openoffice-linux64-nightly/builds/240/steps/retry%20bootstrap/logs/stdio
> 
> it seems that buildbots are having issues with network in general
> (or maybe it was a temporary network issue).
> 
> The failure in jpegsrc.v8d.tar.gz is expected, but URL1 is failing
> not only for cases where it is, by chance, on SourceForge, but also
> for vigra1.6.0.tar.gz and for the files from Mozilla. So it really
> seems that the buildbot was not able to download from anywhere.
> Maybe a forced re-run will fix it.
> 
> And thank you Damjan for your buildbot work! Improved error handling
> and built-in download retry in ./bootstrap will surely help in
> diagnosing build issues in general.
> 
> Regards,
>   Andrea.

Do we have any additional news on the download failures specifically
from the buildbots to SourceForge downloads?
Has anyone contacted SourceForge?

I am not experiencing these problems in my local build. And I made a
very stripped down "download_external_dependencies.pl" to just try
some out manually by just supplying the URL.

The following, failed from buildbot, were OK with my test script--

http://sourceforge.net/projects/oooextras.mirror/files/2ab442d169156f34c379c968f3f482dd-zlib-1.2.7.tar.bz2


http://sourceforge.net/projects/oooextras.mirror/files/52654eb3b2e60c35731ea8fc87f1bd29-jpeg-8d.tar.gz

http://sourceforge.net/projects/oooextras.mirror/files/dd7dab7a5fea97d2a6a43f511449b7cd-expat-2.1.0.tar.gz

I kind of gave up on boost because it was taking a very long time.

...and I didn't continue since my preliminary testing seemed to go OK.

On a related matter, we do have quite a number of download errors
with the URL1 values for some of our older external packs.



-- 
--------------------------------------------
MzK

"Though no one can go back and make a brand new start,
 anyone can start from now and make a brand new ending."
                            -- Carl Bard

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message