openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patricia Shanahan <p...@acm.org>
Subject Re: Building on Windows
Date Mon, 15 Feb 2016 01:29:29 GMT
On 2/14/2016 1:34 PM, Patricia Shanahan wrote:
>
>
> On 2/14/2016 1:32 PM, Patricia Shanahan wrote:
>> On 2/5/2016 6:55 AM, Damjan Jovanovic wrote:
>>> On Fri, Feb 5, 2016 at 4:52 PM, Regina Henschel
>>> <rb.henschel@t-online.de>
>>> wrote:
>>>
>>>> Hi Patricia,
>>>>
>>>> Patricia Shanahan schrieb:
>>>>
>>>>> My build finished!
>>>>>
>>>>> The next problem is to run it. I have hit two problems, one minor. The
>>>>> minor problem is that
>>>>>
>>>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7
>>>>>
>>>>>
>>>>> has incorrect paths using "OpenOffice" rather than
>>>>> "Apache_OpenOffice".
>>>>>
>>>>> The more serious problem is that there does not seem to be a zip file
>>>>> for running without actually installing.
>>>>>
>>>>
>>>> You are right, there is only the folder en-US (or your preferred
>>>> language)
>>>> in instset-native/wntmsci12/Apache_OpenOffice. You can use the setup
>>>> or the
>>>> msi-file to make an administrative installation.
>>>>
>>>> When you have got the installation, then when you made changes, then
>>>> it is
>>>> enough to drop those files from solver/420/wntmsci12/bin into your
>>>> installation, which have changed. Most times that are only a few dlls.
>>>>
>>>> LibreOffice generates a folder with an immediately executable
>>>> soffice.exe.
>>>> So there might exist a configure switch for that in Apache OpenOffice
>>>> too,
>>>> but I don't know.
>>>>
>>>>
>>> If you mean --with-package-format="installed" to ./configure (IIRC the
>>> default is archive, but you can --with-package-format="archive
>>> installed"
>>> to get both) then yes we do have it.
>>
>> I tried adding --with-package-format="archive installed" to my configure
>> parameters, and still don't get a .zip file.
>
> Scrub that. I am not 100% sure I re-ran configure before building :-(

It works fine if I configure before building. I now have both a zip 
file, for copying to other systems, and a ready-to-run version.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message