openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patricia Shanahan <p...@acm.org>
Subject Re: Building on Windows
Date Wed, 03 Feb 2016 11:37:17 GMT
Yes, there is certainly stuff to investigate. My latest failure is:

/usr/bin/cp: missing destination file operand after 
'/cygdrive/c/OpenOfficeDev/Trunk/main/solver/420/wntmsci12.pro/lib/isvl.lib'
Try '/usr/bin/cp --help' for more information.
C:/OpenOfficeDev/Trunk/main/solenv/gbuild/StaticLibrary.mk:45: recipe 
for target 
'/cygdrive/c/OpenOfficeDev/Trunk/main/solver/420/wntmsci12.pro/lib/isvl.lib' 
failed
make: *** 
[/cygdrive/c/OpenOfficeDev/Trunk/main/solver/420/wntmsci12.pro/lib/isvl.lib] 
Error 1
dmake:  Error code 2, while making 'all'

1 module(s):
         xmloff
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making 
/cygdrive/c/OpenOfficeDev/Trunk/main/xmloff/prj

When you have fixed the errors in that module you can resume the build 
by running:

         build --all:xmloff


On 2/3/2016 3:33 AM, Damjan Jovanovic wrote:
> main/oox/prj/build.lst already lists xmlscript as a dependency, so "build"
> should have built it before starting to build oox. Something must be very
> wrong for it not to.
>
> On Wed, Feb 3, 2016 at 1:28 PM, Patricia Shanahan <pats@acm.org> wrote:
>
>> Yes, thanks. At least, it gets past oox.
>>
>> So one trick for a missing file is to explicitly build and deliver in the
>> directory the file should have come from.
>>
>> Later, I may do a new build from a clean check-out, and try to investigate
>> anomalies. Right now, my objective is to just get it built.
>>
>>
>> On 2/3/2016 3:19 AM, Damjan Jovanovic wrote:
>>
>>> That is strange. Does it work if you first do "build" and "deliver" in
>>> main/xmlscript?
>>>
>>> On Wed, Feb 3, 2016 at 1:07 PM, Patricia Shanahan <pats@acm.org> wrote:
>>>
>>> I am now getting to:
>>>>
>>>> Compiling: oox/source/ole/vbacontrol.cxx
>>>> C:/OpenOfficeDev/Trunk/main/oox/source/ole/vbacontrol.cxx(34) : fatal
>>>> error C1083: Cannot open include file: 'xmlscript/xmldlg_imexp.hxx': No
>>>> such file or directory
>>>> dmake:  Error code 2, while making '../../
>>>> wntmsci12.pro/slo/vbacontrol.obj
>>>> '
>>>>
>>>> 1 module(s):
>>>>           oox
>>>> need(s) to be rebuilt
>>>>
>>>> Reason(s):
>>>>
>>>> ERROR: error 65280 occurred while making
>>>> /cygdrive/c/OpenOfficeDev/Trunk/main/oox/source/ole
>>>>
>>>>
>>>>
>>>> On 2/2/2016 9:33 PM, Patricia Shanahan wrote:
>>>>
>>>> python had apparently not been built. I don't know why. I was able to
>>>>> get the build going again with "build --all:python".
>>>>>
>>>>> It is now making progress, but from time-to-time I get this sort of
>>>>> failure:
>>>>>
>>>>> ======================================================================
>>>>> c:/OpenOfficeDev/Trunk/main/svl/source/numbers/zformat.cxx(25) : fatal
>>>>> error C1859:
>>>>> 'c:/OpenOfficeDev/Trunk/main/solver/420/
>>>>> wntmsci12.pro/workdir/PrecompiledHeader/nodebug/precompiled_svl.hxx.pch
>>>>> '
>>>>> unexpected precompiled header error, simply rerunning the compiler might
>>>>> fix this problem
>>>>> C:/OpenOfficeDev/Trunk/main/solenv/gbuild/LinkTarget.mk:126: recipe for
>>>>> target
>>>>> '/cygdrive/c/OpenOfficeDev/Trunk/main/solver/420/
>>>>> wntmsci12.pro/workdir/CxxObject/svl/source/numbers/zformat.o'
>>>>> failed
>>>>> make: ***
>>>>> [/cygdrive/c/OpenOfficeDev/Trunk/main/solver/420/
>>>>> wntmsci12.pro/workdir/CxxObject/svl/source/numbers/zformat.o]
>>>>> Error 2
>>>>> dmake:  Error code 2, while making 'all'
>>>>>
>>>>> 1 module(s):
>>>>>            svl
>>>>> need(s) to be rebuilt
>>>>>
>>>>> Reason(s):
>>>>>
>>>>> ERROR: error 65280 occurred while making
>>>>> /cygdrive/c/OpenOfficeDev/Trunk/main/svl/prj
>>>>>
>>>>> When you have fixed the errors in that module you can resume the build
>>>>> by running:
>>>>>
>>>>>            build --all:svl
>>>>> ======================================================================
>>>>>
>>>>> The build system knows the failure is potentially retriable. It tells
me
>>>>> exactly what to type to do the retry. WHY can't it just retry itself,
>>>>> without needing my fingers on the keyboard?
>>>>>
>>>>>
>>>>>
>>>>> On 2/2/2016 8:10 AM, Patricia Shanahan wrote:
>>>>>
>>>>> OpenGrok looks and sounds like something I should learn about.
>>>>>>
>>>>>> I think my next step is to look into the state of python. Matters
may
>>>>>> have been complicated because I did a "dmake clean" after changing
my
>>>>>> configure parameters to use a 32 bit JDK, before continuing the steps
>>>>>> from configure on.
>>>>>>
>>>>>> There may be a pause - I have some non-programming stuff to do today
>>>>>> and
>>>>>> tomorrow morning.
>>>>>>
>>>>>> Thanks for all the help. Posting immediately on hitting a problem
is
>>>>>> definitely getting faster progress than when I tried to puzzle things
>>>>>> out for myself first.
>>>>>>
>>>>>> On 2/2/2016 6:39 AM, Damjan Jovanovic wrote:
>>>>>>
>>>>>> OpenGrok[1] tells me the pyversion.mk file is in main/python; through
>>>>>>> building it would get delivered to main/solver/... and found
by pyuno.
>>>>>>> Did
>>>>>>> python not build before pyuno did? pyuno/prj/build.lst lists
a
>>>>>>> dependency
>>>>>>> on python when PYTHON is defined[2]:
>>>>>>>
>>>>>>> bgpu    pyuno   :   stoc cpputools cppuhelper bridges tools
>>>>>>> PYTHON:python
>>>>>>> LIBXSLT:libxslt NULL
>>>>>>>
>>>>>>> but earlier you posted your config.log which had this in it:
>>>>>>>
>>>>>>> PYTHON=''
>>>>>>>
>>>>>>> and I am not sure whether that's enough. If the problem is that
the
>>>>>>> python
>>>>>>> module isn't getting built first, you can force it to build first
>>>>>>> through
>>>>>>> one of these hacks:
>>>>>>> * delete the "PYTHON:" prefix to "python" from the build.lst
line
>>>>>>> * manually building python before resuming the build:
>>>>>>> cd main/python
>>>>>>> build
>>>>>>> deliver
>>>>>>> cd ../instsetoo_native
>>>>>>> build --all -P2 -- -P2
>>>>>>>
>>>>>>> References:
>>>>>>> [1]
>>>>>>>
>>>>>>>
>>>>>>> http://opengrok.adfinis-sygroup.org/source/search?q=&defs=&refs=&path=pyversion.mk&hist=&project=aoo-trunk
>>>>>>>
>>>>>>>
>>>>>>> [2]
>>>>>>>
>>>>>>>
>>>>>>> http://opengrok.adfinis-sygroup.org/source/xref/aoo-trunk/main/pyuno/prj/build.lst
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Tue, Feb 2, 2016 at 4:21 PM, Patricia Shanahan <pats@acm.org>
>>>>>>> wrote:
>>>>>>>
>>>>>>> Thanks. Now I get to:
>>>>>>>
>>>>>>>>
>>>>>>>> =============
>>>>>>>> Building module pyuno
>>>>>>>> =============
>>>>>>>>
>>>>>>>> Entering /cygdrive/c/OpenOfficeDev/Trunk/main/pyuno/source/module
>>>>>>>>
>>>>>>>> mkout -- version: 1.8
>>>>>>>> dmake:  makefile.mk:  line 56:  Error: -- Include file pyversion.mk,
>>>>>>>> not
>>>>>>>> found
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On 2/2/2016 4:18 AM, Damjan Jovanovic wrote:
>>>>>>>>
>>>>>>>> For me, main/icu fails to build on Windows about 50% of the
time
>>>>>>>>
>>>>>>>>> for no
>>>>>>>>> apparent reason; I've begun to think it's some sort of
build race
>>>>>>>>> condition
>>>>>>>>> within that module. I haven't seen the buildbots fail
there, and
>>>>>>>>> nobody
>>>>>>>>> else has reported this problem.
>>>>>>>>>
>>>>>>>>> If this is your problem, the only fix I know is the following
hack:
>>>>>>>>>
>>>>>>>>> cd main/icu
>>>>>>>>>
>>>>>>>>> then keep cleaning and rebuilding it until it builds
successfully:
>>>>>>>>>
>>>>>>>>> rm -rf wntmsci12.pro
>>>>>>>>> one of: dmake / build -P2 / build -- -P2 / build -P2
-- -P2
>>>>>>>>>
>>>>>>>>> then when it does, continue as before:
>>>>>>>>>
>>>>>>>>> cd ../instsetoo_native
>>>>>>>>> build --all -P2 -- -P2
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Tue, Feb 2, 2016 at 2:00 PM, Patricia Shanahan <pats@acm.org>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>> Good. My latest error is:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> NMAKE : fatal error U1073: don't know how to make
>>>>>>>>>> '".\..\..\lib\icuin.lib"'
>>>>>>>>>> Stop.
>>>>>>>>>> NMAKE : fatal error U1077:
>>>>>>>>>> 'C:\PROGRA~2\MICROS~1.0\VC\bin\nmake.exe' :
>>>>>>>>>> return code '0x2'
>>>>>>>>>> Stop.
>>>>>>>>>> dmake:  Error code 2, while making './
>>>>>>>>>> wntmsci12.pro/misc/build/so_built_so_icu'
>>>>>>>>>>
>>>>>>>>>> I am hoping after this is all done to add a section
on gotchas and
>>>>>>>>>> their
>>>>>>>>>> symptoms to the step-by-step guide. That may save
future new
>>>>>>>>>> developers
>>>>>>>>>> some time.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On 2/2/2016 3:32 AM, Damjan Jovanovic wrote:
>>>>>>>>>>
>>>>>>>>>> I've documented this gotcha on both
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> and
>>>>>>>>>>> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>>>>>>>>>
>>>>>>>>>>> On Tue, Feb 2, 2016 at 10:29 AM, Patricia Shanahan
<pats@acm.org>
>>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>> Thanks.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>> On 2/1/2016 11:50 PM, Damjan Jovanovic wrote:
>>>>>>>>>>>>
>>>>>>>>>>>> According to
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> http://stackoverflow.com/questions/19641685/java-jni-jawt-error-unresolved-external-symbol-imp-jawt-getawt8
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> you're using a 64 bit JDK instead of
a 32 bit one.
>>>>>>>>>>>>>
>>>>>>>>>>>>> On Tue, Feb 2, 2016 at 9:40 AM, Patricia
Shanahan <pats@acm.org
>>>>>>>>>>>>>>
>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>> After checking out with Cygwin's svn
rather than TortoiseSVN, my
>>>>>>>>>>>>> build
>>>>>>>>>>>>>
>>>>>>>>>>>>> failed in "Building module bean" with
the following message:
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>>          Creating library
>>>>>>>>>>>>>> ../../wntmsci12.pro/lib/iofficebean_t1.lib
>>>>>>>>>>>>>> and
>>>>>>>>>>>>>> object
>>>>>>>>>>>>>> ../../wntmsci12.pro/lib/iofficebean_t1.exp
>>>>>>>>>>>>>> officebean.lib(com_sun_star_comp_beans_LocalOfficeWindow.obj)
:
>>>>>>>>>>>>>> error
>>>>>>>>>>>>>> LNK2019: unresolved external symbol
__imp__JAWT_GetAWT@8
>>>>>>>>>>>>>> referenced
>>>>>>>>>>>>>> in
>>>>>>>>>>>>>> function
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> _Java_com_sun_star_comp_beans_LocalOfficeWindow_getNativeWindow@8
>>>>>>>>>>>>>> ../../wntmsci12.pro/bin/officebean.dll
: fatal error LNK1120:
>>>>>>>>>>>>>> 1
>>>>>>>>>>>>>> unresolved externals
>>>>>>>>>>>>>> dmake:  Error code 96, while making
'../../
>>>>>>>>>>>>>> wntmsci12.pro/bin/officebean.dll'
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> ---------------------------------------------------------------------
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>>>>>>>>>>> For additional commands, e-mail:
>>>>>>>>>>>>>> dev-help@openoffice.apache.org
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> ---------------------------------------------------------------------
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>>>>>>>>>>
>>>>>>>>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>> ---------------------------------------------------------------------
>>>>>>>>>>>
>>>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>>>>>>>>
>>>>>>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>> ---------------------------------------------------------------------
>>>>>>>>>
>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>
>>>>
>>>>
>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message