openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "j.nitschke@ok.de" <j.nitsc...@ok.de>
Subject Re: Building on Windows
Date Mon, 01 Feb 2016 22:41:08 GMT
On Mon, 1 Feb 2016 14:08:06 -0800 Patricia Shanahan wrote:
>
>
> On 2/1/2016 12:04 PM, Patricia Shanahan wrote:
>>
>>
>> On 1/31/2016 6:36 PM, Patricia Shanahan wrote:
>>> Now I'm stuck. I got through configure, with warnings. My build attempt
>>> failed with:
>>>
>>> $ build --all
>>> build -- version: 275224
>>>
>>>
>>> =============
>>> Building module solenv
>>> =============
>>>
>>> Entering /cygdrive/c/OpenOfficeDev/Trunk/main/solenv
>>>
>>> /cygdrive/c/OpenOfficeDev/Trunk/main/solenv/bin/mkout.pl: line 1:
>>> $':\r': command not found
>>> mkout -- version: 1.8
>>
>> The perl module mkout.pl starts with:
>>
>> :
>> eval 'exec perl -wS $0 ${1+"$@"}'
>>      if 0;
>>
>>
>> My Perl is very rusty. Can anyone translate? Especially, the initial
>> line with just a ":" confuses both me and the build.
>
> I took my problem to StackOverflow. See
> http://stackoverflow.com/a/35140265/1798593
>
> I worked around it by setting igncr in my Cygwin bash SHELLOPTS, and
> the build is now building.
>
> Patricia
interesting, how did you checkout the source?

I remember TortoiseSVN converted unix line endings to windows style
unless told otherwise. The original git-scm asks on installation how to
treat line endings. No idea how the cygwin subverion and git packages
behave.

You might run into other unexpected problems due line endings. (e.g.
scripts replacing \n with \r\n for windows)
I would checkout the source again.


Mime
View raw message