openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Marshall <j_k_marshall_2...@live.com>
Subject Re: Build Problem (solved)
Date Sat, 08 Aug 2015 17:36:03 GMT
Hi Regina


Thank you for the advice here.  I followed what you said and moved the source into the root
of C drive, placing it in a directory with no special characters.  I did subsequently encounter
an issue with building the modules associated with the SDK, but I re-ran configure with SDK
disabled using the --disable-odk command.  Accordingly, the build completed and I was able
to install from the build.


I will not move onto some of the tutorials kindly provided on the OO wiki and have a go at
hacking some of the code on my own computer.  Hopefully from there I can tackle some of the
smaller issues identified on Bugzilla and so make a meaningful contribution.


Best regards


Jason






Sent from Windows Mail





From: Regina Henschel
Sent: ‎Tuesday‎, ‎21‎ ‎July‎ ‎2015 ‎12‎:‎51
To: dev@openoffice.apache.org





Hi Jason,

Jason Marshall schrieb:
> Hi Regina
>
> Thank you for looking at this.  I have ensured that with a new Cygwin
> session I have run the following successfully:
>
>     /source winenv.set.sh/
>
>
> Following that, I have run the following:
>
>     /build --all:comphelper 2>&1 | tee mybuild.log/
>
>
> The build again did not progress past building the 'comphelper' module
> and appeared to have the same error as previously.  However, I have
> attached the log file, 'mybuild.log' that was produced.
>
> When I ran the 'configure' command, I ran this with the following
> parameters:
>
>     /./configure --with-frame-home="$SDK_PATH"
>     --with-psdk-home="$SDK_PATH" --with-midl-path="$SDK_PATH/bin"
>     --with-ant-home="/cygdrive/c/ant"
>     --with-jdk-home="/cygdrive/c/Java/jdk1.8.0_45"
>     --with-dmake-url="//https://github.com/mohawk2/dmake/archive/DMAKE_4_12.tar.gz//"
>     --with-epm-url="//https://www.msweet.org/files/project2/epm-4.2-source.tar.gz//"
>     --enable-pch --disable-atl --disable-activex --without-junit
>     --disable-directx/

Please try with removed --enable-pch
"pch" is "precompiled header support"

--with-epm-url is not needed for Windows builds.

You might want to add --without-fonts, download of "gentium" sometimes 
fails.

>
>
> I have also included as a file attachment the output of running
> 'configure' and can confirm that no errors were generated, although two
> warnings were as follows, which appear to not be related to the issue here:
>
>     /checking which cppunit to use... configure: WARNING: not using cppunit/
>     /configure: WARNING: NSIS not found, no self contained installer
>     will be build./
>
>
> I also note from the 'configure' output that the source code is
> identified as being in the 'tmp' directory as follows:
>
>     /The variable SRC_ROOT          is set to: C:/cygwin/tmp/aoo-4.1.1/main/
>
>
> Do you think that it may be better for me to delete the part of the
> build that has succeeded and then unpack the source into another
> directory that is not temp?  If so, would this simply be to the root of
> the Cygwin file system?

Yes, I think it is better to put the source not under tmp or any other 
directory, which is set somewhere as temp-directory.

I have always use a directory directly under C:
I have always use names without special characters.
I have never tried to put the source somewhere inside cygwin, so I 
cannot say, whether that is possible.

To test, whether the tmp directory is the problem, please move the 
folder aoo-4.1.1 under C: and rename it to e.g. aoo411

You need to remove all remainders of previous build tries then.
In cygwin change to the main folder of your source, then use the 
following command (all in one line)
find . -maxdepth 2 -name "wntmsci12*" | xargs rm -rf

In addition you have to manually delete the wntmsci12* folders
in main/solver
in all subfolders of ext_libraries
in all subfolders of extras

Start with a new configure with parameters.

Hopefully it works better then.

Kind regards
Regina





---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message