openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@FreeBSD.org>
Subject Re: build breaker/Issue 126449/ svx module
Date Sun, 09 Aug 2015 05:41:28 GMT
On  8 Aug, Martin Bakker wrote:
> Hi There,
> 
> I'm a developer using  AOO in some of my applications.
> To debug some AOO problems I decided to build AOO with symbols to try and 
> find a solution.
> I followed the instructions on how to build  but got stuck  when trying to 
> build the svx module.
> used svn to get fresh start and tried building without debug, same problem.
> 
> 
> I opend an Issue  on bugzilla but was kindly directed this way.
> 
> see the issue for a complete log.
> configure was run like: 
> configure --with-package-format="installed" --disable-gnome-vfs
> 
> trying to build fails with :
> 
> [ build LNK ] Library/libsvxcore.so
> /home/martin/Downloads/aoo/main/solver/420/unxlngx6.pro/workdir/CxxObject/svx/source/fmcomp/fmgridif.o:

> In function 
> `FmXGridControl::createPeer(com::sun::star::uno::Reference<com::sun::star::awt::XToolkit>

> const&, com::sun::star::uno::Reference<com::sun::star::awt::XWindowPeer> 
> const&)':
> fmgridif.cxx:(.text+0x68b2): undefined reference to `non-virtual thunk to 
> WindowListenerMultiplexer::acquire()'
> /usr/bin/ld: 
> /home/martin/Downloads/aoo/main/solver/420/unxlngx6.pro/workdir/CxxObject/svx/source/fmcomp/fmgridif.o:

> relocation R_X86_64_PC32 against undefined symbol 
> `_ZThn48_N25WindowListenerMultiplexer7acquireEv' can not be used when making 
> a shared object; recompile with -fPIC

Looks like you are compiling with gcc 4.9.  I ran into this same problem
on FreeBSD and worked around it by changing the "-Os" optimization flag
in main/solenv/gbuild/platform/freebsd.mk and
main/solenv/inc/unxfbsdi.mk to:
	"-Os -fno-devirtualize -fno-devirtualize-speculatively"
The files controlling this on your platform will be different.

This is a gcc bug, see:
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65009>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message