openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@FreeBSD.org>
Subject Re: Are the Buildbots down?
Date Tue, 14 Jul 2015 05:49:01 GMT
Next problem ...

libxml2 deliver
deliver -- version: 275594
Module 'libxml2' delivered successfully. 50 files copied, 2 files unchanged

=============
Building module libxslt
=============

[snip]

Disabling crypto support
Enabling debugger
checking for libxml libraries >= 2.6.27... 2.7.8 found
checking whether shared libraries will be built (required for plugins)... yes
checking libxml2 module support... yes
configure: creating ./config.status

[snip]

/bin/sh ../libtool --tag=CC   --mode=link cc  -g -O2 -Wall  -Wl,--version-script
=./libxslt.syms -version-info 2:26:1 -Wl,-rpath,'$ORIGIN:$ORIGIN/../ure-link/lib
' -Wl,-noinhibit-exec -o libxslt.la -rpath /usr/local/lib attrvt.lo xslt.lo xslt
locale.lo xsltutils.lo pattern.lo templates.lo variables.lo keys.lo numbers.lo e
xtensions.lo extra.lo functions.lo namespaces.lo imports.lo attributes.lo docume
nts.lo preproc.lo transform.lo security.lo -L/tmp/openoffice/aoo-4.2.0/main/solv
er/420/unxfbsdx.pro/lib -lxml2 -lm
libtool: link: cc -shared  .libs/attrvt.o .libs/xslt.o .libs/xsltlocale.o .libs/
xsltutils.o .libs/pattern.o .libs/templates.o .libs/variables.o .libs/keys.o .li
bs/numbers.o .libs/extensions.o .libs/extra.o .libs/functions.o .libs/namespaces
.o .libs/imports.o .libs/attributes.o .libs/documents.o .libs/preproc.o .libs/tr
ansform.o .libs/security.o   -L/tmp/openoffice/aoo-4.2.0/main/solver/420/unxfbsd
x.pro/lib -lxml2 -lm  -Wl,--version-script=./libxslt.syms -Wl,-rpath -Wl,\$ORIGI
N:\$ORIGIN/../ure-link/lib -Wl,-noinhibit-exec   -Wl,-soname -Wl,libxslt.so.1 -o
 .libs/libxslt.so.1
/usr/bin/ld: cannot find -lxml2
cc: error: linker command failed with exit code 1 (use -v to see invocation)
Makefile:410: recipe for target 'libxslt.la' failed


% find . -name libtextcat.so -print
./libtextcat/unxfbsdx.pro/lib/libtextcat.so
./libtextcat/unxfbsdx.pro/misc/build/libtextcat-2.2/src/.libs/libtextcat.so
./solver/420/unxfbsdx.pro/lib/libtextcat.so
% find . -name libxml2.so -print
./libxml2/unxfbsdx.pro/lib/libxml2.so
./libxml2/unxfbsdx.pro/misc/build/libxml2-2.7.8/.libs/libxml2.so


Looks like libxml2.so didn't get copied over into solver for some
reason.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message