openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regina Henschel <rb.hensc...@t-online.de>
Subject Re: Fwd: Build Apache open office
Date Fri, 08 May 2015 10:24:42 GMT
Hi,

Nguyễn Đình Văn schrieb:
> ---------- Forwarded message ----------
> From: Nguyễn Đình Văn <dinhvanse@gmail.com>
> Date: 2015-05-07 14:40 GMT+07:00
> Subject: Build Apache open office
> To: dev-help@openoffice.apache.org, qa-help@openoffice.apache.org
>
>
> - I build source apache open office fllow :
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7.
> But when i run command :
>
> SDK_PATH="/cygdrive/c/Program\ Files/Microsoft\ SDKs/Windows/v7.0"
> ./configure \
>      --with-frame-home="/cygdrive/c/Program\ Files/Microsoft\
> SDKs/Windows/v7.0/Bin" \
>      --with-cl-home="/cygdrive/d/abc/abc/VC" \
>      --with-midl-path="/cygdrive/c/Program\ Files/java/Windows/v7.0/Bin" \

The --with-midl-path looks suspicious. The path to java should be in 
--with-jdk-home.
My current configure does not contain --with-midl-path at all, and in 
some older configure it points to "Microsoft SDKs"

>      --with-directx-home="/cygdrive/d/DXSDKInstalled" \
>      --with-ant-home="/cygdrive/c/apache-ant-1.9.4" \
>      --with-dmake-url="/cygdrive/c/dmake-4.12.tar.bz2" \
>      --with-epm-url="/cygdrive/c/epm-3.7-source.tar.gz" \
>      --enable-pch \
>      --disable-atl \
>      --disable-activex \
>      --without-junit
>
> Then output error message :
>
> can't find ms visual studio /vc++ at ./oowintool line 236 configure: error:
> oowintool failed to copy CRT

Are you sure, that escaping the blank in "Program\ Files" works? I have 
such paths without escaping but as simple "Program Files".

Kind regards
Regina


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message