openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hung Mark <mark...@gmail.com>
Subject Re: About debugging tokenizer of writerfilter
Date Sun, 10 Aug 2014 16:12:24 GMT
Hi Louis,


After I enable debug by 'build debug=t', I glimpsed the traceback message
with 'libre...'. (not very sure)
Then I reinstall my VM and delete all libreoffice.

Here is what I do and the resulting message. Well, I guess it's nothing to
do with libreoffice ;-(


mh@ubuntu:~/aoo/main/writerfilter/unxlngx6.pro/lib$ cp
libwriterfilter.uno.so /opt/openoffice4/program/
mh@ubuntu:~/aoo/main/writerfilter/unxlngx6.pro/lib$ cp libdoctok.so
libooxml.so  libresourcemodel.so /opt/openoffice4/program/
mh@ubuntu:~/aoo/main/writerfilter/unxlngx6.pro/lib$ cd -
/opt/openoffice4/program
mh@ubuntu:/opt/openoffice4/program$ ./uno -l libwriterfilter.uno.so -c
debugservices.doctok.ScannerTestService -- file:///home/mh/num.doc
Loading service: debugservices.doctok.ScannerTestService: 0x7fb356994f70
can't initialize UCB
mh@ubuntu:/opt/openoffice4/program$



2014-08-10 23:06 GMT+08:00 Louis Suárez-Potts <luispo@gmail.com>:

>
> > On 2014-08-10, at 09:54, Hung Mark <marklh9@gmail.com> wrote:
> >
> > Hi Peter and Regina,
> >
> > I realized that I might have skipped important steps.
> > Later on I built with debug=t and install the so file, it printed another
> > error message.
> > And I guess that pre-installed libreoffice in my ubuntu 12.04 might
> affect
> > the result.
>
> That's fairly interesting. Can you provide more information on that,
> perhaps in an issue report? I think that many have (or could have) similar
> experiences, as Ubuntu comes with LO.
>
> > I'm now rebuilding my environment.
> > I tried wiki, and I wonder if it is possible to get detail instructions
> > here.
>
> It is, if you also file an issue and just do the usual of reminding
> everyone :-)
>
> But also, your experiences can add usefully to any content in that wiki.
> It's a good "fail." :-)
>
>
> >
> >
> > Best Regards.
> >
> >
> best
> louis
>
>
> >
> > 2014-08-09 22:00 GMT+08:00 Regina Henschel <rb.henschel@t-online.de>:
> >
> >> Hi,
> >>
> >> Hung Mark schrieb:
> >>
> >> Hi,
> >>>
> >>> I tried to understand why my document doesn't format correctly.
> >>>
> >>> I followed steps on wiki :
> >>> https://wiki.openoffice.org/wiki/WriterFilter
> >>>
> >>>
> >>> ./uno -l libwriterfilter.so -c debugservices.ooxml.ScannerTestService
> --
> >>> file:///home/mark/num.docx
> >>>
> >>> error: libwriterfilter.so: cannot get factory of demanded
> implementation:
> >>>>
> >>> debugservices.ooxml.ScannerTestService
> >>>
> >>>> dying...
> >>>>
> >>> ./uno -l libwriterfilter.so -c debugservices.doctok.ScannerTestService
> --
> >>> file:///home/mark/num.doc
> >>>
> >>> error: libwriterfilter.so: cannot get factory of demanded
> implementation:
> >>>>
> >>> debugservices.doctok.ScannerTestService
> >>>
> >>>> dying...
> >>>>
> >>>
> >>> Is the document outdated or did I miss anything?
> >>>
> >>>
> >> I cannot help you in using uno, but if your document looks different in
> MS
> >> Word and OpenOffice, you should write a bug report. Reduce the document
> to
> >> the relevant parts and attach the reduced document to your report.
> Please
> >> specify in the bug report the program and version you have used to
> produce
> >> the document.
> >>
> >> There will be a release candidate of the version 4.1.1 soon (around end
> of
> >> next week). You should try that version too.
> >>
> >> Kind regards
> >> Regina
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> >> For additional commands, e-mail: dev-help@openoffice.apache.org
> >>
> >>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message