openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver-Rainer Wittmann <orwittm...@googlemail.com>
Subject Re: [Build] Modifying oowintool
Date Thu, 28 Aug 2014 07:26:31 GMT
Hi,

On 27.08.2014 20:52, Michal Hriň wrote:
> Hi,
>
> I'm trying to compile OO on Windows, specifically 8.1.
>

for building AOO on Windows you currently need the Visual Studio 2008 
C++ compiler.
On [1] you will find the Windows specific build requirements. The 
Microsoft Windows SDK for Windows 7 and .NET Framework 3.5 SP1 brings 
the compiler.

For debugging you can use one of the latest Visual Studio versions, even 
the Express editions.

[1] 
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Building_on_Windows


Best regards, Oliver.


> The problem is that Microsoft provides on the top page only Visual
> Studio 2013, and 2010. I'm using free Express edition.
>
> Configure stops every time on compiler. When was used 2010 compiler,
> configure says that the version is less than required.
>
> So I went forward with 2013.
>
> But now I don't have an idea how to solve the problem,
> probably in "oowintool" script
>
> https://fisheye6.atlassian.com/browse/ooo/main/oowintool?r=1413471
>
> Configure stops an says:
>
> --
> checking for bash... /usr/bin/bash
> checking ml.exe assembler path... checking for ml.exe... no
> found (/cygdrive/c/Program Files (x86)/Microsoft Visual Studio 12.0/VC/bin)
>
> checking for zip... /usr/bin/zip
> checking for unzip... /usr/bin/unzip
> checking for dbghelp.dll... found and executable
> checking for vcredist_x86.exe... found and executable
> checking for vcredist_x64.exe... found and executable
> Can't find MS Visual Studio / VC++ at ./oowintool line 248.
> configure: error: oowintool failed to copy CRT
>
> --
>
> so I opened this script and saw that it didn't recognize my 2013
> compiler so I tried to edit it, but it still not works.
>
> I modified script around line 208, where I added :
> --
> my %msvs_express_2013 = (
>      'ver' => '12.0',
>      'key' => 'Microsoft/VDExpress/12.0_Config/Setup/VS/ProductDir',
>      'dll_path' => 'VC/redist/x86/Microsoft.VC120.CRT',
>      'dll_suffix' => '120'
> );
> my %msvc_express_2013 = (
>      'ver' => '12.0',
>      'key' => 'Microsoft/VDExpress/12.0_Config/Setup/VC/ProductDir',
>      'dll_path' => 'redist/x86/Microsoft.VC120.CRT',
>      'dll_suffix' => '120'
> );
>
> sub find_msvs()
> {
>      my @ms_versions = ( \%msvs_express_2013, \%msvs_2008,
> \%msvs_express_2008, \%msvs_2005, \%msvs_express_2005,
> \%msvs_net_2003_ea, \%msvs_net_2003 );
>
>      for $ver (@ms_versions)
>      {
>      my $install = reg_get_value ("HKEY_CURRENT_USER/Software/" .
> $ver->{'key'});
>      if (defined $install && $install ne '') {
>          $ver->{'product_dir'} = $install;
>          return $ver;
>      }
>      }
>      die "Can't find MS Visual Studio / VC++";
> }
>
> sub find_msvc()
> {
>      my @ms_versions = ( \%msvc_express_2013, \%msvc_2008,
> \%msvc_express_2008, \%msvc_2005, \%msvc_express_2005, \%msvc_net_2003 );
>
>      for $ver (@ms_versions)
>      {
>      my $install = reg_get_value ("HKEY_CURRENT_USER/Software/" .
> $ver->{'key'});
>      if (defined $install && $install ne '') {
>          $ver->{'product_dir'} = $install;
>          return $ver;
>      }
>      }
>      die "Can't find MS Visual Studio / VC++";
> }
> --
>
> Any ideas ?
>
> Regards,
> Michal Hriň
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message