openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Herbert Duerr <...@apache.org>
Subject Re: buildbot success in ASF Buildbot on openoffice-linux64-nightly
Date Mon, 19 May 2014 07:06:11 GMT
On 16.05.2014 11:10, Herbert Duerr wrote:
> On 15.05.2014 07:54, Ariel Constenla-Haile wrote:
>> On Tue, Apr 15, 2014 at 08:42:12AM +0000, buildbot@apache.org wrote:
>>> Hi! , The openoffice-linux64-nightly builder has just completed a run
>>>
>>> STATUS: Success
>>>  [...]
>>
>> This last mail was from a month ago, aren't the build bots sending this
>> notification any longer?
>
> [...]
> So the main suspect is AOO's custom messageFormatter. Maybe it throws an
> exception that is internally caught by the buildbot software? Since we
> don't have access (AFAIK) to the buildbot's stderr output we have to
> guess. In revision 908989 I disabled our custom messageFormatter for
> now. Let's see how if we can narrow down the problem in this way.

So my hypothesis that the custom message formatter caused the problem 
was apparently correct: The messages are now sent again after I 
(temporarily?) changed the mail notifier configuration to use the 
default message formatter. The difference can be seen in [1] (default) 
and [2] (custom). The default formatter produces a quite good message so 
that I suggest to keep it as is. Fixing the original problem when access 
to stderr or the bbot's internal log isn't available isn't worth the 
trouble.

[1] 
http://mail-archives.apache.org/mod_mbox/openoffice-commits/201404.mbox/%3C20140401083733.90BA5C015E%40aegis.apache.org%3E
[2] 
http://mail-archives.apache.org/mod_mbox/openoffice-commits/201405.mbox/%3C201405170844.s4H8iVoY084114@aegis.apache.org%3E

Herbert

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message