openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer <awf....@gmail.com>
Subject Re: dmake clean
Date Wed, 19 Feb 2014 07:55:51 GMT
On 19.02.2014 00:48, Kay Schenk wrote:
> On Tue, Feb 18, 2014 at 3:01 PM, Steele, Raymond <raymond.steele@lmco.com>wrote:
>
>> I see in the Makefile:
>>
>> clean .PHONY
>>
>>                  -rm -rf */$(INPATH)
>>                  -rm -rf solver/*/$(INPATH)
>>
>> I am going to make an assumption that I performed the dmake clean and
>> $INPATH was not set, therefore  rm -rf */ was performed????
>>
>> From: Steele, Raymond
>> Sent: Tuesday, February 18, 2014 3:58 PM
>> To: dev@openoffice.apache.org
>> Subject: dmake clean
>>
>> I am not sure why, but I just did a dmake clean in ../main and once if
>> finished all the module directories including source was deleted.
>> Thankfully, I had a backup.  Can anyone explain this?
>>
>> Raymond
>>
>>
> Hello Raymond --
>
> Yes, an incredibly annoying thing and one I have experienced as well.
>
>   If you "source" your env script and THEN do "dmake clean", only the bits
> generated toward the native build will disappear. The clean script does a
> MUCH bigger remove if you don't do that first. The first time this happened
> to me, I freaked a bit, but as I hadn't made any local mods, an svn update
> got everything back.
>
>   It's good that you had a backup since I'm assuming you made local mods
> that you wanted to keep.  The build doc needs a bit of updating to help
> others avoid this pitfall.


Thanks for bringing this to my attention.  Up to now I thought that the 
worst that 'dmake clean' would do would be to delete dmake as well.
I will see what I can do.

-Andre

>
>
> Happy coding!
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message