openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer <awf....@gmail.com>
Subject Re: many many stlport issues...can anyone help
Date Wed, 20 Nov 2013 11:01:41 GMT
On 20.11.2013 09:54, Herbert Duerr wrote:
> On 20.11.2013 09:20, Andre Fischer wrote:
>> On 20.11.2013 08:33, Herbert Duerr wrote:
>>>
>>> Please use the --without-stlport configure switch.
>>>
>>> This option is the new default. Thanks to Jan for fixing configure.in.
>>> But you'd need to update to the newest trunk version to benefit from
>>> Jan's fix.
>>>
>>
>> Is there any reason why we still need this option (be it default or
>> not)?
>
> If there is a choice between step-wise evolution and a big-bang change 
> I'd always prefer the step-wise evolution.

I agree.  But I would like steps that go from valid state to valid 
state.  From what I have heard I had the impression that the 
--without-stlport option had only one valid value left and that using 
--with-stlport would break the build.

>
>>  Is there any scenario where we would need that switch to turn on
>> support for stlport?
>
> A developer reusing the latest recipes from our snapshots page would 
> fail with the latest trunk if the --without-stlport option was no 
> longer recognized.

Would it not be better to update the recipes?

I would assume that removing the configure option and adapting the build 
recipes take just a couple of hours to do.  Would it not be better to 
spend this additional time and make the change of removing support for 
stlport complete in one step?

-Andre


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message