openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Herbert Duerr <...@apache.org>
Subject Re: does something still depend on poppler?
Date Fri, 08 Nov 2013 09:56:55 GMT
Hi Pedro, hi Armin,

On 08.11.2013 10:06, Armin Le Grand wrote:
> On 07.11.2013 20:04, Pedro Giffuni wrote:
>> I just noticed on FreeBSD port we have a dependency on poppler-glib.
>> Opengrok reports it is detected in configure but it doesn't seem
>> to be used elsewhere.
>>
>> The poppler license is cat-x so it was probably removed before
>> graduation. Is it still useful at all?
>
> OpenGrok only gives trunk/main/configure.in and there is something like
> --with-system-poppler. I have not found a reaction on that flag, but I
> am no configure expert, so someone knowing that better (hdu?) should
> have a look...

Looking through the history the --with-system-poppler and 
--enable-pdf-import configure options seem to be remainders of the XPDF 
removal in the IP-Clearance phase that was done before our first 
release. https://issues.apache.org/ooo/show_bug.cgi?id=118592 has more 
details on that removal.

The developers that worked on XPDF removal (Andre and J├╝rgen) know 
probably better whether these options are still needed?

Herbert

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message