openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From janI <j...@apache.org>
Subject Re: [announce] genLang extract is ready.
Date Mon, 16 Sep 2013 08:17:34 GMT
On 16 September 2013 00:46, Andrea Pescetti <pescetti@apache.org> wrote:

> On 15/09/2013 janI wrote:
>
>  On 15 September 2013 00:49, janI wrote:
>>
>>> Please correct me, but fedora 19 is not part of our product release ? my
>>> aim is to support what AOO supports.
>>>
>>
> It is a standard Linux system, and OpenOffice should build and run on all
> recent Linux systems. For sure it would be a bug (unrelated to this
> discussion) if our official RPM packages did not run on it.
>


But I don't believe we have "supported" and "unsupported" Linux systems, as
> in general any recent system with standard system tools will work. However,
> I perfectly understand that you must start with something, and starting
> with what the buildbots use is indeed the most reasonable choice. Then, if
> adaptations are needed, we can find the patterns and apply them.
>
>
OK, I simply dont have experience with fedora. I run with ubuntu 12.04, and
the comilers etc. that come with that. I build trunk several times a week
without problems, and of course also l10n40.

But anyhow it must work on other platforms as well.




>
>  my configure options are taken from our buildbot:
>>>
>>
> It breaks the same way on my system. I explicitly tried with both
> --with-stlport and --without-stlport since the default here depends on
> whether you build on a 32 bit or 64 bit system.
>
>
>  I need to support vc 6.0 since our
>>> buildbot uses that (even though its very outdated). Funny things here is
>>> that VC 6.0 adn 2012 are imcompatible.
>>>
>>
> This is something we can discuss. Supporting an obsolete compiler by being
> incompatible with a newer one is understandable only if there are
> advantages. I believe that other developers encountered this problem
> already; they will be able to give better advice.


The problem I had with VC6 was not access() as I thought, it was the std
namespace and a couple of class constructs I use.

It would be nice if we in general "upped" our compilers to the state of art.



>
>
>  function "access" is normally defined in sys/stat.h on linux. You need to
>> see in which include file access is defined on your system, and either add
>> an #ifdef for your system, or extend the include files.
>>
>
> Thanks for investigating. As for the patch, I already included earlier in
> this thread.
>

I have now added a #include <unistd.h>, it seems ubuntu 12.04 includes that
through another file.


>
> Then the build breaks in another file due to a conversion that my gcc does
> not support/admit, but this should be quite unrelated...


Now I have removed all warnings, so this is now one of the few modules
without warnings (actually that would be a good task for a new developer).

 R1523556 compiles without warnings on ubuntu 12.04 and windows7 (VC2012).

rgds
jan I.



@ariel wrote:

You should try to avoid all that system calls, the URE libraries have
a system abstraction layer to write portable code; vid.
http://www.openoffice.org/api/docs/cpp/ref/names/index.html

This would not be a good idea, the tool is specifically written so it is
indendent of all AOO libraries, thereby it can be placed anywhere in the
build stream. Using the URE libraries will as far as I can see add quite a
lot of dependencies.



>
>
> Regards,
>   Andrea.
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.**apache.org<dev-unsubscribe@openoffice.apache.org>
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message