openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 張仁瀚 <yohey03...@gmail.com>
Subject Re: ERROR when build AOO
Date Thu, 08 Aug 2013 15:38:31 GMT
Yeah! I built AOO and installed successfully on my linux system after
removed LibO!
Thanks for your help.


2013/8/8 edward <ekuang1@ucsc.edu>

> Thanks. Removing libreoffice did the job.
>
>
> On 08/07/2013 11:13 AM, Rory O'Farrell wrote:
>
>> On Wed, 7 Aug 2013 11:00:16 -0700
>> Edward Kuang <ekuang1@ucsc.edu> wrote:
>>
>>  I can confirm the same error
>>>
>>> $ sudo dpkg -i
>>> unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>> DEBS/desktop-integration/**openoffice4.0-debian-menus_4.**0-9702_all.deb<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/desktop-integration/openoffice4.0-debian-menus_4.0-9702_all.deb>
>>>
>>> Selecting previously unselected package openoffice-debian-menus.
>>> (Reading database ... 193152 files and directories currently installed.)
>>> Unpacking openoffice-debian-menus (from
>>> .../openoffice4.0-debian-**menus_4.0-9702_all.deb) ...
>>> dpkg: error processing
>>> unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>> DEBS/desktop-integration/**openoffice4.0-debian-menus_4.**
>>> 0-9702_all.deb(--install)<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/desktop-integration/openoffice4.0-debian-menus_4.0-9702_all.deb(--install)>
>>> :
>>>   trying to overwrite '/usr/bin/soffice', which is also in package
>>> libreoffice-common 1:3.5.7-0ubuntu4
>>> /usr/bin/gtk-update-icon-cache
>>> gtk-update-icon-cache: Cache file created successfully.
>>> /usr/bin/gtk-update-icon-cache
>>> gtk-update-icon-cache: Cache file created successfully.
>>> Processing triggers for shared-mime-info ...
>>> Processing triggers for hicolor-icon-theme ...
>>> Processing triggers for gnome-icon-theme ...
>>> Processing triggers for bamfdaemon ...
>>> Rebuilding /usr/share/applications/bamf.**index...
>>> Processing triggers for desktop-file-utils ...
>>> Processing triggers for gnome-menus ...
>>> Errors were encountered while processing:
>>>
>>> unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>> DEBS/desktop-integration/**openoffice4.0-debian-menus_4.**0-9702_all.deb<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/desktop-integration/openoffice4.0-debian-menus_4.0-9702_all.deb>
>>>
>>>
>>> On Wed, Aug 7, 2013 at 9:44 AM, 張仁瀚 <yohey03518@gmail.com> wrote:
>>>
>>>  Thanks for your help! It seems that I have build it successfully by
>>>> following
>>>> the same steps you used. And thanks Kay for telling me to check this url
>>>> again so I could fix the epm error.
>>>> Although I can build AOO without errors, I can't install it
>>>> successfully.
>>>> Nothing wrong happened when processing the step:
>>>> (cd to instsetoo_natives)
>>>> $ sudo dpkg -i unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>>> DEBS/*.deb<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/*.deb>
>>>>
>>>> But in this step, something heppened:
>>>> $ sudo dpkg -i
>>>>
>>>> unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>>> DEBS/desktop-integration/**openoffice4.0-debian-menus_4.**
>>>> 0-9702_all.deb<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/desktop-integration/openoffice4.0-debian-menus_4.0-9702_all.deb>
>>>>
>>>> (Reading database ... 214450 files and directories currently installed.)
>>>> Unpacking openoffice-debian-menus (from
>>>> .../openoffice4.0-debian-**menus_4.0-9702_all.deb) ...
>>>> dpkg: error processing
>>>>
>>>> unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>>> DEBS/desktop-integration/**openoffice4.0-debian-menus_4.**
>>>> 0-9702_all.deb(--install)<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/desktop-integration/openoffice4.0-debian-menus_4.0-9702_all.deb(--install)>
>>>> :
>>>>   trying to overwrite '/usr/bin/soffice', which is also in package
>>>> libreoffice-common 1:3.5.7-0ubuntu4
>>>> /usr/bin/gtk-update-icon-cache
>>>> gtk-update-icon-cache: Cache file created successfully.
>>>> /usr/bin/gtk-update-icon-cache
>>>> gtk-update-icon-cache: Cache file created successfully.
>>>> Processing triggers for bamfdaemon ...
>>>> Rebuilding /usr/share/applications/bamf.**index...
>>>> Processing triggers for desktop-file-utils ...
>>>> Processing triggers for gnome-menus ...
>>>> Processing triggers for shared-mime-info ...
>>>> Processing triggers for gnome-icon-theme ...
>>>> Processing triggers for hicolor-icon-theme ...
>>>> Errors were encountered while processing:
>>>>
>>>>
>>>> unxlngx6.pro/Apache_**OpenOffice/deb/install/en-US/**
>>>> DEBS/desktop-integration/**openoffice4.0-debian-menus_4.**
>>>> 0-9702_all.deb<http://unxlngx6.pro/Apache_OpenOffice/deb/install/en-US/DEBS/desktop-integration/openoffice4.0-debian-menus_4.0-9702_all.deb>
>>>>
>>>> $
>>>> ------------------------------**-------
>>>> It seems that I failed to install it. Also, installing terminaled even
>>>> if I
>>>> went to
>>>> the route where "openoffice4.0-debian-menus_4.**0-9702_all.deb" is and
>>>> then click it twice to open it.
>>>> How can I fix it?
>>>> Thanks again for your read and help.
>>>> Thanks!
>>>>
>>>> Regards,
>>>>    Yohey
>>>>
>>>>
>>>> 2013/8/7 Edward Kuang <ekuang1@ucsc.edu>
>>>>
>>>>  I had the same exact problem. I'm running ubuntu 64bit 12.04 not on a
>>>>> virtual machine. This is a completely fresh install of ubuntu. The
>>>>> steps
>>>>> I've done to try and build are
>>>>>
>>>>> cd to aoo-trunk/main
>>>>> $ autconf
>>>>> $ ./configure --with-dmake-url=
>>>>>
>>>>>
>>>>>  http://dmake.apache-extras.**org.codespot.com/files/dmake-**
>>>> 4.12.tar.bz2--with-epm-url=<http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2--with-epm-url=>
>>>> http://epm.sourcearchive.com/**downloads/3.7-1/epm_3.7.orig.**
>>>> tar.gz--disable-odk<http://epm.sourcearchive.com/downloads/3.7-1/epm_3.7.orig.tar.gz--disable-odk>
>>>>
>>>>> --disable-binfilter
>>>>> $ ./bootstrap
>>>>> $ source LinuxX86-64Env.Set.sh
>>>>> $ cd instsetoo_native/
>>>>> $ build --all
>>>>>
>>>>> I get the same exact error that says epm not found IF I used the
>>>>> epm-url
>>>>> above. But I used --with-epm-url=
>>>>> http://www.msweet.org/files/**project2/epm-3.7-source.tar.gz<http://www.msweet.org/files/project2/epm-3.7-source.tar.gz>from
this
>>>>>
>>>> page
>>>>
>>>>> http://wiki.openoffice.org/**wiki/Documentation/Building_**Guide_AOO<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO>during
>>>>>
>>>> a
>>>>
>>>>> second run through. It's been building for a while now and looks like
>>>>>
>>>> it's
>>>>
>>>>> working at least.
>>>>>
>>>>>
>>>>>
>>>>> On Tue, Aug 6, 2013 at 4:41 PM, Kay Schenk <kay.schenk@gmail.com>
>>>>> wrote:
>>>>>
>>>>>  On Tue, Aug 6, 2013 at 1:07 AM, 張仁瀚 <yohey03518@gmail.com>
wrote:
>>>>>>
>>>>>>  Hello everyone,
>>>>>>>
>>>>>>> My name is Yohey, and I come from Taiwan.I am a "freshman" in
AOO.
>>>>>>> I use Ubuntu Linux as my environment, which version is 12.04.
I
>>>>>>>
>>>>>> follow
>>>>
>>>>> the following web to build AOO:
>>>>>>>
>>>>>>>
>>>>>>>  http://wiki.openoffice.org/**wiki/Documentation/Building_**
>>>> Guide_AOO/Step_by_step<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step>
>>>>
>>>>> I followed the two steps under SVN and then jumped to "Install
>>>>>>> requirements" to
>>>>>>> do the steps under it. But when I got to the step "Build", I
had some
>>>>>>> error.
>>>>>>> Here is my error log:
>>>>>>>
>>>>>>> yohey@yohey-VirtualBox:~/**Openoffice/aoo-trunk/main/**
>>>>>>> instsetoo_native$
>>>>>>>
>>>>>> build
>>>>>>
>>>>>>> --all
>>>>>>> ...
>>>>>>> ...
>>>>>>> ...(Building log)
>>>>>>> ...
>>>>>>>
>>>>>>> =============
>>>>>>> Building module epm
>>>>>>> =============
>>>>>>>
>>>>>>> Entering /home/yohey/Openoffice/aoo-**trunk/main/epm
>>>>>>>
>>>>>>> dmake:  Error: -- `./
>>>>>>> unxlngx6.pro/misc/**3ade8cfe7e59ca8e65052644fed9fc**
>>>>>>> a4-epm-3.7.unpack<http://unxlngx6.pro/misc/3ade8cfe7e59ca8e65052644fed9fca4-epm-3.7.unpack>
>>>>>>> '
>>>>>>>
>>>>>> not
>>>>
>>>>> found, and can't be made
>>>>>>>
>>>>>>> 1 module(s):
>>>>>>>      epm
>>>>>>> need(s) to be rebuilt
>>>>>>>
>>>>>>> Reason(s):
>>>>>>>
>>>>>>> ERROR: error 65280 occurred while making
>>>>>>> /home/yohey/Openoffice/aoo-**trunk/main/epm
>>>>>>>
>>>>>>> When you have fixed the errors in that module you can resume
the
>>>>>>>
>>>>>> build
>>>>
>>>>> by
>>>>>
>>>>>> running:
>>>>>>>
>>>>>>>      build --all:epm
>>>>>>>
>>>>>>> yohey@yohey-VirtualBox:~/**Openoffice/aoo-trunk/main/**
>>>>>>> instsetoo_native$
>>>>>>>
>>>>>>> -----------------------------**end---------------------------**---
>>>>>>>
>>>>>>> I have tried it for a long time but I can't fix it up to now.
>>>>>>>
>>>>>>> Thanks you for reading my question.
>>>>>>> Thanks!
>>>>>>>
>>>>>>> Regards,
>>>>>>>   Yohey.
>>>>>>>
>>>>>>>  Hi Yohey --
>>>>>>
>>>>>> OK, I am looking at the build instruction page you used. If you are
>>>>>>
>>>>> using
>>>>
>>>>> the Windows 7 instructions, the epm-url in the configure section was
>>>>>>
>>>>> wrong
>>>>>
>>>>>> and needs to be the same url as for the Ubuntu instructions. So,
I
>>>>>> just
>>>>>> fixed this.
>>>>>>
>>>>>> It seems that epm did not build and this is needed to do the actual
>>>>>>
>>>>> build.
>>>>>
>>>>>> So, a few things that might help troubleshoot this problem:
>>>>>>
>>>>>> -- if you could post more information here about  your setup (OS,
>>>>>> etc.)
>>>>>> and the configuration options you used, that would help a lot
>>>>>>
>>>>>> -- you may want to take a look at the general AOO Build page if you
>>>>>>
>>>>> haven't
>>>>>
>>>>>> already:
>>>>>> http://wiki.openoffice.org/**wiki/Documentation/Building_**Guide_AOO<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO>
>>>>>>
>>>>>> In any case, we are here to help and welcome your development efforts.
>>>>>>
>>>>> And,
>>>>>
>>>>>> of course, we very much welcome any comments you may have on the
>>>>>>
>>>>> Building
>>>>
>>>>> Guides themselves.
>>>>>>
>>>>>>
>>>>>>  If I remember correctly I got the same error when installing from
>>  the AOO 4.0 release debs. My cure was completely to remove all traces of
>> LibreOffice using Synaptic. Again, from memory, this was achieved by
>> removing libreoffice-core.
>>
>> I think it is possible to run OpenOffice in parallel with LibreOffice,
>> but I have no detailed information on how to do that, as I don't need to do
>> it.
>>
>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.**apache.org<dev-unsubscribe@openoffice.apache.org>
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message