openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Regina Henschel <rb.hensc...@t-online.de>
Subject Re: cannot paste a web image into a presentation?
Date Mon, 19 Aug 2013 13:25:14 GMT
Hi Rob,

it is https://issues.apache.org/ooo/show_bug.cgi?id=122920

Kind regards
Regina

Rob Weir schrieb:
> On Wed, Mar 7, 2012 at 3:41 AM, Oliver-Rainer Wittmann
> <orwittmann@googlemail.com> wrote:
>> Hi,
>>
>>
>> On 07.03.2012 09:16, lou ql wrote:
>>>
>>> On 6 March 2012 18:35, Oliver-Rainer
>>> Wittmann<orwittmann@googlemail.com>wrote:
>>>
>>>> Hi,
>>>>
>>>>
>>>> On 06.03.2012 03:41, lou ql wrote:
>>>>
>>>>> URL:
>>>>> https://cwiki.apache.org/**confluence/display/OOOUSERS/**
>>>>>
>>>>> AOO+3.4+Unofficial+Developer+**Snapshots<https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+3.4+Unofficial+Developer+Snapshots>
>>>>>
>>>>> I tried copy the logo at the topleft of this page then paste into
>>>>> document/spreadsheet/**presentation, and find that the picture cannot
be
>>>>> pasted into presentation. But I can do this in MS office 2010
>>>>>
>>>>>
>>>> Currently, I have problems reproducing your problem.
>>>>
>>>> Can you please be a little bit more specific?
>>>> How do you copy the image?
>>>> Are you using a browser? Which one?
>>>>
>>>> I have done the following using latest snapshot build for Windows, rev.
>>>> 1296433:
>>>> - open the website in Firefox
>>>> - open context menu for the image
>>>> - choose "Copy Image"
>>>> - open an empty presentation document
>>>> - hit keys Ctrl-V
>>>> -->  bitmap is pasted into the presentation.
>>>> (Unfortunately, its background is black. I am experiencing the same in MS
>>>> Paint. Thus, I assume that the copy process of Firefox does not
>>>> recognized
>>>> a possible existing Alpha channel for the transparency.)
>>>>
>>>> My 2nd try was:
>>>> - open the website in Firefox
>>>> - make a selection of the image using the mouse
>>>> - hit keys Ctrl-C
>>>> - open an empty presentation document
>>>> - hit keys Ctrl-V
>>>> -->  nothing happens (the same happens in OOo 3.3). Reason for this is
>>>> that
>>>> the presentation document can not interpret the HTML in the clipboard.
>>>>
>>>> My 3rd try was:
>>>> - open the website in Firefox
>>>> - open context menu for the image
>>>> - choose "Copy Image Location"
>>>> - open an empty presentation document
>>>> - menu Insert - Picture - From file
>>>> - paste image URL into "File name" field
>>>> - check checkbox "Link"
>>>> - hit button "Open"
>>>> -->  image is inserted as linked image. It takes some time to download
>>>> the
>>>> image from the internet - I also had to allow the soffice.bin process to
>>>> access the internet.
>>>>
>>>>
>>> I'm doing with the second way, it works in document and spreadsheet, also
>>> works in MS office PPT.
>>>
>>>
>>
>> Ok.
>> Thus, this way is currently not supported by Impress - our presentation
>> component.
>> Thus, from my point of view this issue would be a request for enhancement.
>>
>> Note: Before pasting you can observe via menu edit - paste special what the
>> corresponding application can interpret from the different available formats
>> provided by the clipboard.
>>
>
> I think we have a regression here.
>
> Steps:
>
> 1. Load Impress, Load Browser to http://www.openoffice.org
>
> 2. Right click on the AOO logo in upper left corner (a PNG file) and
> Copy/Image (in Firefox) or Copy (in Internet Explorer)
>
> 3. In Impress, Edit Paste the image.    (If you do Edit/Paste Special
> the format is called "bitmap")
>
> Observed Behavior:
>
> 1. In AOO 3.4.1 the image pastes in correct in I.E. and Firefox on Windows
>
> 2. In AOO 4.0.0 the image pastes in as a solid black box in Firefox,
> but pastes in correctly in I.E.  The same version of Firefox (23.0.1)
> was used in both tests.
>
> IMHO this is a serious issue, since it makes it very hard to reuse
> graphics from the web.  The workaround is not very good -- save image
> from web to a file and then import it into Impress.
>
> Regards,
>
> -Rob
>
>>
>> Best regards, Oliver.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message