openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Juan C. Sanz " <juancsa...@hotmail.com>
Subject BootstrapException: no office executable found!
Date Sat, 29 Jun 2013 18:20:13 GMT
Hello.
I've just start to learn with the OpenOffice Developer's Guide.
Following the Getting Started chapter I've installed:

  * a 32-bit version of JDK (jdk-7u25-nb-7_3_1-linux-i586.sh and
    jdk-6u45-linux-i586.bin)
  * a Java IDE (Netbeans 7.3 - I installed 7.3.1 but I uninstalled it
    due some problems)
  * OpenOffice SDK
    (Apache_OpenOffice_incubating-SDK_3.4.1_Linux_x86_install-deb_en-US.tar.gz)
  * OpenOffice
    (Apache_OpenOffice_incubating_3.4.1_Linux_x86_install-deb_es.tar.gz)
  * OpenOffice plugging for Netbeans
    (org-openoffice-extensions-3.0.2.nbm, from
    http://people.apache.org/~cmarcum/devtools/)

All it is running in a VirtualBox machine with Linux Mint 15 32-bit 
(linux 3.8.0-19 and MATE 1.6.0)
My problem is that when I try to run any sample of the Developer's Guide 
I always get the same error:
/com.sun.star.comp.helper.BootstrapException: no office executable found!//
//        at 
com.sun.star.comp.helper.Bootstrap.bootstrap(Bootstrap.java:239)//
//        at 
com.example.OfficeUNOClientApp.main(OfficeUNOClientApp.java:49)/
Also if I create a new "empty" Apache OpenOffice Client Application 
project, running the frame created, I get the same error.
I've tried to change the java platform (that's why I have jdk-7 and 
jdk-6 installed), following the (very old) advises from some forums I've 
tried to add everything to the CLASSPATH, I've tried soffice 
"-accept=socket,host=0,port=2002;urp;", I execute the setsdkenv_unix...
I think I've done everything, but I get always the same error.
What am I doing wrong? Some more advises?
Regards
Juan C. Sanz

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message