openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajath Shashidhara <rajaths.raja...@gmail.com>
Subject Bug[119445]
Date Tue, 16 Apr 2013 09:37:41 GMT
Hello,

I am a beginner in this opensource development. Kindly bear with my
trivial doubts.
I would like to participate in gsoc 2013. I began with solving a bug
which was related page layout. Mr. Rob flagged that bug as hard for a
beginner in a series of mails that I had with a few developers who
helped me a lot.

For that reason, I chose an easier bug to solve. Bug - 119445
I used the following method to fix this bug.
I removed the entry <menu:menuitem menu:id=".uno:ExportToPDF"/>
from main/sw/uiconfig/swriter/menubar/menubar.xml

I then built openoffice again. Now Export to PDF is not shown anymore in Writer!
But, I also have to remove the part of the code which connects this
menuitem to mouseclick and the function of exporting to PDF has to be
removed.

I tried my best to find the link where exactly this xml file is used
and the ui response is coded. I would be very happy If anybody could
help me out with this. I would be very excited to complete my first
bug fix!

-- 
Rajath S,
M.Sc(Hons.) Physics,
Birla Institute of Technology and Science - Pilani,
Pilani

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message