openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <arie...@apache.org>
Subject Re: New license for libwpd, libwps, libwpg
Date Sun, 21 Apr 2013 22:12:18 GMT
Hi Jani,

On Mon, Apr 22, 2013 at 12:06:18AM +0200, janI wrote:
> > > I am trying to understand the discussion here, and I miss
> > > something.
> > >
> > > If we do not have libwpd in our 3.4.0 release I assume we have
> > > something else to replace it (or have we removed the feature that
> > > uses libwpd?).
> >
> > answer in https://issues.apache.org/ooo/show_bug.cgi?id=120043#c1
> >
> thx. Now I understand the problems.
> 
> Would it btw not be smarter in general to have conversions from
> relative old packages like wordperfect in an extension (as suggested
> in the bug report), that would help reduce the footprint, and users
> can still convert.

The suggestion quoted there is not realistic: writerfilter depends on
several core libraries
http://hg.services.openoffice.org/OOO340/file/c904c1944462/writerperfect/prj/build.lst
An extension can use only URE libraries, so making an extension out of
writerfilter will require to rewrite the code.

On the other hand, "re-integrating" libpwd is more than re-integrating
it: the code has changed, writerfilter need modifications (that is,
someone in the know must update the library, it's not simply dumping the
new tar and making it compile).


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message