openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Herbert Dürr <...@apache.org>
Subject Re: What is the build environment?
Date Tue, 05 Mar 2013 09:00:30 GMT
Hi!

On 2013/03/05 6:51 AM, Yi Xuan Liu wrote:
> I tried to install the latest build on my machine, on which the OS is
> Ubuntu 10.04. And I cannot start AOO after installation.
> The error is "GLIBC_2.15 not found", which is due to the lower OS version.
>
> What is our build environment? Is there any limitation for OS version?

The build platform depends on what you mean with "latest build". E.g. 
for our nightly buildbot builds we are using the ASF provided machines
dedicated for this service. http://apache.org/dev/machines shows that 
our nightly 64bit-Linux build is created on "AMD64 Ubuntu 10.04.4 LTS" 
and our nightly 32bit-Linux build is created on "i386 Ubuntu 12.04 LTS". 
So if you were trying to install the 32bit nightly Linux build the 
problem can be easily explained: On Linux building forward compatible 
binaries is rather easy nowadays, but the same isn't true for building 
backwards compatible stuff.

For our releases, betas etc. we (thanks Ariel!) is doing the build on 
rather old systems so that they have a very good binary compatibility.

So in short: If you want to test the Linux-Nightly on Ubuntu 10.4 (or 
newer) please use the 64bit version. If you want to test the 32bit 
Linux-Nightly as provided by the current buildbot (bb-vm2_ubuntu_32bit) 
please use 32bit Ubuntu 12.4 or later.

Hope that helps,
Herbert

By the way I just committed r1452693 so that the configure logs will 
provide more details of the build platform.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message