openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Yin <steve.yin....@gmail.com>
Subject Re: [Call For QA Volunteers] AOO UI IAccessible2 testing work
Date Wed, 06 Feb 2013 06:37:19 GMT
Hi Stuart,

Please refer to the wiki:
https://cwiki.apache.org/confluence/display/OOOUSERS/Tips+for+branch+ia2


On Wed, Feb 6, 2013 at 12:32 PM, Ariel Constenla-Haile
<arielch@apache.org>wrote:

> Hi Stuart,
>
> On Wed, Feb 06, 2013 at 02:25:13AM +0000, V Stuart Foote wrote:
> > Steve, Ariel
> >
> > Installed Ariel's posted ia2 branch build "Run as Administrator", and
> > also captured a verbose install log.
> >
> > AOO350m1(Build:9611)  -  Rev. 1441343 2013-02-04 20:38:26 -0300 (lun,
> > 04 feb 2013)
> >
> > Windows 7 sp1 64-bit Oracle Java JRE 1.7u11
> >
> > Verified the UaccCOM.dll is registered at:
> >
> >
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\B4197A678F2F566AC9CE342EB80665B2
> > as 346FD3847C37D3440BBCC0FF600F4DEA with a string value of C:\Program
> > Files (x86)\Apache OpenOffice 3\program\UAccCOM.dll
> >
> > However, when running the ia2 branch as a user in the Administrators
> > group,
>
> Note that I am also in the Administrators category, but it didn't work,
> I had to run OpenOffice as Administrator (right-click on the Desktop
> shortcut, select "Run as administrator").
>
> > and monitoring with a11y's AccProbe Eclipse RCP probe as well
> > as the MS AccEvent I am not seeing IAccessible2 events, only MSAA. The
> > UI Access mode of AccEvent listings are also very sparse.
> >
> > Kind of interesting is that AccProbe shows all only a few of the msaa
> > components "howFound" from Navigating the Tree--with most "howFound"
> > values of AtPoint:java.awt.Point from browsing the GUI. No event
> > tracking in the probes--and it follows that NVDA is mute.
> >
> > Am I missing something? Ariel on your Windows box are you running an
> > Oracle 7 JRE, or Just the JDK 6 you built against?
>
> I have several Java versions, OpenOffice is configured to run with JRE
> 7.
>
> > Going to try removing JRE 1.7u11 and backing up to 1.6u39 to see if
> > that has an impact, but if IAccessibile2 is functional--should not
> > need a JRE, right?
>
> When running as a normal user (even in the Administrators category),
> OpenOffice was using Java, the ia2 component and COM were not even
> loaded; running the program as administrator made ia2 work.
>
>
>
> Regards
> --
> Ariel Constenla-Haile
> La Plata, Argentina
>



-- 
Best Regards,

Steve Yin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message