openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: [IMPORTANT, DISCUSS]: no migration/use of former user profile with AOO 4.0
Date Fri, 18 Jan 2013 03:08:25 GMT
On Thu, Jan 17, 2013 at 10:05 PM, Rob Weir <robweir@apache.org> wrote:
> On Thu, Jan 17, 2013 at 2:55 AM, Oliver-Rainer Wittmann
> <orwittmann@googlemail.com> wrote:
>> Hi,
>>
>>
>> On 17.01.2013 03:16, Rob Weir wrote:
>>>
>>> On Wed, Jan 16, 2013 at 6:49 PM, Regina Henschel
>>> <rb.henschel@t-online.de> wrote:
>>>>
>>>> Hi Rob,
>>>>
>>>> I had the crash problem too, but unfortunately I do not have the user
>>>> profile any longer. But I can list some things, which I usually do with
>>>> each
>>>> version:
>>>>
>>>
>>> Wow, this is quite a list!
>>>
>>> So let's play detective here, and "think like a bug".  If something
>>> went wrong, what are likely causes?
>>>
>>> -- The profile conversion can't be totally broken or it would fail for
>>> every upgrade
>>>
>>> -- It cannot depend on a very rare situation, like a specific macro
>>> import or a rarely used extension, otherwise we would not see many
>>> reports at all.
>>>
>>> So what is in the middle?   Volume of changes?  Exceeding a specific
>>> string length?  Some data type conversion issue?  Locale dependency?
>>> Character set conversion?
>>>
>>> If it is any single cause then it could be narrowed down by a binary
>>> search style set of tests.  Tedious, but doable.
>>>
>>>> - Add name to user data, turn off "Help Agent", increase Graphics cache
>>>> to
>>>> maximum, number of objects to 100, set number of undo steps to 20.
>>>> - In Pathes: Add AutoCorrect, AutoText, Gallery, and Templates from a
>>>> folder
>>>> outside my home directory, do not make it the default. Set Graphics to
>>>> the
>>>> default Windows folder for personal pictures.
>>>> - Set Macro Security to Medium.
>>>> - Set JRE to Java 1.6.0.37.
>>>> - Have Online Update to check automatically every week.
>>>> - Clear checkbox "Size optimation for ODF settings".
>>>> - Set HTML to Export OOoWriter and Character set UTF-8.
>>>> - Change Languages to not use the "default" item, enable both items in
>>>> enhanced language support.
>>>> - Set personal document templates from the added path (see above) as
>>>> default
>>>> template.
>>>> - Define own toolbar in Draw and in Impress with commands for macros.
>>>> - Import about 10 macro libraries.
>>>> - In Draw and Impress: Dock toolbar 'Options' to the left and customize
>>>> it.
>>>> Customize the drawing toolbar to show the toolboxes instead of single
>>>> shapes. Drag the zoom sub-toolbar from the standard bar and dock it.
>>>> Stack
>>>> Page pane and Style&Formatting window.
>>>> - Customize standard toolbar: remove, disable and add commands.
>>>> In Writer dock table and numbering toolbar to the right, Style&Formatting
>>>> window to the left, show drawing toolbar, customize standard toolbar,
>>>> define
>>>> own toolbar for macros.
>>>>   - Install a German or an English language pack, depending on which is
>>>> the
>>>> basis installation. Make sure the dictionary is installed and install it,
>>>> if
>>>> it is missing. Keep the default installed extensions.
>>>>
>>>> Including the recent document list, this results always in a
>>>> registrymodifications.xcu with size around 800KB.
>>>>
>>>> All that was done on WinXP. [I'm now on Win7.]
>>>>
>>>> I think, this might give you an imagination of "highly customized".
>>>>
>>>> Kind regards
>>>> Regina
>>>>
>>>> Rob Weir schrieb:
>>>>
>>>>> On Wed, Jan 16, 2013 at 12:49 PM, Kay Schenk <kay.schenk@gmail.com>
>>>>> wrote:
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On 01/15/2013 12:48 AM, Herbert Duerr wrote:
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On 14.01.2013 22:50, Hagar Delest wrote:
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Le 14/01/2013 12:06, Oliver-Rainer Wittmann a écrit :
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Does exist a description (may be inclusive a blob of
the former user
>>>>>>>>> profile) to reproduce the problem?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Sadly, no.
>>>>>>>> XP seems the version where it occurs the most.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Was the profile migration problem also reported on Mac, Linux
or
>>>>>>> FreeBSD? If it was mostly an XP problem then the observation
by
>>>>>>> Stephan
>>>>>>> Bergmann mentioned in
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> http://ooo-forums.apache.org/en/forum/viewtopic.php?t=55017&p=242599#p242632
>>>>>>> could be real the root cause of all our profile migration related
>>>>>>> instabilities.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> as an FYI...I use linux 32 bit rpm, and have never had a user profile
>>>>>> issue,
>>>>>> that I know of :]
>>>>>>
>>>>>
>>>>> I've never seen the issue either, on Windows XP, 7 or 8.
>>>>>
>>>>>
>>>>> But I do have a clean XP virtual machine image that I can run some
>>>>> tests on.  If anyone has a suggestion on how one can force the problem
>>>>> to occur, let me know.
>>>>>
>>>>> I assume it is some form of:
>>>>>
>>>>> 1) Install OOo 3.3.0
>>>>>
>>>>> 2) Do a bunch of stuff that triggers profile changes
>>>>>
>>>>> 3) Upgrade to AOO 3.4.1
>>>>>
>>>>> 4) Kaboom!
>>>>>
>>>>> But what are some things I should do for step #2?
>>>>>
>>
>> I now have an user profile which causes constantly crashes.
>> It had been "created" on a Windows 7 machine where I had OOo 3.3, AOO 3.4
>> and now AOO 3.4.1 installed.
>> I did not remember what I did in step #2, but it was very little - I think.
>>
>> I am now ready to debug the crash. It happens somehow when trying to access
>> certain installed extensions. This is just the first glance. Thus, do not
>> nail me down on it, when I find out that it is something else ;-)
>>
>> I keep you informed.
>>
>
> Cool!
>
> Do you (or anyone else) have a Bugzilla issue you want to use for
> this?  We have quite a few reports on this issue and I'd like to start
> closing them out as duplicates of a root issue.
>
> If no one has a good one, I can pick one at random.
>

This appears to be one of the earlier ones:

https://issues.apache.org/ooo/show_bug.cgi?id=120227

I'll use that.

-Rob

> -Rob
>
>> Best regards, Oliver.

Mime
View raw message