openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabrizio Sancin <f.san...@gmail.com>
Subject Re: Build OpenOffice 3.4.1 - Error in module
Date Tue, 15 Jan 2013 11:51:58 GMT
Hi, Oliver

I built it with a source release.
Now I'm build trying with SVN :
https://svn.apache.org/repos/asf/incubator/ooo/trunk
then, I will follow your advice.
See what happens.

Thank you,
Fabrizio.







2013/1/15 Oliver-Rainer Wittmann <orwittmann@googlemail.com>

> Hi,
>
>
> On 15.01.2013 10:53, Fabrizio Sancin wrote:
>
>> Hello,
>>
>> I have tried to build OpenOffice using the steps described here:
>> http://wiki.openoffice.org/**wiki/Documentation/Building_**
>> Guide_AOO/Step_by_step<http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step>
>>
>> My platform is windows 7 x64 sp1
>>
>> I downloaded Source release at
>> http://www.openoffice.org/**download/other.html#tested-sdk<http://www.openoffice.org/download/other.html#tested-sdk>
>>
>> Everything worked out just fine until i ran the command build --all in
>> cygwin, after compiling one hour, the error i got was:
>>
>>
>> =============
>> Building module comphelper
>> =============
>>
>> Entering /tmp/aoo-3.4.1/main/**comphelper/prj
>>
>> cd .. && make -s -r -j1  && make -s -r deliverlog
>> [ info  ALL ] LinkTarget Library/isal.lib not defined: Assuming headers to
>> be there!
>> [ info  ALL ] LinkTarget Library/icppuhelper.lib not defined: Assuming
>> headers to be there!
>> [ info  ALL ] LinkTarget Library/icppu.lib not defined: Assuming headers
>> to
>> be there!
>> [ info  ALL ] LinkTarget Library/iucbhelper.lib not defined: Assuming
>> headers to be there!
>> [ info  ALL ] LinkTarget Library/ivos.lib not defined: Assuming headers to
>> be there!
>> [ info  ALL ] LinkTarget Library/stlport_vc71.lib not defined: Assuming
>> headers to be there!
>> [ info  ALL ] LinkTarget Library/uwinapi.lib not defined: Assuming headers
>> to be there!
>> [ info  ALL ] LinkTarget Library/kernel32.lib not defined: Assuming
>> headers
>> to be there!
>> [ info  ALL ] LinkTarget Library/msvcrt.lib not defined: Assuming headers
>> to be there!
>> [ info  ALL ] LinkTarget Library/oldnames.lib not defined: Assuming
>> headers
>> to be there!
>> [ build PKG ] comphelper_inc
>> [ build PCH ] precompiled_comphelper
>> precompiled_comphelper.cxx
>> awk: fatal: can't open source file
>> `C:/cygwinc:/cygwin/tmp/aoo-3.**4.1/main/solenv/gbuild/**processdeps.awk'
>> for
>> reading (No such file or directory)
>> C:/cygwin/tmp/aoo-3.4.1/main/**solenv/gbuild/**PrecompiledHeaders.mk:49:
>> recipe
>> for target `/tmp/aoo-3.4.1/main/solver/**341/
>> wntmsci12.pro/workdir/**PrecompiledHeader/nodebug/**
>> precompiled_comphelper.hxx.pch<http://wntmsci12.pro/workdir/PrecompiledHeader/nodebug/precompiled_comphelper.hxx.pch>
>> **'
>> failed
>> make: *** [/tmp/aoo-3.4.1/main/solver/**341/
>> wntmsci12.pro/workdir/**PrecompiledHeader/nodebug/**
>> precompiled_comphelper.hxx.pch<http://wntmsci12.pro/workdir/PrecompiledHeader/nodebug/precompiled_comphelper.hxx.pch>
>> **]
>> Error 2
>> dmake:  Error code 2, while making 'all'
>>
>> 1 module(s):
>>          comphelper
>> need(s) to be rebuilt
>>
>> Reason(s):
>>
>> ERROR: error 65280 occurred while making /tmp/aoo-3.4.1/main/**
>> comphelper/prj
>>
>> When you have fixed the errors in that module you can resume the build by
>> running:
>>
>>      build --all:comphelper
>>
>>
>> Please help if you can!
>>
>> Thank you!
>>
>>
> It looks like that you have somehow lost (or never had) the file
> main/solenv/gbuild/**processdeps.awk
>
> Are you working with a source release or a SVN checkout of the source code
> repository?
>
> If you are working on a SVN checkout the following command will bring back
> the file:
> svn update main/solenv/gbuild/**processdeps.awk
>
>
> Best regards, Oliver.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message