openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Lam <mnsyl4...@verizon.net>
Subject Re: Error Building module hsqldb - Installation Source Code in AOO
Date Sun, 27 Jan 2013 19:52:37 GMT
I had the same issue but it was due to JDK7, I switch and it is working 
but I have a question about how the java libraries are included. As 
mentioned by Kay, the current version of hsqldb is quite old. The latest 
is 2.2.9 and the same goes for Lucene the included version is 2.x 
whereas the latest is 4.1. How come the jar is being created as part of 
the build process instead of just pulling a prebuild version?

On a similar note, I had an additional issue with the build complaining 
about the dmake that is pull down by bootstrap being an invalid bzip2 
file, not sure if other people ran into the same issue. I had another 
copy of dmake on my machine and I just applied it to get pass the issue. 
All of these were done from a fresh checkout from SVN.

On 01/27/2013 01:13 PM, Kay Schenk wrote:
> On Sat, Jan 26, 2013 at 5:17 PM, Pedro Giffuni <pfg@apache.org> wrote:
>
>> Hello Alan;
>>
>> My guess is that you are using a localized (non-english) environment, but
>> JDK7 is also a know source of problems ih hsqldb.
>>
>> Hope that helps,
>>
>> Pedro.
>
> A quick weird question on this...Is this partially due to the rather old
> version of HSQLD we package -- 1.8? (in ext_sources)-- as opposed to newer
> 2.2?   Among other things...I am actually trying to investigate more of the
> java issues, so this is why I ask.
>
>
>
>
>


Mime
View raw message