openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Pescetti <pesce...@apache.org>
Subject Re: [IMPORTANT, DISCUSS]: no migration/use of former user profile with AOO 4.0
Date Sat, 12 Jan 2013 15:11:42 GMT
On 10/01/2013 Hagar Delest wrote:
> Le 10/01/2013 13:57, Rob Weir a écrit :
>> If we have not figured out exactly what causes the current OOo 3.3.0
>> -> AOO 3.4.x profile migration problems, how are we certain that these
>> problems will not come back when we migrate AOO 4.0 to AOO 4.1 ???

Between 3.3.1 and 3.4.1 we changed (twice) the way the profile is 
stored, first removing a dependency on BerkeleyDB and then reducing the 
profile size by not putting a copy of shared extensions there. If we 
don't do incompatible changes again, we remove this type of risks.

> Even a brand new install leads to profile corruption rather quickly
> (especially under XP).

I've seen it happen when one tries to keep both 3.3 and 3.4 installed, 
with a "setup /a" for example. The two, unless he takes care of 
customizing it in the INI files, will try to use the same profile 
folder. The first run of 3.4 will convert it to the 3.4 format, then if 
you run 3.3 again you will break it. This is of course an unsupported 
configuration, but it might explain why people who see 3.4.1 working 
smoothly suddenly find it broken. I'm not implying that this covers all 
the cases you report, but it could be responsible for a part of them.

Regards,
   Andrea.

Mime
View raw message