openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fabian <>
Subject Re: [EXT] image double click
Date Wed, 08 Feb 2012 08:09:48 GMT
Hi Ariel,

You were right that I missed to add the class in the property file. I tried that before but
comma separated and forgot to test it again only space separated. 

Doing this gave me the error that the __getComponent method is missing. I added it and the
add-on starts but the __getComponent method isn't called and neither are the __getServiceFactory
are the __writeRegistryServiceInfo methods. Do I have to implement any other Interfaces in
my Job class so that __getComponent is called?

I've tried the component wizard before and faced the same problem as you do under linux.


On Feb 7, 2012, at 8:32 PM, Ariel Constenla-Haile wrote:

> Hi Fabian,
> On Tue, Feb 07, 2012 at 06:57:10PM +0100, fabian wrote:
>> This is were I stumble and my Job class wasn't triggered so far.
>> I know that my job shall be registered by __getServiceFactory and
>> __writeRegistryServiceInfo by the set implementatiton name:
>> "myaddon.test.InterceptorJob", but I couldn't figure out what is
>> necessary that those methods are called by openoffice.
>> I've seen examples where the XJob implementation is set in the jar
>> manifest as "RegistrationClassName" and I guess therefor its
>> __getServiceFactory is called. In my generated manifest my
>> addonStarter class is set as RegistrationClass.
> you might be missing to add the class in
> nbproject/ :
> The property registration.classname must list all classes that need to
> be registered as UNO components, separated by a space:
> registration.classname=my.impl.Class1 my.impl.Class2 my.impl.Class3
> AFAIK if you use the wizard (right click on a package and choose New
> - Other, in the "New File" dialog choose "" under
> Categories and "Java UNO Object" under "File Types", then select the
> type to implement) the class is added automatically (I can't tell now,
> it does not work on Linux, the "Select Services" dialog shows "<No Types
> Available>").
> Regards
> -- 
> Ariel Constenla-Haile
> La Plata, Argentina

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message