openmeetings-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessio Falsetti <alessio.false...@eng.it>
Subject Re: Clustering
Date Wed, 26 Aug 2015 13:10:53 GMT
Hi Maxim,

1) I have installed OpenMeetings, Moodle and the plug-in
2) I have configured the cluster for OpenMeetings (it works)
3) I have created a course in Moodle and add the new activity of OM at a
certain date
4) I have created another activity of OM in other date, same course
5) 2 users are connected to the first activity (room 1)
6) 2 other users are connected to the second activity (room 2)

All users are re-directed to the master server.

Please let me know! Thank you!


2015-07-29 19:10 GMT+02:00 Maxim Solodovnik <solomax666@gmail.com>:

> Actually the rooms are created in the DB
> Server selection mechanism is "in charge" only on room entering
>
> could you please provide repo-steps so I can try your scenario?
>
> On Wed, Jul 29, 2015 at 11:04 PM, Alessio Falsetti <
> alessio.falsetti@eng.it> wrote:
>
>> Hi Maxim!
>>
>> With this version of OpenMeetings, the clustering works as expected!
>> Thank you!! :)
>>
>> But there is still an issue with Moodle plug-in. If the user access via
>> Moodle plug-in, all the rooms will be created only on master server. The
>> plug-in use "addRoomWithModerationAndExternalType" REST API for create a
>> room.
>> Maybe this function does not work/support the room distribution mechanism
>> ?
>>
>> Thank you again and please let me know!
>>
>> Alessio
>>
>>
>>
>>
>> On 07/07/2015 at 19:37 you worte:
>>
>> Should be fixed
>> please try build #146 from here [1]
>> please write any issues/comments to the issue [2]
>>
>> [1]
>> https://builds.apache.org/view/M-R/view/OpenMeetings/job/Openmeetings%203.0.x/
>> [2] https://issues.apache.org/jira/browse/OPENMEETINGS-1230
>>
>> Thanks for the reporting!
>>
>>
>> On Tue, Jul 7, 2015 at 3:36 PM, Alessio Falsetti <alessio.falsetti@eng.it
>> > wrote:
>>
>>> Hi Maxim,
>>>
>>> ok thank you! Please let me know if you find something!
>>>
>>> Alessio
>>>
>>>
>>>
>>> On 07/07/2015 at 07:43 you wrote:
>>>
>>> It seems like I was able to reproduce something :(
>>> Will try to investigate and address this
>>>
>>> On Mon, Jul 6, 2015 at 11:08 PM, Maxim Solodovnik <
>>> <solomax666@gmail.com>solomax666@gmail.com> wrote:
>>>
>>>> Hello Alessio,
>>>>
>>>> sorry for keeping silence (busy with my day-time job and other duties
>>>> :((( )
>>>> I'll try to configure cluster of 2 servers locally and reproduce your
>>>> issue (I'll try to do it this week, please ping me in case I'll be too
>>>> silent :)))
>>>>
>>>> I see no issues with your config, so i'll try to reproduce the issue
>>>> first
>>>> There are no additional steps, I'm using same instruction :(((
>>>>
>>>>
>>>> On Mon, Jul 6, 2015 at 11:00 PM, Alessio Falsetti <
>>>> <alessio.falsetti@eng.it>alessio.falsetti@eng.it> wrote:
>>>>
>>>>> Hi Maxim,
>>>>>
>>>>> any other suggestions regarding this problem with the clustering? There
>>>>> is some other undocumented parameter with which to experiment?
>>>>>
>>>>> Please let me know. Thanks in advance!
>>>>>
>>>>> Alessio
>>>>>
>>>>>
>>>>>
>>>>> On 30/06/2015 at 16:39 you wrote:
>>>>>
>>>>> Do you have servers enabled in admin?
>>>>> Do you have there ids specified in openmeetings-applicationContext.xml?
>>>>> Is there anything in the logs?
>>>>> What is displayed in Admin->Connections?
>>>>>
>>>>> On Tue, Jun 30, 2015 at 8:05 PM, Alessio Falsetti <
>>>>> <alessio.falsetti@eng.it>alessio.falsetti@eng.it> wrote:
>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> we have configured OpenMeetings in cluster as described in
>>>>>> <http://openmeetings.apache.org/Clustering.html>
>>>>>> http://openmeetings.apache.org/Clustering.html
>>>>>>
>>>>>> but there is a problem with the users distribution on the slave
>>>>>> servers.
>>>>>> We have OpenMeetings version 3.0.5 whit this configuration: 1 Master
>>>>>> and
>>>>>> 2 slaves, but all users are redirected only to first slave server,
>>>>>> even
>>>>>> if users are in different rooms.
>>>>>>
>>>>>> What's wrong? Any suggestions? Please help!
>>>>>>
>>>>>> Thanks in advance!
>>>>>>
>>>>>> --
>>>>>> Alessio
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> WBR
>>>>> Maxim aka solomax
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> WBR
>>>> Maxim aka solomax
>>>>
>>>
>>>
>>>
>>> --
>>> WBR
>>> Maxim aka solomax
>>>
>>>
>>>
>>
>>
>> --
>> WBR
>> Maxim aka solomax
>>
>>
>>
>> --
>> Alessio
>>
>>
>
>
> --
> WBR
> Maxim aka solomax
>

Mime
View raw message