openmeetings-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maxim Solodovnik <solomax...@gmail.com>
Subject RE: OM 3.0 and Apache ProxyPass
Date Tue, 08 Apr 2014 23:29:48 GMT
I guess so. // is not very good in URL
On Apr 8, 2014 4:47 PM, "Marcello Lorenzi" <cello86@hotmail.it> wrote:

> I added this access entries taken by the access_log of OM:
>
> 92.168.250.163 - - [08/Apr/2014:23:34:22 +0200] "GET /openmeetings//
> HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:34:33 +0200] "GET /openmeetings//
> HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:34:54 +0200] "GET
> /openmeetings//signout HTTP/1.1" 302 -
> 192.168.250.160 - - [08/Apr/2014:23:35:05 +0200] "GET
> /openmeetings/signin?1 HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:35:05 +0200] "GET
> /openmeetings//signin HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:37:20 +0200] "GET /openmeetings//
> HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:37:28 +0200] "GET /openmeetings//
> HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:44:42 +0200] "GET /openmeetings//
> HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:48:29 +0200] "GET /openmeetings//
> HTTP/1.1" 302 -
> 192.168.250.163 - - [08/Apr/2014:23:48:36 +0200] "GET /openmeetings/
> HTTP/1.1" 302 -
>
> The issue seems to be the / present into the request. Could it be the "/"
> char present at the end of proxypass and proxypassreverse directives?
>
> Marcello
>
> ------------------------------
> From: cello86@hotmail.it
> To: user@openmeetings.apache.org
> Subject: RE: OM 3.0 and Apache ProxyPass
> Date: Tue, 8 Apr 2014 22:36:58 +0000
>
> Hi Maxim,
> on my configuration both the directives are present but I also configured
> ProxyPassPreserverHost to On and ProxyRequest set to Off.
>
> I don't understand the real issue on this configuration but all the
> request are redirected to http://<ipaddr>:5080/signin with a correct 404
> HTTP error.
>
> Marcello
>
> ------------------------------
> Date: Tue, 8 Apr 2014 16:32:59 -0600
> Subject: Re: OM 3.0 and Apache ProxyPass
> From: solomax666@gmail.com
> To: user@openmeetings.apache.org
>
> I guess you need proxypass proxypassreverse. If I'm not mistaken both are
> necessary
> On Apr 8, 2014 4:30 PM, "Marcello Lorenzi" <cello86@hotmail.it> wrote:
>
> Hi All,
> I have upgrade my Openmeetings instance from 2.2.0 to 3.0.0 version this
> evening but I noticed a strange behavior. My installation is composed by 2
> Apache webservers balanced on port 80 by a Load balancer and into the
> configuration of each webserver I configured a proxypass directive to move
> all the content to a single OM instance listening on port 5080.
>
> During the first time the configuration works but after some hours I
> noticed that all the contents are redirect to /signin page, but the page
> isn't present on the OM instance because it works with /openmeetings/signin.
>
> Could this problem be related to proxypass and the JSESSIONID created by
> OM?
>
> Thanks,
> Marcello
>
>

Mime
View raw message