openmeetings-user-russian mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sergey sivun <neptu...@gmail.com>
Subject Re: работа 4.0
Date Mon, 20 Nov 2017 10:36:48 GMT
Спасибо!

20 ноября 2017 г., 12:28 пользователь Maxim Solodovnik <solomax666@gmail.com
> написал:

> для свежего билда, наверное, даже лучше тут
> https://builds.apache.org/view/M-R/view/OpenMeetings/
> job/OpenMeetings%204.0.x/site/openmeetings-server/Clustering.html
> смотреть ....
>
> 2017-11-20 17:21 GMT+07:00 Maxim Solodovnik <solomax666@gmail.com>:
>
> > инструкция тут: http://openmeetings.apache.org/Clustering.html
> > я выключил "авто-обнаружение" потому что с ним
и без настройки результат
> > странный :(
> >
> > 2017-11-20 17:05 GMT+07:00 sergey sivun <neptun38@gmail.com>:
> >
> >> Да, вроде все нормально. Тестировал правда
пока без HTTPS
> >>
> >> теперь бы еще найти инструкцию как теперь
кластер настраивать т.к. в
> >> прошлом учебном году т.е. этой весной приходилось
включать.
> >>
> >> Вы просто сейчас работу в кластере отключили
как я понял?
> >>
> >> 20 ноября 2017 г., 11:42 пользователь Maxim Solodovnik <
> >> solomax666@gmail.com
> >> > написал:
> >>
> >> > ну то есть если брать билд №92 - всё работает?
> >> >
> >> > 2017-11-20 16:40 GMT+07:00 sergey sivun <neptun38@gmail.com>:
> >> >
> >> > > Сейчас поэкспериментировал с разными
версиями.
> >> > >
> >> > > Исходные условия. Сборка 3.3.2 и 4.0, 2 сервера
 условно сервер
> >> > 1(основной)
> >> > > и сервер 2(резерв)
> >> > >
> >> > >
> >> > > 1. На резервном сервере 2 запускаем 4.0
версию, на основном 3.3.2
> >> > >    результат как я описывал ранее(проблему)
центральная часть
> комнаты
> >> на
> >> > > основном сервере не запускается, видео
и микрофон нельзя включить.
> >> > >    Гашение 4 версии на резервном сервере
2 и перезапуск 3.3.2 на
> >> основном
> >> > > восстанавливает нормальную работу.
> >> > >
> >> > >
> >> > > 2. На резервном сервере 2 запускаем 4.0
версию, на основном тоже 4.0
> >> > версию
> >> > >     результат немного другой. Как я описывал
ранее - центральная
> часть
> >> > > комнаты на основном сервере загружается,
видео и звук включаются но
> >> > > показывают только на том кампе где они
запущены, все остальные его
> не
> >> > > видят.
> >> > >    Гашение 4 версии на резервном сервере
2 и перезапуск 4.0 на
> >> основном
> >> > > восстанавливает нормальную работу.
> >> > >
> >> > > 3. На резервном сервере 2 запускаем 4.0.1
версию ночную сегодняшнюю
> >> > сборку
> >> > > 92 , на основном тоже самое.
> >> > >  Работоспособность нормальная в плане
видео.
> >> > >
> >> > >
> >> > >
> >> > >
> >> > >
> >> > > 19 ноября 2017 г., 7:20 пользователь Maxim Solodovnik
<
> >> > > solomax666@gmail.com>
> >> > > написал:
> >> > >
> >> > > > Так же можно проверить последнюю
"ночную" сборку:
> >> > > > https://builds.apache.org/view/M-R/view/OpenMeetings/
> >> > > > job/OpenMeetings%204.0.x/
> >> > > >
> >> > > > 2017-11-17 14:32 GMT+07:00 Maxim Solodovnik <solomax666@gmail.com
> >:
> >> > > >
> >> > > > > кластер был переделан на текущую
реализацию в 3.3.1 (
> >> > > > > http://openmeetings.apache.org/NewsArchive.html)
> >> > > > >
> >> > > > > можете проверить следующее:
> >> > > > >
> >> > > > > в файл webapps/openmeetings/WEB-INF/classes/hazelcast.xml
> >> > > > > вставить следующий XML:
> >> > > > > <network><join><multicast enabled="false"/><tcp-ip
> >> > > > > enabled="false"/></join></network>
> >> > > > >
> >> > > > > поможет это?
> >> > > > > если да - обновлю чтобы по умолчанию
было ....
> >> > > > >
> >> > > > >
> >> > > > > 2017-11-16 23:01 GMT+07:00 Maxim Solodovnik <
> solomax666@gmail.com
> >> >:
> >> > > > >
> >> > > > >> Вот что делать с внутренними
серверами не понятно :(((
> >> > > > >> Теоретически сертификат можно
выписать и на ИП, но вот что
> >> делать с
> >> > > > >> "серыми" ИП ....
> >> > > > >>
> >> > > > >> эту фигню с HTTPS не мы придумали
.... :(((
> >> > > > >>
> >> > > > >> я на своих тестовых серверах
самоподписаный СА сделал
> >> > > > >>
> >> > > > >> 2017-11-16 21:05 GMT+07:00 sergey sivun <neptun38@gmail.com>:
> >> > > > >>
> >> > > > >>> не знаю, в 3.3.2 по кластерам
по другому было все.
> >> > > > >>>
> >> > > > >>> но нет, до этого он то работал
а вот в пятницу или в четверг
> >> > > обновился
> >> > > > >>> адобе на 27 версию и я начал
вечером готовить комнаты для
> >> субботних
> >> > > > >>> лекций
> >> > > > >>> а оно все не работает. пробовал
разные варианты, ранее
> описывал,
> >> > уже
> >> > > в
> >> > > > 10
> >> > > > >>> вечера откатился на 3.2.1 да
так пока и оставил.
> >> > > > >>> 4.0 я начал ставить уже после
того как оно перестало работать.
> >> > > > >>> с  понедельника занятий удаленных
нет, поставлю 4 на боевой
> >> сервер,
> >> > > > >>> понаблюдаю
> >> > > > >>>
> >> > > > >>> 16 ноября 2017 г., 15:49 пользователь
Maxim Solodovnik <
> >> > > > >>> solomax666@gmail.com
> >> > > > >>> > написал:
> >> > > > >>>
> >> > > > >>> > Очень это странно :(
> >> > > > >>> > У нас на демо основная версия
до недавнего времени стояла
> >> 3.3.2
> >> > > > >>> > Проблем не было
> >> > > > >>> > Тут только дебаг на клиенте
включать - смотреть
> >> > > > >>> > Может опять кластер?
> >> > > > >>> > Его можно выключить
> >> > > > >>> >
> >> > > > >>> > WBR, Maxim
> >> > > > >>> > (from mobile, sorry for the typos)
> >> > > > >>> >
> >> > > > >>> > On Nov 16, 2017 17:36, "sergey sivun" <neptun38@gmail.com>
> >> > wrote:
> >> > > > >>> >
> >> > > > >>> > > вот, почему я и начал
4 версию тестировать т.к. писал в
> >> прошлую
> >> > > > >>> пятницу -
> >> > > > >>> > > на сервере стояла версия
3.3.2 и после обновления флеш
> >> плеера
> >> > на
> >> > > > >>> клиентах
> >> > > > >>> > > она перестала работать
- просто заходишь в комнату - слева
> >> > список
> >> > > > >>> есть
> >> > > > >>> > т.к.
> >> > > > >>> > > он написан на html5 а центра
нет - не грузится адобе флеш,
> >> > > > откатился
> >> > > > >>> на
> >> > > > >>> > > версию 3.2.1 - все нормально
на том же сервере, сейчас
> идут
> >> там
> >> > > > >>> лекции
> >> > > > >>> > >
> >> > > > >>> > > 16 ноября 2017 г., 12:31 пользователь
Julia Filippova <
> >> > > > >>> > > julia@distant.msu.ru>
> >> > > > >>> > > написал:
> >> > > > >>> > >
> >> > > > >>> > > > Прошу прощение, тестирую
версию 4.0.1, видео+микрофон в
> >> > Мозилле
> >> > > > и в
> >> > > > >>> > > версии
> >> > > > >>> > > > 56.0.2 не определяется,
и в версии 57.
> >> > > > >>> > > > Возможно скачала еще
сырую сборку:( А тип - вебинар
> >> вообще не
> >> > > > >>> работает,
> >> > > > >>> > > все
> >> > > > >>> > > > модули не загружаются,
чистый экран.
> >> > > > >>> > > >
> >> > > > >>> > > > 16 ноября 2017 г., 13:17 пользователь
Julia Filippova <
> >> > > > >>> > > > julia@distant.msu.ru>
> >> > > > >>> > > > написал:
> >> > > > >>> > > >
> >> > > > >>> > > > > Спасибо, попробую
на мозилле протестить!
> >> > > > >>> > > > >
> >> > > > >>> > > > > 16 ноября 2017 г., 13:15
пользователь sergey sivun <
> >> > > > >>> > neptun38@gmail.com
> >> > > > >>> > > >
> >> > > > >>> > > > > написал:
> >> > > > >>> > > > >
> >> > > > >>> > > > > не, это другая проблема,
тут все показывалось но на
> >> местном
> >> > > > >>> только
> >> > > > >>> > > кампе
> >> > > > >>> > > > >>
> >> > > > >>> > > > >> как я в последнее
время выкручиваюсь  без HTTPS - то
> >> пока
> >> > > > только
> >> > > > >>> > > мозилла
> >> > > > >>> > > > >> фирефокс дает
показ и камеры и микрофона(тоже конечно
> >> надо
> >> > > > >>> > разрешать)
> >> > > > >>> > > но
> >> > > > >>> > > > >> дает показ. Правда
вчера мозилла обновился до 57
> >> версии и
> >> > > > >>> теперь он
> >> > > > >>> > > > вроде
> >> > > > >>> > > > >> фирефокс квантум
- на нем еще не пробовал
> >> > > > >>> > > > >> Все остальные
не хотят показывать ни в списке ни
> потом.
> >> > > > >>> > > > >>
> >> > > > >>> > > > >>
> >> > > > >>> > > > >> 16 ноября 2017 г.,
12:10 пользователь Julia
> Filippova <
> >> > > > >>> > > > >> julia@distant.msu.ru>
> >> > > > >>> > > > >> написал:
> >> > > > >>> > > > >>
> >> > > > >>> > > > >> > Т.е. не обязательно
 цитирую -> "нужно настраивать
> >> HTTPS
> >> > > для
> >> > > > >>> того
> >> > > > >>> > > > чтобы
> >> > > > >>> > > > >> > камера/микрофон
были доступны" ?
> >> > > > >>> > > > >> > У меня аналогичная
проблема с камерой и
> микрофоном: в
> >> > > списке
> >> > > > >>> > > написано
> >> > > > >>> > > > >> > Заблокировано.
> >> > > > >>> > > > >> >
> >> > > > >>> > > > >> > 16 ноября 2017
г., 13:00 пользователь sergey sivun
> <
> >> > > > >>> > > > neptun38@gmail.com>
> >> > > > >>> > > > >> > написал:
> >> > > > >>> > > > >> >
> >> > > > >>> > > > >> > > Выдалось
немного времени, помучал 4 версию.
> >> > > > >>> > > > >> > > Проблема
с непоказом видео решилась.
> >> > > > >>> > > > >> > > Как оказалось,
видимо в 4 версии переписали код
> >> > работы в
> >> > > > >>> > кластере
> >> > > > >>> > > и
> >> > > > >>> > > > >> при
> >> > > > >>> > > > >> > > запуске
он начал автоматически
> >> > > > >>> > > > >> > >  определять
наличие еще серверов в сети, хотя
> никто
> >> > его
> >> > > об
> >> > > > >>> этом
> >> > > > >>> > не
> >> > > > >>> > > > >> просил
> >> > > > >>> > > > >> > > вначале
я тестовую версию с нуля поставил на
> >> сервер с
> >> > > > >>> адресом
> >> > > > >>> > > > >> > 192.168.1.4,
> >> > > > >>> > > > >> > > посмотрел
на версию, все нормально и выключил
> >> > > > >>> > > > >> > > опенмеетинг
командой red5-shutdown.sh
> >> > > > >>> > > > >> > > потом поставил
(с нуля) 4 версию на рабочий
> сервер
> >> > > > >>> 192,168,1,9 и
> >> > > > >>> > > > была
> >> > > > >>> > > > >> > > проблема
с видео описанная ранее.
> >> > > > >>> > > > >> > > и вот при
разборе логов нашел что он сам
> >> обнаруживает
> >> > > еще
> >> > > > >>> сервер
> >> > > > >>> > > 1.4
> >> > > > >>> > > > >> > > При этом
все кроме видео работает, точнее оно
> >> работает
> >> > > но
> >> > > > >>> только
> >> > > > >>> > > на
> >> > > > >>> > > > >> той
> >> > > > >>> > > > >> > > машине где
запущено.
> >> > > > >>> > > > >> > > думаю как-же
так он находит если на 1.4 все
> >> > > > >>> выключено(программа
> >> > > > >>> > я
> >> > > > >>> > > > имею
> >> > > > >>> > > > >> > > ввиду), оказалось
что на 1.4 остались ява
> процессы
> >> в
> >> > > > памяти.
> >> > > > >>> > > > >> > > после прибивания
их, 1,9 перестал обнаруживать
> 1,4
> >> и
> >> > > видео
> >> > > > >>> все
> >> > > > >>> > > > >> нормально
> >> > > > >>> > > > >> > > пошло.
> >> > > > >>> > > > >> > > буду тестировать
дальше.
> >> > > > >>> > > > >> > >
> >> > > > >>> > > > >> > > 11 ноября
2017 г., 9:46 пользователь Maxim
> >> Solodovnik
> >> > <
> >> > > > >>> > > > >> > > solomax666@gmail.com>
> >> > > > >>> > > > >> > > написал:
> >> > > > >>> > > > >> > >
> >> > > > >>> > > > >> > > > все эти
утилиты никак не влияют на передачу
> >> > > аудио/видео
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > > > в списке
камер и микрофонов пусто: про это уже
> >> давно
> >> > > > >>> разговоры
> >> > > > >>> > > > идут
> >> > > > >>> > > > >> > > > Политика
браузеров поменялась: нужно
> настраивать
> >> > HTTPS
> >> > > > для
> >> > > > >>> > того
> >> > > > >>> > > > >> чтобы
> >> > > > >>> > > > >> > > > камера/микрофон
были доступны
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > > > 2017-11-11
14:36 GMT+07:00 sergey sivun <
> >> > > > >>> neptun38@gmail.com>:
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > > > > Результат
ожидаемій т.к. на этом сервере не
> >> > > > установлено
> >> > > > >>> > > никаких
> >> > > > >>> > > > >> > > библиотек
> >> > > > >>> > > > >> > > > > которые
нужны для нормальной работы
> >> опенметинга в
> >> > > > >>> дальнейшем
> >> > > > >>> > > но
> >> > > > >>> > > > >> > которые
> >> > > > >>> > > > >> > > > > надо
будет потом ставить для импорта файлов и
> >> т.д,
> >> > > там
> >> > > > >>> даже
> >> > > > >>> > > > >> опенофиса
> >> > > > >>> > > > >> > > > нет.
> >> > > > >>> > > > >> > > > > На
боевом сервере ничего не менялось да и
> >> версия
> >> > > > 3.2.1.
> >> > > > >>> то
> >> > > > >>> > > > >> работает.
> >> > > > >>> > > > >> > > > > А скорее
всего на клиентах обновился адобе
> флеш
> >> > > плеер
> >> > > > и
> >> > > > >>> вот
> >> > > > >>> > > > новая
> >> > > > >>> > > > >> > > версия
> >> > > > >>> > > > >> > > > не
> >> > > > >>> > > > >> > > > > работает
с 3.3
> >> > > > >>> > > > >> > > > >
> >> > > > >>> > > > >> > > > > еще
проблема что броузеры или еще что стали
> >> > > > блокировать
> >> > > > >>> > видео,
> >> > > > >>> > > > >> > точнее в
> >> > > > >>> > > > >> > > > > окне
настроек в списке камер и микрофона
> пусто,
> >> > > сейчас
> >> > > > >>> вот
> >> > > > >>> > > > >> > > преподаватель
> >> > > > >>> > > > >> > > > > пытается
4 броузерами работать- пусто. ну это
> >> > > связано
> >> > > > >>> как я
> >> > > > >>> > > > понял
> >> > > > >>> > > > >> с
> >> > > > >>> > > > >> > > HTTPS
> >> > > > >>> > > > >> > > > > к сожалению
по той инструкции что давали не
> >> смог
> >> > > > понять
> >> > > > >>> как
> >> > > > >>> > > > НТТРS
> >> > > > >>> > > > >> > > > настроить
> >> > > > >>> > > > >> > > > > (тут
тоже поднимали вопрос насчет внятной
> >> > инструкции
> >> > > > >>> > > желательно
> >> > > > >>> > > > на
> >> > > > >>> > > > >> > > > русском)
> >> > > > >>> > > > >> > > > > но
эта проблема появилась не вчера а уже с
> пару
> >> > > > месяцев
> >> > > > >>> > назад
> >> > > > >>> > > > >> > > > >
> >> > > > >>> > > > >> > > > > попробую
на неделе помучать 4 версию до обеда
> >> > правда
> >> > > > >>> занятия
> >> > > > >>> > > > >> > постоянно
> >> > > > >>> > > > >> > > > >
> >> > > > >>> > > > >> > > > > 11 ноября
2017 г., 5:43 пользователь Maxim
> >> > > Solodovnik
> >> > > > <
> >> > > > >>> > > > >> > > > > solomax666@gmail.com>
> >> > > > >>> > > > >> > > > > написал:
> >> > > > >>> > > > >> > > > >
> >> > > > >>> > > > >> > > > > >
Ну вот, это ожидаемый результат :)
> >> > > > >>> > > > >> > > > > >
> >> > > > >>> > > > >> > > > > >
WBR, Maxim
> >> > > > >>> > > > >> > > > > >
(from mobile, sorry for the typos)
> >> > > > >>> > > > >> > > > > >
> >> > > > >>> > > > >> > > > > >
On Nov 11, 2017 01:28, "sergey sivun" <
> >> > > > >>> neptun38@gmail.com
> >> > > > >>> > >
> >> > > > >>> > > > >> wrote:
> >> > > > >>> > > > >> > > > > >
> >> > > > >>> > > > >> > > > > >
Сейчас попробовал по быстрому поставил 4.0
> >> > версию
> >> > > на
> >> > > > >>> > другой
> >> > > > >>> > > > >> сервер,
> >> > > > >>> > > > >> > > > > ничего
> >> > > > >>> > > > >> > > > > >
не настраивал, да и на сервере только
> самба,
> >> > видео
> >> > > > >>> общее в
> >> > > > >>> > > > >> комнате
> >> > > > >>> > > > >> > > есть
> >> > > > >>> > > > >> > > > > >
операционка и там и там Debian 8
> >> > > > >>> > > > >> > > > > >
> >> > > > >>> > > > >> > > > >
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > > > --
> >> > > > >>> > > > >> > > > WBR
> >> > > > >>> > > > >> > > > Maxim aka
solomax
> >> > > > >>> > > > >> > > >
> >> > > > >>> > > > >> > >
> >> > > > >>> > > > >> >
> >> > > > >>> > > > >> >
> >> > > > >>> > > > >> >
> >> > > > >>> > > > >> > --
> >> > > > >>> > > > >> > ---С уважением,
> >> > > > >>> > > > >> > специалист
технической поддержки ЦРЭОР МГУ, Юлия.
> >> > > > >>> > > > >> >
> >> > > > >>> > > > >>
> >> > > > >>> > > > >
> >> > > > >>> > > > >
> >> > > > >>> > > > >
> >> > > > >>> > > > > --
> >> > > > >>> > > > > ---С уважением,
> >> > > > >>> > > > > специалист технической
поддержки ЦРЭОР МГУ, Юлия.
> >> > > > >>> > > > >
> >> > > > >>> > > > >
> >> > > > >>> > > > >
> >> > > > >>> > > >
> >> > > > >>> > > >
> >> > > > >>> > > > --
> >> > > > >>> > > > ---С уважением,
> >> > > > >>> > > > специалист технической
поддержки ЦРЭОР МГУ, Юлия.
> >> > > > >>> > > >
> >> > > > >>> > >
> >> > > > >>> >
> >> > > > >>>
> >> > > > >>
> >> > > > >>
> >> > > > >>
> >> > > > >> --
> >> > > > >> WBR
> >> > > > >> Maxim aka solomax
> >> > > > >>
> >> > > > >
> >> > > > >
> >> > > > >
> >> > > > > --
> >> > > > > WBR
> >> > > > > Maxim aka solomax
> >> > > > >
> >> > > >
> >> > > >
> >> > > >
> >> > > > --
> >> > > > WBR
> >> > > > Maxim aka solomax
> >> > > >
> >> > >
> >> >
> >> >
> >> >
> >> > --
> >> > WBR
> >> > Maxim aka solomax
> >> >
> >>
> >
> >
> >
> > --
> > WBR
> > Maxim aka solomax
> >
>
>
>
> --
> WBR
> Maxim aka solomax
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message