openmeetings-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maxim Solodovnik <solomax...@gmail.com>
Subject Re: FFmpeg error on Ubuntu 17.04
Date Sat, 15 Apr 2017 16:50:57 GMT
Hello Alvaro,
I have updated my machine to 17.04 and previously compiled ffmpeg works as
expected
I'll try to re-compile it from sources and will let you know

On Sat, Apr 15, 2017 at 1:22 PM, Alvaro <zurcamos2@gmail.com> wrote:

> Hello Maxim,
>
> As you surely know, Ubuntu 17.04 final is launched.
> I've installed it to make the OM tutorial, but
> found an error when compile ffmpeg.
>
> FFmpeg script: ffmpeg-ubuntu-debian.sh
>
> ...run it and get this error:
>
>   -----------------
>   -----------------
>
> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.a(fwd_txfm_ssse3_x86_64.asm.o):
> relocation R_X86_64_32 against `.rodata' can not be used when making a
> shared object; recompile con -fPIC
> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.a(inv_txfm_ssse3_x86_64.asm.o):
> relocation R_X86_64_32 against `.rodata' can not be used when making a
> shared object; recompile con -fPIC
> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.a(quantize_ssse3_x86_64.asm.o):
> relocation R_X86_64_32 against `.rodata' can not be used when making a
> shared object; recompile con -fPIC
> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.a(subpel_variance_sse2.asm.o):
> relocation R_X86_64_32 against `.rodata' can not be used when making a
> shared object; recompile con -fPIC
> /usr/bin/ld: falló el enlace final: Sección no representable en la
> salida
> collect2: error: ld returned 1 exit status
> Makefile:136: fallo en las instrucciones para el objetivo 'ffmpeg_g'
> make: *** [ffmpeg_g] Error 1
> cp: no se puede efectuar `stat' sobre 'ffmpeg': No existe el archivo o
> el directorio
> cp: no se puede efectuar `stat' sobre 'ffprobe': No existe el archivo o
> el directorio
> cp: no se puede efectuar `stat' sobre 'ffserver': No existe el archivo o
> el directorio
> cp: no se puede efectuar `stat' sobre 'x264': No existe el archivo o el
> directorio
> FFmpeg Compilation is Finished!
>
>    -------------
>    -------------
>
> But, if i add --enable-shared to x264, fdk-aac, lame, opus, libvpx and
> ffmpeg, in the script, the compilation it is right, without any error.
> But the compiled files as ffmpeg, ffplay, etc, are not
> "application/x-executable" files, but "application/x-sharedlib".
>
> This is the same if compile sox, swftools, the compiled files are
> "application/x-sharedlib", without add --enable-shared, don't need it.
> It looks like the result of any compilation is "application/x-sharedlib"
> files.
>
> Have you an idea about how resolve this?
>
> Thanks
>
> Alvaro
>
>


-- 
WBR
Maxim aka solomax

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message