openmeetings-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alvaro <zurca...@gmail.com>
Subject Re: FFmpeg error on Ubuntu 17.04
Date Thu, 20 Apr 2017 09:27:21 GMT
Don't warry, Maxim. Will make a fresh installation on a
Pentium IV. To see if the hardware have any influence.

......

El jue, 20-04-2017 a las 15:57 +0700, Maxim Solodovnik escribió:
> Alvaro,
> 
> I don't know what might be wrong here
> I followed instructions, most packages were installed from apt-get
> others were compiled from sources
> 
> ffmpeg compiled successfully, runnable
> prints all options after execution
> 
> On Thu, Apr 20, 2017 at 3:38 PM, Alvaro <zurcamos@gmail.com> wrote:
> 
> > Well Maxim, i've installed ubuntu-17.04-server-amd64.iso
> > and get errors in the ffmpeg compilation.
> >
> > Is something strange, if i install sox from the repos,
> > the file /usr/bin/sox, also is a "application/x-sharedlib"
> > file, no a normal sox. The aspect it is different to the
> > sox file on Ubuntu 16.04 and others Linux distros, because
> > they are not "application/x-sharedlib" files.
> >
> > I think is something related with Ubuntu 17.04.
> >
> >
> > .................
> >
> >
> >
> >
> > El mié, 19-04-2017 a las 23:05 +0700, Maxim Solodovnik escribió:
> > > Hello Alvaro,
> > >
> > > just have downloaded Ubuntu 17.04 server ISO
> > > Was able to compile and run ffmpeg without any issues
> > >
> > > On Wed, Apr 19, 2017 at 7:54 PM, Maxim Solodovnik <solomax666@gmail.com>
> > > wrote:
> > >
> > > > The machine was updated from 16.10
> > > > will try to set up fresh Ubuntu
> > > > will take some time
> > > >
> > > > On Wed, Apr 19, 2017 at 5:45 PM, Alvaro <zurcamos@gmail.com> wrote:
> > > >
> > > >> ...do you compile ffmpeg on a fresh Ubuntu
> > > >> 17.04 installation or on a dist-upgrade?
> > > >>
> > > >> Following the actual web-guide:
> > > >>
> > > >> https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu
> > > >>
> > > >> ...i get errors.
> > > >> The only way for me to compile rightly is like i told
> > > >> you about "--enable-shared". On this way when make a
> > > >> recording, result a .flv file in /.../streams/2 (for example),
> > > >> but give an error to convert it to mp4.
> > > >>
> > > >> If i copy from Ubuntu 16.04 (/usr/local/bin) the nine
> > > >> files, product of ffmpeg compilation, and put them in
> > > >> Ubuntu 17.04 (/usr/local/bin), then the recordings
> > > >> made it works right, without errors.
> > > >>
> > > >> I've installed two diferents iso of Ubuntu 17.04:
> > > >>
> > > >> ubuntu-mate-17.04-desktop-amd64.iso
> > > >>
> > > >> ...and
> > > >>
> > > >> ubuntu-17.04-desktop-amd64.iso
> > > >>
> > > >> ...and got the same errors on both.
> > > >>
> > > >> Attached two captures and a log.
> > > >>
> > > >> Can't make the tutorial until it is solved.
> > > >>
> > > >> Some more idea...?
> > > >>
> > > >>
> > > >> ................
> > > >>
> > > >>
> > > >>
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> El mié, 19-04-2017 a las 00:22 +0700, Maxim Solodovnik escribió:
> > > >> > Hello Alvaro,
> > > >> >
> > > >> > Just have tried to recompile using this:
> > > >> > https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu guide
> > > >> >
> > > >> > works for me as expected
> > > >> >
> > > >> > On Sat, Apr 15, 2017 at 11:50 PM, Maxim Solodovnik <
> > > >> solomax666@gmail.com>
> > > >> > wrote:
> > > >> >
> > > >> > > Hello Alvaro,
> > > >> > > I have updated my machine to 17.04 and previously compiled
ffmpeg
> > > >> works as
> > > >> > > expected
> > > >> > > I'll try to re-compile it from sources and will let you
know
> > > >> > >
> > > >> > > On Sat, Apr 15, 2017 at 1:22 PM, Alvaro <zurcamos2@gmail.com>
> > wrote:
> > > >> > >
> > > >> > >> Hello Maxim,
> > > >> > >>
> > > >> > >> As you surely know, Ubuntu 17.04 final is launched.
> > > >> > >> I've installed it to make the OM tutorial, but
> > > >> > >> found an error when compile ffmpeg.
> > > >> > >>
> > > >> > >> FFmpeg script: ffmpeg-ubuntu-debian.sh
> > > >> > >>
> > > >> > >> ...run it and get this error:
> > > >> > >>
> > > >> > >>   -----------------
> > > >> > >>   -----------------
> > > >> > >>
> > > >> > >> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.
> > > >> a(fwd_txfm_ssse3_x86_64.asm.o):
> > > >> > >> relocation R_X86_64_32 against `.rodata' can not be
used when
> > making
> > > >> a
> > > >> > >> shared object; recompile con -fPIC
> > > >> > >> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.
> > > >> a(inv_txfm_ssse3_x86_64.asm.o):
> > > >> > >> relocation R_X86_64_32 against `.rodata' can not be
used when
> > making
> > > >> a
> > > >> > >> shared object; recompile con -fPIC
> > > >> > >> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.
> > > >> a(quantize_ssse3_x86_64.asm.o):
> > > >> > >> relocation R_X86_64_32 against `.rodata' can not be
used when
> > making
> > > >> a
> > > >> > >> shared object; recompile con -fPIC
> > > >> > >> /usr/bin/ld: /root/ffmpeg_build/lib/libvpx.
> > > >> a(subpel_variance_sse2.asm.o):
> > > >> > >> relocation R_X86_64_32 against `.rodata' can not be
used when
> > making
> > > >> a
> > > >> > >> shared object; recompile con -fPIC
> > > >> > >> /usr/bin/ld: falló el enlace final: Sección no representable
en
> > la
> > > >> > >> salida
> > > >> > >> collect2: error: ld returned 1 exit status
> > > >> > >> Makefile:136: fallo en las instrucciones para el objetivo
> > 'ffmpeg_g'
> > > >> > >> make: *** [ffmpeg_g] Error 1
> > > >> > >> cp: no se puede efectuar `stat' sobre 'ffmpeg': No existe
el
> > archivo
> > > >> o
> > > >> > >> el directorio
> > > >> > >> cp: no se puede efectuar `stat' sobre 'ffprobe': No
existe el
> > > >> archivo o
> > > >> > >> el directorio
> > > >> > >> cp: no se puede efectuar `stat' sobre 'ffserver': No
existe el
> > > >> archivo o
> > > >> > >> el directorio
> > > >> > >> cp: no se puede efectuar `stat' sobre 'x264': No existe
el
> > archivo o
> > > >> el
> > > >> > >> directorio
> > > >> > >> FFmpeg Compilation is Finished!
> > > >> > >>
> > > >> > >>    -------------
> > > >> > >>    -------------
> > > >> > >>
> > > >> > >> But, if i add --enable-shared to x264, fdk-aac, lame,
opus,
> > libvpx
> > > >> and
> > > >> > >> ffmpeg, in the script, the compilation it is right,
without any
> > > >> error.
> > > >> > >> But the compiled files as ffmpeg, ffplay, etc, are not
> > > >> > >> "application/x-executable" files, but "application/x-sharedlib".
> > > >> > >>
> > > >> > >> This is the same if compile sox, swftools, the compiled
files are
> > > >> > >> "application/x-sharedlib", without add --enable-shared,
don't
> > need
> > > >> it.
> > > >> > >> It looks like the result of any compilation is
> > > >> "application/x-sharedlib"
> > > >> > >> files.
> > > >> > >>
> > > >> > >> Have you an idea about how resolve this?
> > > >> > >>
> > > >> > >> Thanks
> > > >> > >>
> > > >> > >> Alvaro
> > > >> > >>
> > > >> > >>
> > > >> > >
> > > >> > >
> > > >> > > --
> > > >> > > WBR
> > > >> > > Maxim aka solomax
> > > >> > >
> > > >> >
> > > >> >
> > > >> >
> > > >>
> > > >>
> > > >
> > > >
> > > > --
> > > > WBR
> > > > Maxim aka solomax
> > > >
> > >
> > >
> > >
> >
> >
> >
> 
> 



Mime
View raw message