openmeetings-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry Zamula <club.brant...@gmail.com>
Subject Re: Fix build process bug
Date Fri, 13 Apr 2012 08:02:12 GMT
Yes, but now in ${dist.persistence.dir} I already have a persistence.xml.
And MappingToolTask ​​does not see it.

2012/4/13 Maxim Solodovnik <solomax666@gmail.com>

> Persistence.xml is copied to its location by one of the ant tasks. You need
> to add dependency to this task (have no sources right now, can tell exact
> task name later today)
>  On Apr 13, 2012 2:23 PM, "Dmitry Zamula" <club.brantner@gmail.com> wrote:
>
> > Hello!
> >
> > I want to fix bug - after a few builds of the system, there is a
> > duplicate information in database(in particular, this affects the
> interface
> > - double buttons, menus, etc.). I wrote new target in build.xml:
> >
> > <target name="refresh">
> >    <taskdef name="tablerefresh"
> > classname="org.apache.openjpa.jdbc.ant.MappingToolTask">
> >      <classpath refid="jpa.enhancement.classpath" />
> >    </taskdef>
> >    <tablerefresh schemaAction="refresh">
> >      <config propertiesFile="${dist.persistence.dir}/persistence.xml" />
> >    </tablerefresh>
> >    <echo message="Table refreshing complete." />
> > </target>
> >
> > But, MappingToolTask cant find persistence.xml (Error: A connection could
> > not be obtained for driver class
> "org.apache.commons.dbcp.BasicDataSource"
> > and URL "null").
> > Does anyone have any ideas why this is happening?
> >
>



-- 
_________________________________________________________

С уважением,

Замула Дмитрий

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message