openmeetings-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "seba.wagner@gmail.com" <seba.wag...@gmail.com>
Subject Re: Which files to replace
Date Sat, 14 Apr 2012 06:42:23 GMT
Could you have a look at what is as date/time in the field
appointment_starttime
appointment_endtime

In the database? This date/time has NO timezone info. It is on the local
timezone of the machine.

Sebastian

2012/4/13 Naveed Nazir <naveed_nazir@yahoo.com>

> Hello Sebastian,
> I used the svn head from 10 days ago and used the build file that came
> with it.
> My problem is similar to the problem that Maxim is reporting in the emails
> "Testing new Calendar UI in Your timezone"
>
> The problem is reproducible. I am located in EDT (GMT-4) and the server is
> located in PDT (GMT-7). Profiles have the correct entries in the
> configuration. This is what happens when I schedule a meeting for April 17
> at 12:00 EDT (noon) it shows up in my calendar on April 16 at 09:00 (EDT).
>
> Here is an excerpt from jvm.stdout
> DEBUG 04-13 09:08:32.073 CalendarService.java 43228848 131
> org.openmeetings.app.remote.CalendarService [NioProcessor-3] -
> saveAppointMent users_id:2
> DEBUG 04-13 09:08:32.077 OpenXGHttpClient.java 43228852 318
> org.openmeetings.app.sip.xmlrpc.OpenXGHttpClient [NioProcessor-3] - SIP is
> disabled
> DEBUG 04-13 09:08:32.122 Roommanagement.java 43228897 232
> org.openmeetings.app.data.conference.Roommanagement [NioProcessor-3] -
> getRoombyId : 50
> DEBUG 04-13 09:08:32.125 Usermanagement.java 43228900 1473
> org.openmeetings.app.data.user.Usermanagement [NioProcessor-3] -
> Usermanagement.getUserById
> DEBUG 04-13 09:08:32.131 AppointmentDaoImpl.java 43228906 218
> org.openmeetings.app.data.calendar.daos.AppointmentDaoImpl [NioProcessor-3]
> - addAppointment appointmentstart :1: 16.04.2012 06:00:00 PDT (-0700)
> DEBUG 04-13 09:08:32.131 AppointmentDaoImpl.java 43228906 221
> org.openmeetings.app.data.calendar.daos.AppointmentDaoImpl [NioProcessor-3]
> - addAppointment appointmentend :1: 16.04.2012 07:00:00 PDT (-0700)
> DEBUG 04-13 09:08:32.132 AppointmentReminderTypDaoImpl.java 43228907 51
> org.openmeetings.app.data.calendar.daos.AppointmentReminderTypDaoImpl
> [NioProcessor-3] - AppointmentReminderTypById: 3
> DEBUG 04-13 09:08:32.133 AppointmentCategoryDaoImpl.java 43228908 52
> org.openmeetings.app.data.basic.Configurationmanagement [NioProcessor-3] -
> getAppointmentCategoryById: 1
> DEBUG 04-13 09:08:32.352 MeetingMemberLogic.java 43229127 319
> org.openmeetings.app.data.calendar.management.MeetingMemberLogic
> [NioProcessor-3] - getMemberById
> DEBUG 04-13 09:08:32.353 MeetingMemberDaoImpl.java 43229128 52
> org.openmeetings.app.data.calendar.daos.MeetingMemberDaoImpl
> [NioProcessor-3] - getMeetingMemberById: 66
> DEBUG 04-13 09:08:32.379 MeetingMemberLogic.java 43229154 108
> org.openmeetings.app.data.calendar.management.MeetingMemberLogic
> [NioProcessor-3] - :::: addMeetingMember ..... 3
> DEBUG 04-13 09:08:32.383 MeetingMemberLogic.java 43229158 147
> org.openmeetings.app.data.calendar.management.MeetingMemberLogic
> [NioProcessor-3] - Reminder for Appointment : iCal mail
> ### SENDING iCAL EMAIL
>
> Notice that what ever shows as appointment time in the server is the time
> the meeting gets scheduled for.
>
> I added an instrumentation line just below the first line in the log
> above, but it is not showing up. I want to trace / debug as to where the
> shift is coming from. Please help.
>
> Thanks
> Naveed
>
>
>
>
>
> ________________________________
>  From: "seba.wagner@gmail.com" <seba.wagner@gmail.com>
> To: openmeetings-dev@incubator.apache.org; Naveed Nazir <
> naveed_nazir@yahoo.com>
> Sent: Friday, April 13, 2012 3:50 AM
> Subject: Re: Which files to replace
>
> Hallo Naveed,
>
> can you please tell us which version of OpenMeetings you are using?
>
> Sebastian
>
> 2012/4/13 Naveed Nazir <naveed_nazir@yahoo.com>
>
> > My openmeetings install is working but not showing proper times in the
> > invitations. Times are shifting back by 27 hours. To understand the
> > problem I have added some instrumentation code to a file and rebuilt the
> > openmeetings with ant. I replaced the three jars in the /opt/red5 folder
> > with the new jars from dist folder, but my changes are not showing up.
> > Which files do I need to replace?
> >
> > Any idea on where to look for the time shift problem.
> >
> > Thanks
> > Naveed
> >
>
>
>
> --
> Sebastian Wagner
> https://twitter.com/#!/dead_lock
> http://www.openmeetings.de
> http://www.webbase-design.de
> http://www.wagner-sebastian.com
> seba.wagner@gmail.com
>



-- 
Sebastian Wagner
https://twitter.com/#!/dead_lock
http://www.openmeetings.de
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wagner@gmail.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message