openmeetings-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "seba.wagner@gmail.com" <seba.wag...@gmail.com>
Subject Re: deploying multiple openmeetings instances into a single red5
Date Sat, 18 Feb 2012 10:11:48 GMT
yes but the beans in red5-service.xml I know for sure that those cannot be
the problem, as this just has been working in previous versions of
openmeetings/red5.

Sebastian

2012/2/18 Maxim Solodovnik <solomax666@gmail.com>

> Those defined in openmeetings-applicationContext.xml
> and various services definitions (from red5-services/*xml)
>
> On Sat, Feb 18, 2012 at 17:02, seba.wagner@gmail.com <
> seba.wagner@gmail.com> wrote:
>
>> I think those names should only be unique inside the webapp's context.
>> I mean Red5 does also natively use beans, spring et cetera. But it was
>> possible to deploy multiple webapps into a single red5 container just like
>> any other tomcat webapp.
>> Each webapp had its own scope and RTMP-Endpoint.
>>
>> Which ejb's do you mean exactly?
>>
>> Sebastian
>>
>>
>> 2012/2/18 Maxim Solodovnik <solomax666@gmail.com>
>>
>>> Hello Sebastian,
>>>
>>> I guess the cause of might be in the same ejb names.
>>> If I'm not mistaken all beans need to have unique names (some names are
>>> hardcoded in java files so it might be challenging task...).
>>>
>>> I can investigate.
>>>
>>> On Sat, Feb 18, 2012 at 16:51, seba.wagner@gmail.com <
>>> seba.wagner@gmail.com> wrote:
>>>
>>>> Hi Maxim,
>>>>
>>>> in the past it was possible to deploy OpenMeetings (under a different
>>>> webapp name of course) multiple times in the same Red5 container.
>>>>
>>>> Somehow this stopped working, I wonder why?
>>>> The effect with OpenMeetings 1.9.1 is:
>>>> If you deploy two instances of the openmeetings webapp into red5, the
>>>> first one works as epxected, the second one, you are able to run the
>>>> installer but after that the SWF just won't be able to connect via RTMP.
>>>> Do you got an idea if your webapp renaming / dynamic context loader has
>>>> something todo with it?
>>>> I think the log files are produced correctly, so each instance has its
>>>> own log, but I cannot remember 100% now, I will have to check that again.
>>>> Maybe I should also do that test again with the latest updated red5 now.
>>>>
>>>> Thanks,
>>>> Sebastian
>>>>
>>>> --
>>>> Sebastian Wagner
>>>> http://www.openmeetings.de
>>>> http://incubator.apache.org/openmeetings/
>>>> http://www.webbase-design.de
>>>> http://www.wagner-sebastian.com
>>>> seba.wagner@gmail.com
>>>>
>>>
>>>
>>>
>>> --
>>> WBR
>>> Maxim aka solomax
>>>
>>
>>
>>
>> --
>> Sebastian Wagner
>> http://www.openmeetings.de
>> http://incubator.apache.org/openmeetings/
>> http://www.webbase-design.de
>> http://www.wagner-sebastian.com
>> seba.wagner@gmail.com
>>
>
>
>
> --
> WBR
> Maxim aka solomax
>



-- 
Sebastian Wagner
http://www.openmeetings.de
http://incubator.apache.org/openmeetings/
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wagner@gmail.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message