openmeetings-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maxim Solodovnik (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (OPENMEETINGS-1879) ffmpeg-ubuntu-debian.sh - some package install failed
Date Tue, 22 May 2018 04:07:00 GMT

     [ https://issues.apache.org/jira/browse/OPENMEETINGS-1879?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Maxim Solodovnik resolved OPENMEETINGS-1879.
--------------------------------------------
    Resolution: Cannot Reproduce

 NREP :(

please reopen with additional steps required to reproduce this

> ffmpeg-ubuntu-debian.sh - some package install failed
> -----------------------------------------------------
>
>                 Key: OPENMEETINGS-1879
>                 URL: https://issues.apache.org/jira/browse/OPENMEETINGS-1879
>             Project: Openmeetings
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 4.0.3
>            Reporter: Leonid
>            Assignee: Maxim Solodovnik
>            Priority: Minor
>
> h1. *1. Package libx265-dev*
> Remove *libx265-dev* from this line in script:
> {code:java}
> sudo apt-get -y --force-yes install autoconf automake build-essential libass-dev libfreetype6-dev
libsdl1.2-dev libtheora-dev libtool libva-dev libvdpau-dev libvorbis-dev libxcb1-dev libxcb-shm0-dev
libxcb-xfixes0-dev pkg-config texi2html zlib1g-dev mercurial cmake libx264-dev libx265-dev
libfdk-aac-dev libmp3lame-dev{code}
>  
> When running *./ffmpeg-ubuntu-debian.sh* this command failed. It's because of *libx265-dev* can't
be located:
>  
> {code:java}
> E: Unable to locate package libx265-dev{code}
>  
> Some lines below there are commands to download, compile and install *libx265-dev.*
>  
> {code:java}
> hg clone https://bitbucket.org/multicoreware/x265
> wget -O fdk-aac.tar.gz https://github.com/mstorsjo/fdk-aac/tarball/master
> cd x265/build/linux
> PATH="$HOME/bin:$PATH" cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX="$HOME/ffmpeg_build"
-DENABLE_SHARED:bool=off ../../source && make && sudo make install &&
make distclean; cd ~/ffmpeg_sources
> {code}
> Link to *ffmpeg-ubuntu-debian.sh -[https://cwiki.apache.org/confluence/download/attachments/27838216/ffmpeg-ubuntu-debian.sh]*
> Original installation notes of *libx265-dev* can be found here - [https://bitbucket.org/multicoreware/x265/wiki/Home]
> h1. *2. Compilation of x264*
> *Add* assembler installation line:
>  
> {code:java}
> wget http://www.nasm.us/pub/nasm/releasebuilds/2.13.03/nasm-2.13.03.tar.xz
> tar -xvf nasm-2.13.03.tar.xz
> cd nasm-2.13.03
> ./configure
> sudo make
> sudo make install
> cd ..
> {code}
>  
> When running:
> {code:java}
> cd x264-*/
> PATH="$HOME/bin:$PATH" ./configure --prefix="$HOME/ffmpeg_build" --bindir="$HOME/bin"
--enable-static --disable-opencl && PATH="$HOME/bin:$PATH" make && sudo make
install && make distclean; cd ..
> {code}
> I'm getting an error *found no assembler*:
> {code:java}
> Found no assembler
> Minimum version is nasm-2.13
> If you really want to compile without asm, configure with --disable-asm.
> {code}
> Original installation notes of *assembler install* can be found here -  http://www.sthshare.com/wordpress/found-no-assembler-minimum-version-is-nasm-2-13.html



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message